aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 20:17:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 20:17:47 +0000
commit56c005aae1f9ff4efbc95b18b5df01849da726b8 (patch)
tree9dd838edc36f6fcb90226ddf0babc2c777058ca8
parent9b9f2251a6ef86b1544c4ba545247cd7ea1f26bf (diff)
downloadports-56c005aae1f9ff4efbc95b18b5df01849da726b8.tar.gz
ports-56c005aae1f9ff4efbc95b18b5df01849da726b8.zip
Notes
-rw-r--r--devel/xparam/Makefile9
-rw-r--r--devel/xparam/distinfo2
-rw-r--r--devel/xparam/files/patch-Makefile.in22
-rw-r--r--devel/xparam/files/patch-examples::calculator::Makefile.in15
-rw-r--r--devel/xparam/files/patch-examples::involved::Makefile.in15
-rw-r--r--devel/xparam/files/patch-lib::Makefile.in19
-rw-r--r--devel/xparam/files/patch-lib::sources::xpv_dynamic_loader.cpp (renamed from devel/xparam/files/patch-lib_sources_xpv__dynamic__loader.cpp)7
-rw-r--r--devel/xparam/pkg-plist21
8 files changed, 96 insertions, 14 deletions
diff --git a/devel/xparam/Makefile b/devel/xparam/Makefile
index d824d023f6b7..aa5c03f1b260 100644
--- a/devel/xparam/Makefile
+++ b/devel/xparam/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= xparam
-PORTVERSION= 1.11
+PORTVERSION= 1.21
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,13 +16,8 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-dynamic
USE_GMAKE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,-ldl,,g" ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/xparam/distinfo b/devel/xparam/distinfo
index 31e02f8b0e2a..e20c801f4a57 100644
--- a/devel/xparam/distinfo
+++ b/devel/xparam/distinfo
@@ -1 +1 @@
-MD5 (xparam-1.11.tar.gz) = 0cdfe0b51160af2565b6279a26569743
+MD5 (xparam-1.21.tar.gz) = 99663ae50810fe4707b7acb453af3db4
diff --git a/devel/xparam/files/patch-Makefile.in b/devel/xparam/files/patch-Makefile.in
new file mode 100644
index 000000000000..b23aa94a9e06
--- /dev/null
+++ b/devel/xparam/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig Sat Nov 16 01:29:46 2002
++++ Makefile.in Sat Dec 21 14:09:19 2002
+@@ -52,17 +52,11 @@
+ prepare_check :
+ -$(MAKE) -C tests prepare
+
+-ifeq (x$(DESTDIR),x)
+-install_command = (@LDCONFIG@ $(libdir) || true) >/dev/null 2>&1
+-else
+-install_command = echo @LDCONFIG@ not run. You may need to execute \"@LDCONFIG@ $(libdir)\" after installation in $(libdir).
+-endif
+-
+-install : $(LIBNAME) installinfo
++install : $(LIBNAME)
+ $(INSTALL) -d $(DESTDIR)$(libdir)
+ $(INSTALL) -d $(DESTDIR)$(includedir)
+ $(INSTALL) -d $(DESTDIR)$(priv_includedir)
+- libtool $(INSTALL_PROGRAM) $(LIBNAME) $(DESTDIR)$(libdir)
++ libtool --mode=install $(INSTALL_PROGRAM) $(LIBNAME) $(DESTDIR)$(libdir)
+ $(INSTALL_DATA) $(XPARAM_PUBLIC_INCLUDE_FILES) $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(XPARAM_INCLUDE_FILES) $(DESTDIR)$(priv_includedir)
+ $(install_command)
diff --git a/devel/xparam/files/patch-examples::calculator::Makefile.in b/devel/xparam/files/patch-examples::calculator::Makefile.in
new file mode 100644
index 000000000000..c9ce136e45fe
--- /dev/null
+++ b/devel/xparam/files/patch-examples::calculator::Makefile.in
@@ -0,0 +1,15 @@
+--- examples/calculator/Makefile.in.orig Sat Oct 26 09:45:35 2002
++++ examples/calculator/Makefile.in Sat Dec 21 14:10:40 2002
+@@ -17,10 +17,10 @@
+ $(CXX) -c -o $@ $<
+
+ sobj/mathfunc.so : $(SLOBJECTS)
+- libtool $(CXX) -shared $^ -lxparam -o $@
++ libtool --mode=link $(CXX) -shared $^ -lxparam -o $@
+
+ $(SLOBJECTS) : obj/%.lo : src/%.cpp include/mathfunc.h include/functions.h
+- libtool $(CXX) -c -o $@ $<
++ libtool --mode=compile $(CXX) -c -o $@ $<
+
+ clean :
+ -rm -f $(TARGETS) $(OBJECTS) $(SOBJECTS) $(SLOBJECTS)
diff --git a/devel/xparam/files/patch-examples::involved::Makefile.in b/devel/xparam/files/patch-examples::involved::Makefile.in
new file mode 100644
index 000000000000..91adf7e6ebaf
--- /dev/null
+++ b/devel/xparam/files/patch-examples::involved::Makefile.in
@@ -0,0 +1,15 @@
+--- examples/involved/Makefile.in.orig Sat Oct 26 09:45:35 2002
++++ examples/involved/Makefile.in Sat Dec 21 14:11:44 2002
+@@ -20,10 +20,10 @@
+ $(CXX) -c -o $@ $<
+
+ sobj/circle.so : $(SLOBJECTS)
+- libtool $(CXX) -shared $^ -lxparam -o $@
++ libtool --mode=link $(CXX) -shared $^ -lxparam -o $@
+
+ $(SLOBJECTS) : obj/%.lo : src/%.cpp include/circle.h include/shapes.h
+- libtool $(CXX) -c -o $@ $<
++ libtool --mode=compile $(CXX) -c -o $@ $<
+
+ clean :
+ -rm -f $(TARGETS) $(OBJECTS) $(SOBJECTS) $(SLOBJECTS)
diff --git a/devel/xparam/files/patch-lib::Makefile.in b/devel/xparam/files/patch-lib::Makefile.in
new file mode 100644
index 000000000000..96e953675a6d
--- /dev/null
+++ b/devel/xparam/files/patch-lib::Makefile.in
@@ -0,0 +1,19 @@
+--- lib/Makefile.in.orig Sat Oct 26 09:45:35 2002
++++ lib/Makefile.in Sat Dec 21 14:06:47 2002
+@@ -36,13 +36,13 @@
+ -rm -rf $(XPARAM_OBJ_PATH)/.libs $(ANTLR_OBJ_PATH)/.libs
+
+ $(XPARAM_LOBJ_FILES) : $(XPARAM_OBJ_PATH)/%.lo : $(XPARAM_SRC_PATH)/%.cpp Makefile
+- libtool @CXX@ @CXXFLAGS@ @CPPFLAGS@ -I$(ANTLR_INCLUDE_PATH) -c -o $@ $<
++ libtool --mode=compile @CXX@ @CXXFLAGS@ @CPPFLAGS@ -I$(ANTLR_INCLUDE_PATH) -c -o $@ $<
+
+ $(ANTLR_LOBJ_FILES) : $(ANTLR_OBJ_PATH)/%.lo : $(ANTLR_SRC_PATH)/%.cpp
+- libtool @CXX@ @CXXFLAGS@ @CPPFLAGS@ -I$(ANTLR_INCLUDE_PATH) -c -o $@ $<
++ libtool --mode=compile @CXX@ @CXXFLAGS@ @CPPFLAGS@ -I$(ANTLR_INCLUDE_PATH) -c -o $@ $<
+
+ $(LIBRARY) : $(ALL_LOBJ_FILES)
+- libtool @CXX@ @LDFLAGS@ -o $(LIBRARY) $(ALL_LOBJ_FILES) @LIBS@ -rpath $(libdir) -version-info 1:0:0
++ libtool --mode=link @CXX@ @LDFLAGS@ -o $(LIBRARY) $(ALL_LOBJ_FILES) @LIBS@ -rpath $(libdir) -version-info 1:0:0
+
+ .PHONY : all clean
+
diff --git a/devel/xparam/files/patch-lib_sources_xpv__dynamic__loader.cpp b/devel/xparam/files/patch-lib::sources::xpv_dynamic_loader.cpp
index 537cd2f10be0..2c1ba9aee6b1 100644
--- a/devel/xparam/files/patch-lib_sources_xpv__dynamic__loader.cpp
+++ b/devel/xparam/files/patch-lib::sources::xpv_dynamic_loader.cpp
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- lib/sources/xpv_dynamic_loader.cpp.orig Sun Dec 22 17:50:59 2002
-+++ lib/sources/xpv_dynamic_loader.cpp Sun Dec 22 17:51:18 2002
+--- lib/sources/xpv_dynamic_loader.cpp.orig Sun Nov 25 03:43:26 2001
++++ lib/sources/xpv_dynamic_loader.cpp Sat Dec 28 10:59:43 2002
@@ -209,7 +209,7 @@
loader.load(type_name);
}
diff --git a/devel/xparam/pkg-plist b/devel/xparam/pkg-plist
index 951473da9009..1bf96086864d 100644
--- a/devel/xparam/pkg-plist
+++ b/devel/xparam/pkg-plist
@@ -1,15 +1,20 @@
include/xparam/xp_config.h
include/xparam/xp_error.h
include/xparam/xp_handle.h
+include/xparam/xp_hvl.h
include/xparam/xp_loader.h
include/xparam/xp_param.h
include/xparam/xp_param_imp.h
include/xparam/xp_paramset.h
include/xparam/xp_paramset_manip.h
+include/xparam/xp_parsed_types.h
+include/xparam/xp_parser.h
include/xparam/xp_saver.h
include/xparam/xp_singleton.h
include/xparam/xp_type_compare.h
include/xparam/xp_type_tag.h
+include/xparam/xp_typed_tuple.h
+include/xparam/xp_typed_value_map.h
include/xparam/xp_user_namespace.h
include/xparam/xp_value.h
include/xparam/xp_value_list.h
@@ -19,6 +24,7 @@ include/xparam/xp_value_sink.h
include/xparam/xp_value_sink_imp.h
include/xparam/xp_value_source.h
include/xparam/xp_value_source_imp.h
+include/xparam/xp_value_tuple.h
include/xparam/xparam.h
include/xparam/xparam_extend.h
include/xparam/xpv_arg_def.h
@@ -37,6 +43,9 @@ include/xparam/xpv_dtor_imp.h
include/xparam/xpv_enum_registry.h
include/xparam/xpv_extend_namespace.h
include/xparam/xpv_facade_imp.h
+include/xparam/xpv_hvl_creator.h
+include/xparam/xpv_hvl_creator_imp.h
+include/xparam/xpv_hvl_registry.h
include/xparam/xpv_iconv.h
include/xparam/xpv_iconv_imp.h
include/xparam/xpv_output.h
@@ -47,9 +56,16 @@ include/xparam/xpv_reg_conversion.h
include/xparam/xpv_reg_ctor.h
include/xparam/xpv_reg_ctor_imp.h
include/xparam/xpv_reg_enum.h
+include/xparam/xpv_reg_hvl.h
include/xparam/xpv_reg_inheritance.h
+include/xparam/xpv_reg_list.h
include/xparam/xpv_reg_macros.h
+include/xparam/xpv_reg_map.h
include/xparam/xpv_reg_output.h
+include/xparam/xpv_reg_pair.h
+include/xparam/xpv_reg_set.h
+include/xparam/xpv_reg_typed_tuple.h
+include/xparam/xpv_reg_typed_value_map.h
include/xparam/xpv_reg_vector.h
include/xparam/xpv_regcom.h
include/xparam/xpv_registry.h
@@ -57,6 +73,9 @@ include/xparam/xpv_scheduler.h
include/xparam/xpv_subobject_output.h
include/xparam/xpv_template_fooler.h
include/xparam/xpv_type.h
+include/xparam/xpv_typed_tuple_creator.h
+include/xparam/xpv_typed_tuple_creator_imp.h
+include/xparam/xpv_typed_tuple_registry.h
include/xparam/xpv_untyped_null.h
include/xparam/xpv_value_imp.h
include/xparam.h
@@ -64,5 +83,5 @@ include/xparam_extend.h
lib/libxparam.a
lib/libxparam.la
lib/libxparam.so
-lib/libxparam.so.0
+lib/libxparam.so.1
@dirrm include/xparam