aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 07:15:33 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-19 07:15:33 +0000
commit6651d9e9f28e81a78469e463b020744fb5357a9c (patch)
treec594de27aa25b9c6241161b72c03172eba24f700
parent779e11504a382a338f5baec3700a5ece63ba0b50 (diff)
downloadports-6651d9e9f28e81a78469e463b020744fb5357a9c.tar.gz
ports-6651d9e9f28e81a78469e463b020744fb5357a9c.zip
Notes
-rw-r--r--math/mtl/Makefile7
-rw-r--r--math/mtl/files/patch-mtl__Makefile.in17
2 files changed, 20 insertions, 4 deletions
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
index 258f2946804e..7eace15b6409 100644
--- a/math/mtl/Makefile
+++ b/math/mtl/Makefile
@@ -22,7 +22,6 @@ USES= perl5
USE_PERL5= build
WRKSRC = ${WRKDIR}/${DISTNAME:R}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/gnu\*)/,/;;/{/CXX=/d; /CXX_OPTIMIZE_FLAGS=/d; \
s/CXXFLAGS="/&$$ac_cv_env_CXXFLAGS_value /; }' \
@@ -49,9 +48,9 @@ CXXFLAGS+= -fpermissive
PORTEXAMPLES= *
post-install:
- @${MKDIR} ${EXAMPLESDIR}/doubledouble
- @${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${EXAMPLESDIR}/doubledouble
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/doubledouble
+ @${INSTALL_DATA} ${WRKSRC}/contrib/examples/* ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/contrib/doubledouble/* ${STAGEDIR}${EXAMPLESDIR}/doubledouble
.endif
.include <bsd.port.post.mk>
diff --git a/math/mtl/files/patch-mtl__Makefile.in b/math/mtl/files/patch-mtl__Makefile.in
new file mode 100644
index 000000000000..666c8f4724b4
--- /dev/null
+++ b/math/mtl/files/patch-mtl__Makefile.in
@@ -0,0 +1,17 @@
+--- mtl/Makefile.in.orig 2014-06-19 15:12:46.890432000 +0800
++++ mtl/Makefile.in 2014-06-19 15:13:23.850278020 +0800
+@@ -454,11 +454,11 @@ uninstall-am: uninstall-info-am
+
+
+ make-install-dirs:
+- -if test '!' -d $(includedir); then mkdir -p $(includedir); fi
++ -if test '!' -d $(DESTDIR)$(includedir); then mkdir -p $(DESTDIR)$(includedir); fi
+
+ install-data-hook: make-install-dirs
+- -@ echo Installing $(includedir) ; \
+- $(INSTALL_DATA) *.h $(includedir)
++ -@ echo Installing $(DESTDIR)$(includedir) ; \
++ $(INSTALL_DATA) *.h $(DESTDIR)$(includedir)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: