aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-10-04 02:42:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-10-04 02:42:24 +0000
commit7dc3025cf6396ef0ba02af420257044831395d47 (patch)
tree026fdd67bd4e3c4a74e0abd1197d28d1f6bf655e
parent6d63967e4d5d8455cb8cb3163e98a35e831f03d6 (diff)
downloadports-7dc3025cf6396ef0ba02af420257044831395d47.tar.gz
ports-7dc3025cf6396ef0ba02af420257044831395d47.zip
Notes
-rw-r--r--net-im/centericq/Makefile8
-rw-r--r--net/centericq/Makefile8
2 files changed, 16 insertions, 0 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index cf9292455416..b2813d818b36 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -34,6 +34,7 @@ OPTIONS= NLS "Native Language Support" on \
AIM "Support for AOL's Instant Messenger Protocol" off \
IRC "Support for IRC Protocol" off \
JABBER "Support for Jabber Protocol" off \
+ GPGME "Support for PGP encrypted Jabber messages" on \
RSS "Support for RSS" off \
LJ "Support for LiveJournal" off \
GG "Support for Gadu-Gadu Protocol" off
@@ -81,6 +82,13 @@ CONFIGURE_ARGS+= --disable-irc
.if !defined(WITH_JABBER)
CONFIGURE_ARGS+= --disable-jabber
+.else
+.if !defined(WITH_GPGME)
+CONFIGURE_ARGS+= --without-gpgme
+.else
+LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
+.endif
.endif
.if !defined(WITH_RSS)
diff --git a/net/centericq/Makefile b/net/centericq/Makefile
index cf9292455416..b2813d818b36 100644
--- a/net/centericq/Makefile
+++ b/net/centericq/Makefile
@@ -34,6 +34,7 @@ OPTIONS= NLS "Native Language Support" on \
AIM "Support for AOL's Instant Messenger Protocol" off \
IRC "Support for IRC Protocol" off \
JABBER "Support for Jabber Protocol" off \
+ GPGME "Support for PGP encrypted Jabber messages" on \
RSS "Support for RSS" off \
LJ "Support for LiveJournal" off \
GG "Support for Gadu-Gadu Protocol" off
@@ -81,6 +82,13 @@ CONFIGURE_ARGS+= --disable-irc
.if !defined(WITH_JABBER)
CONFIGURE_ARGS+= --disable-jabber
+.else
+.if !defined(WITH_GPGME)
+CONFIGURE_ARGS+= --without-gpgme
+.else
+LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
+.endif
.endif
.if !defined(WITH_RSS)