aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-09 19:55:35 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-09 19:55:35 +0000
commit80f1b4b0ed9140e13fb6833accfceb27b18777a6 (patch)
tree72a26049278bd70028871c444a3a097ad0c563a9
parent019c0460b1620d6eae869986271df02f8e9200cf (diff)
downloadports-80f1b4b0ed9140e13fb6833accfceb27b18777a6.tar.gz
ports-80f1b4b0ed9140e13fb6833accfceb27b18777a6.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-OpenCA-OpenSSL/Makefile27
-rw-r--r--security/p5-OpenCA-OpenSSL/pkg-descr3
-rw-r--r--security/p5-OpenCA-OpenSSL/pkg-plist11
4 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 05e5b6216a2d..842d061c158d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -553,6 +553,7 @@
SUBDIR += p5-Nmap-Scanner
SUBDIR += p5-OpenCA-CRL
SUBDIR += p5-OpenCA-CRR
+ SUBDIR += p5-OpenCA-OpenSSL
SUBDIR += p5-OpenCA-PKCS7
SUBDIR += p5-OpenCA-REQ
SUBDIR += p5-OpenCA-X509
diff --git a/security/p5-OpenCA-OpenSSL/Makefile b/security/p5-OpenCA-OpenSSL/Makefile
new file mode 100644
index 000000000000..7dece5f1e3ff
--- /dev/null
+++ b/security/p5-OpenCA-OpenSSL/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-OpenCA-OpenSSL
+# Date created: 2012-03-09
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenCA-OpenSSL
+PORTVERSION= 2.0.29
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MADWOLF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl Crypto Extention to OpenSSL
+
+BUILD_DEPENDS= p5-Locale-libintl>=0:${PORTSDIR}/devel/p5-Locale-libintl \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
+ p5-X500-DN>=0:${PORTSDIR}/net/p5-X500-DN
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= OpenCA::OpenSSL.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-OpenCA-OpenSSL/pkg-descr b/security/p5-OpenCA-OpenSSL/pkg-descr
new file mode 100644
index 000000000000..016ec9c346fe
--- /dev/null
+++ b/security/p5-OpenCA-OpenSSL/pkg-descr
@@ -0,0 +1,3 @@
+Perl Crypto Extention to OpenSSL
+
+WWW: http://search.cpan.org/dist/OpenCA-OpenSSL/
diff --git a/security/p5-OpenCA-OpenSSL/pkg-plist b/security/p5-OpenCA-OpenSSL/pkg-plist
new file mode 100644
index 000000000000..b0d3150b09fe
--- /dev/null
+++ b/security/p5-OpenCA-OpenSSL/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/OpenCA/OpenSSL/SMIME.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/OpenCA/OpenSSL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/OpenCA/OpenSSL.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/OpenSSL/OpenSSL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/OpenSSL/OpenSSL.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/OpenSSL/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/OpenSSL/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenCA/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/OpenCA