aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-09-08 07:49:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-09-08 07:49:05 +0000
commit88d9c9d8a200f46ff190f88092d5c36cbd05ab4c (patch)
tree5f9d9deaa49eb0d2f5be56fd579f6a7db5873556
parent163465897a67c3d386e010e2419af1c6d4099fc5 (diff)
downloadports-88d9c9d8a200f46ff190f88092d5c36cbd05ab4c.tar.gz
ports-88d9c9d8a200f46ff190f88092d5c36cbd05ab4c.zip
Notes
-rw-r--r--databases/spatialite/Makefile4
-rw-r--r--net/userfw/Makefile4
-rw-r--r--science/hdf/Makefile8
-rw-r--r--sysutils/userspace-rcu/Makefile8
-rw-r--r--textproc/google-ctemplate/Makefile8
5 files changed, 29 insertions, 3 deletions
diff --git a/databases/spatialite/Makefile b/databases/spatialite/Makefile
index 81d7b6403558..963edf3dd063 100644
--- a/databases/spatialite/Makefile
+++ b/databases/spatialite/Makefile
@@ -41,4 +41,8 @@ post-patch:
BROKEN= does not build
.endif
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc: invokes i386 assembler
+.endif
+
.include <bsd.port.post.mk>
diff --git a/net/userfw/Makefile b/net/userfw/Makefile
index 6fa8667af4ac..00fabe458beb 100644
--- a/net/userfw/Makefile
+++ b/net/userfw/Makefile
@@ -36,6 +36,10 @@ BROKEN= does not compile on FreeBSD 7.x
IGNORE= requires kernel source files
.endif
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
CMAKE_ARGS+= -DDOMAIN_STUB:BOOL=OFF
CMAKE_ARGS+= -DOPCODE_VERIFICATION:BOOL=OFF
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index f085f7cc794e..c8b0ddf06be3 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -48,4 +48,10 @@ post-install:
# Removing useless .la files from ${PREFIX}/lib
${RM} -f ${PREFIX}/lib/libdf.la ${PREFIX}/lib/libmfhdf.la
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/userspace-rcu/Makefile b/sysutils/userspace-rcu/Makefile
index 55719e153d1e..0533d4c6b1b2 100644
--- a/sysutils/userspace-rcu/Makefile
+++ b/sysutils/userspace-rcu/Makefile
@@ -24,4 +24,10 @@ post-patch:
-e 's,^\(pkgconfigdir = \).(libdir),\1${PREFIX}/libdata,' \
${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/google-ctemplate/Makefile b/textproc/google-ctemplate/Makefile
index fbd6411018d4..4ba27fae1eb6 100644
--- a/textproc/google-ctemplate/Makefile
+++ b/textproc/google-ctemplate/Makefile
@@ -41,4 +41,10 @@ post-patch:
tests: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
+
+.include <bsd.port.post.mk>