aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2014-05-14 02:12:19 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2014-05-14 02:12:19 +0000
commitb0a698929582099c7853ad3912a532e7d95f6005 (patch)
treec9d7567a3994cc00bea3150f5895d752517ddfdf
parent73113c198899812289ae90df6cfd2e94ee528b2e (diff)
downloadports-b0a698929582099c7853ad3912a532e7d95f6005.tar.gz
ports-b0a698929582099c7853ad3912a532e7d95f6005.zip
Notes
-rw-r--r--net/honeyd/Makefile26
-rw-r--r--net/honeyd/pkg-plist2
2 files changed, 13 insertions, 15 deletions
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 6d02e6517175..1b6a69cb7977 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -11,9 +11,11 @@ MASTER_SITES= http://www.honeyd.org/uploads/ \
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Simulate virtual network hosts (honeypots)
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent \
- dnet.1:${PORTSDIR}/net/libdnet
-BUILD_DEPENDS= ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+LICENSE= GPLv2
+
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent \
+ libdnet.so:${PORTSDIR}/net/libdnet \
+ libpcre.so:${PORTSDIR}/devel/pcre
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
@@ -27,12 +29,6 @@ CONFIGURE_ARGS+= --with-python
CONFIGURE_ARGS+= --without-python
.endif
-LICENSE= GPLv2
-
-MAN1= honeydctl.1
-MAN8= honeyd.8
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if !defined(WITH_PYTHON)
@@ -50,17 +46,17 @@ post-configure:
# Have to make this directory, the Makefile is stupid and tries to
# install stuff here without making it.
pre-install:
- @${MKDIR} ${DATADIR}/webserver
+ @${MKDIR} ${STAGEDIR}${DATADIR}/webserver
post-install:
- @${MKDIR} ${DATADIR}/scripts/snmp
+ @${MKDIR} ${STAGEDIR}${DATADIR}/scripts/snmp
@cd ${WRKSRC}/scripts && \
${INSTALL_DATA} README* INSTALL* kuang2.conf \
- ${DATADIR}/scripts && \
- ${INSTALL_SCRIPT} *.pl *.sh ${DATADIR}/scripts
+ ${STAGEDIR}${DATADIR}/scripts && \
+ ${INSTALL_SCRIPT} *.pl *.sh ${STAGEDIR}${DATADIR}/scripts
@cd ${WRKSRC}/scripts/snmp && \
${INSTALL_DATA} README default.snmp *.tpl \
- ${DATADIR}/scripts/snmp && \
- ${INSTALL_SCRIPT} *.pl ${DATADIR}/scripts/snmp
+ ${STAGEDIR}${DATADIR}/scripts/snmp && \
+ ${INSTALL_SCRIPT} *.pl ${STAGEDIR}${DATADIR}/scripts/snmp
.include <bsd.port.post.mk>
diff --git a/net/honeyd/pkg-plist b/net/honeyd/pkg-plist
index 8d5c76236b07..66f31789f7e2 100644
--- a/net/honeyd/pkg-plist
+++ b/net/honeyd/pkg-plist
@@ -7,6 +7,8 @@ include/honeyd/hooks.h
include/honeyd/plugins.h
include/honeyd/plugins_config.h
lib/honeyd/libhoneyd.so
+man/man1/honeydctl.1.gz
+man/man8/honeyd.8.gz
%%DATADIR%%/README
%%DATADIR%%/config.ethernet
%%DATADIR%%/config.sample