aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-08 01:39:35 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-08 01:39:35 +0000
commitfd91adca16847b5595b6d12eb25d12e789d52abb (patch)
treee5ce7df0f40e861ae203e1d95d81f820b594fa13
parent9bdcc3fd9440520d71be28663b1f0b8311b7d03a (diff)
downloadports-fd91adca16847b5595b6d12eb25d12e789d52abb.tar.gz
ports-fd91adca16847b5595b6d12eb25d12e789d52abb.zip
MFH: r567816
net/openvswitch: Fix conflicts with libc (uuid_to_string(2)) PR: 238331 Submitted by: Nikola Kolev <koue AT chaosophia DOT net>, amdmi3 Reported by: Ian Campbell <ianc1215 AT gmail DOT com> Approved by: portmgr (bugfix blanket)
Notes
Notes: svn path=/branches/2021Q1/; revision=567817
-rw-r--r--net/openvswitch/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 992e253bf3dd..0f6c6ef03f56 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openvswitch
DISTVERSION= 2.14.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://openvswitch.org/releases/
@@ -35,6 +36,10 @@ INSTALL_TARGET=install-strip
SHLIB_VER= ${DISTVERSION:C/\.[0-9]*$//}
PLIST_SUB= SHLIB_VER=${SHLIB_VER}
+post-patch:
+ @${REINPLACE_CMD} -e 's|uuid_from_string(|uuid_from_string_ovs(|g' \
+ ${WRKSRC}/*/*.c ${WRKSRC}/*/*.h
+
post-install:
${MKDIR} ${STAGEDIR}/var/run/openvswitch
${MKDIR} ${STAGEDIR}/var/log/openvswitch