aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-03-21 04:53:12 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-03-21 04:53:12 +0000
commit08a32c12cabec90f6a83c20c9f3c4063682fa73e (patch)
tree1dd2e148ef76b05c482671655ad18a476724a0bb
parent41465aa51dfd7cfdc1a0b43b3e930b0f13ec6f30 (diff)
downloadports-08a32c12cabec90f6a83c20c9f3c4063682fa73e.tar.gz
ports-08a32c12cabec90f6a83c20c9f3c4063682fa73e.zip
Notes
-rw-r--r--net/blam/Makefile22
-rw-r--r--www/gecko-sharp/Makefile22
-rw-r--r--www/gecko-sharp10/Makefile22
3 files changed, 60 insertions, 6 deletions
diff --git a/net/blam/Makefile b/net/blam/Makefile
index 6431c7839b76..60a38137dfdf 100644
--- a/net/blam/Makefile
+++ b/net/blam/Makefile
@@ -8,7 +8,7 @@
PORTNAME= blam
PORTVERSION= 1.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.6
@@ -20,15 +20,33 @@ BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp \
${X11BASE}/libdata/pkgconfig/gecko-sharp.pc:${PORTSDIR}/www/gecko-sharp
RUN_DEPENDS= ${BUILD_DEPENDS}
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+MOZILLA= mozilla
+.endif
+.endif
+
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_LIBTOOL_VER=15
USE_GMAKE= yes
-
+CONFIGURE_ARGS= --with-mozilla=${MOZILLA}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= blam.schemas
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>
diff --git a/www/gecko-sharp/Makefile b/www/gecko-sharp/Makefile
index 0427c797a5d7..ad4b841a4e84 100644
--- a/www/gecko-sharp/Makefile
+++ b/www/gecko-sharp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gecko-sharp
PORTVERSION= 0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://go-mono.com/archive/1.0.3/
@@ -16,11 +16,29 @@ COMMENT= Mono bindings for embeding mozilla
BUILD_DEPENDS= gapi-parser:${PORTSDIR}/x11-toolkits/gtk-sharp
RUN_DEPENDS= ${BUILD_DEPENDS} \
- ${X11BASE}/lib/mozilla/components/libwidget_gtk2.so:${PORTSDIR}/www/mozilla
+ ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+MOZILLA= mozilla
+.endif
+.endif
USE_GNOME= gnomehack gnometarget
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>
diff --git a/www/gecko-sharp10/Makefile b/www/gecko-sharp10/Makefile
index 0427c797a5d7..ad4b841a4e84 100644
--- a/www/gecko-sharp10/Makefile
+++ b/www/gecko-sharp10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gecko-sharp
PORTVERSION= 0.6
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://go-mono.com/archive/1.0.3/
@@ -16,11 +16,29 @@ COMMENT= Mono bindings for embeding mozilla
BUILD_DEPENDS= gapi-parser:${PORTSDIR}/x11-toolkits/gtk-sharp
RUN_DEPENDS= ${BUILD_DEPENDS} \
- ${X11BASE}/lib/mozilla/components/libwidget_gtk2.so:${PORTSDIR}/www/mozilla
+ ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
+
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla
+.else
+.if ${WITH_MOZILLA}=="firefox"
+MOZILLA= firefox
+.else
+MOZILLA= mozilla
+.endif
+.endif
USE_GNOME= gnomehack gnometarget
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default ${PORTNAME} uses www/mozilla for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " firefox "
+ @${ECHO_MSG} ""
+
.include <bsd.port.mk>