aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-10-23 16:34:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-10-23 16:34:43 +0000
commit0aa737a3361845ec8f71d74835196cd5ec620250 (patch)
tree6cc56fc8997a9b33f3a2e326fc1a9a97affe375c
parent34e555714096a8da20bb049a438dc2df7b729e10 (diff)
downloadports-0aa737a3361845ec8f71d74835196cd5ec620250.tar.gz
ports-0aa737a3361845ec8f71d74835196cd5ec620250.zip
Notes
-rw-r--r--benchmarks/dbs/Makefile1
-rw-r--r--cad/gmsh/Makefile1
-rw-r--r--comms/uhd/Makefile3
-rw-r--r--devel/glib20/Makefile1
-rw-r--r--emulators/rtc/Makefile1
-rw-r--r--french/aster/Makefile1
-rw-r--r--games/armagetron/Makefile2
-rw-r--r--games/bloboats/Makefile1
-rw-r--r--lang/dmd2/Makefile1
-rw-r--r--lang/racket/Makefile1
-rw-r--r--mail/spamilter/Makefile1
-rw-r--r--math/blitz++/Makefile1
-rw-r--r--misc/xiphos/Makefile1
-rw-r--r--multimedia/vdr-plugin-upnp/Makefile1
-rw-r--r--net/knemo-kde4/Makefile1
-rw-r--r--net/openafs/Makefile2
-rw-r--r--net/userfw/Makefile1
-rw-r--r--print/pdftk/Makefile1
-rw-r--r--security/krb5-114/Makefile1
-rw-r--r--security/pidentd/Makefile1
-rw-r--r--security/revealrk/Makefile1
-rw-r--r--sysutils/asmem/Makefile1
-rw-r--r--sysutils/asmon/Makefile1
-rw-r--r--sysutils/bsdmoted/Makefile1
-rw-r--r--sysutils/cfengine310/Makefile1
-rw-r--r--sysutils/cfengine311/Makefile1
-rw-r--r--sysutils/cfengine312/Makefile1
-rw-r--r--sysutils/cfengine32/Makefile1
-rw-r--r--sysutils/cfengine33/Makefile1
-rw-r--r--sysutils/cfengine34/Makefile1
-rw-r--r--sysutils/cfengine35/Makefile1
-rw-r--r--sysutils/cfengine36/Makefile1
-rw-r--r--sysutils/cfengine37/Makefile1
-rw-r--r--sysutils/cfengine38/Makefile1
-rw-r--r--sysutils/cfengine39/Makefile1
-rw-r--r--sysutils/muse/Makefile1
-rw-r--r--sysutils/pcbsd-utils-qt5/Makefile1
-rw-r--r--sysutils/qjail4/Makefile1
-rw-r--r--sysutils/scprotect/Makefile1
-rw-r--r--sysutils/showbeastie/Makefile1
-rw-r--r--sysutils/syslog-ng36/Makefile1
-rw-r--r--sysutils/syslog-ng37/Makefile1
-rw-r--r--sysutils/wmmemfree/Makefile1
-rw-r--r--sysutils/xosview/Makefile1
-rw-r--r--www/cherokee/Makefile1
45 files changed, 48 insertions, 1 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index 4d8ad8fed987..1465759f33d3 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -16,6 +16,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= gnuplot:math/gnuplot
BROKEN_FreeBSD_12= tcp_debug.h: field has incomplete type 'struct tcpcb'
+BROKEN_FreeBSD_13= tcp_debug.h: field has incomplete type 'struct tcpcb'
BUILD_WRKSRC= ${WRKSRC}/obj/${OPSYS}
INSTALL_WRKSRC= ${WRKSRC}/obj/${OPSYS}
diff --git a/cad/gmsh/Makefile b/cad/gmsh/Makefile
index 62ddf4bb860f..3347ac51858a 100644
--- a/cad/gmsh/Makefile
+++ b/cad/gmsh/Makefile
@@ -15,6 +15,7 @@ LICENSE= AGPLv3+ APACHE20 GPLv3+ GPLv2+ LGPL21
LICENSE_COMB= multi
BROKEN_FreeBSD_12_i386= fails to build on FreeBSD 12 i386 due to a clang bug: https://llvm.org/bugs/show_bug.cgi?id=21903
+BROKEN_FreeBSD_13_i386= fails to build on FreeBSD 13 i386 due to a clang bug: https://llvm.org/bugs/show_bug.cgi?id=21903
BROKEN_powerpc64= fails to build: .rodata._Z7pow_intRKdRKi referenced in section .got of CMakeFiles/gmsh.dir/Numeric/bezierBasis.cpp.o: defined in discarded section
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 912433571f34..83b8ca37865d 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -28,6 +28,9 @@ CONFLICTS= usrp-[0-9]*
BROKEN_FreeBSD_12_aarch64= fails to configure: Could not find standard set_new_handler function
BROKEN_FreeBSD_12_armv6= fails to configure: Could not find standard set_new_handler function
BROKEN_FreeBSD_12_armv7= fails to configure: Could not find standard set_new_handler function
+BROKEN_FreeBSD_13_aarch64= fails to configure: Could not find standard set_new_handler function
+BROKEN_FreeBSD_13_armv6= fails to configure: Could not find standard set_new_handler function
+BROKEN_FreeBSD_13_armv7= fails to configure: Could not find standard set_new_handler function
BROKEN_powerpc64= fails to link: undefined reference to boost function
USES= compiler:c++11-lib cmake:outsource ncurses pkgconfig \
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 9e6dedb84bac..344176643e68 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -55,6 +55,7 @@ COLLATION_FIX_DESC= Use ICU for UTF-8 string collation (if libc is broken)
OPTIONS_EXCLUDE_FreeBSD_11= COLLATION_FIX
OPTIONS_EXCLUDE_FreeBSD_12= COLLATION_FIX
+OPTIONS_EXCLUDE_FreeBSD_13= COLLATION_FIX
DEBUG_CONFIGURE_ON= --enable-debug=yes
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index d6aa6098bfff..79a407583662 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= emulation@FreeBSD.org
COMMENT= Kernel module which provides /dev/rtc device support
BROKEN_FreeBSD_12= fails to compile: rtc.c:166:2: implicit declaration of function 'MALLOC' is invalid in C99
+BROKEN_FreeBSD_13= fails to compile: rtc.c:166:2: implicit declaration of function 'MALLOC' is invalid in C99
WRKSRC= ${WRKDIR}/files
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 7600b5827d0c..f6ac77bb6deb 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -12,6 +12,7 @@ COMMENT= Code_Aster finite element method solver
LICENSE= GPLv2
BROKEN_FreeBSD_12= does not build (sed: ${STAGEDIR}${inst_dir}/${VE}/aster.conf: No such file or directory)
+BROKEN_FreeBSD_13= does not build (sed: ${STAGEDIR}${inst_dir}/${VE}/aster.conf: No such file or directory)
#-----------------------------------------------------------------------
# You may define these options:
diff --git a/games/armagetron/Makefile b/games/armagetron/Makefile
index 44d2a8b2212b..c0f6efb87bba 100644
--- a/games/armagetron/Makefile
+++ b/games/armagetron/Makefile
@@ -18,6 +18,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
BROKEN_FreeBSD_12_armv6= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
BROKEN_FreeBSD_12_armv7= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+BROKEN_FreeBSD_13_armv6= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
+BROKEN_FreeBSD_13_armv7= network/nNetObject.cpp:1533:46: error: ordered comparison between pointer and zero ('const nSocket *' and 'int')
USES= gmake jpeg
GNU_CONFIGURE= yes
diff --git a/games/bloboats/Makefile b/games/bloboats/Makefile
index bcd8855fdab4..4d388a765286 100644
--- a/games/bloboats/Makefile
+++ b/games/bloboats/Makefile
@@ -20,6 +20,7 @@ LICENSE_FILE= ${WRKSRC}/copying.txt
BROKEN_FreeBSD_11= does not build on 11.X
BROKEN_FreeBSD_12= does not build on 12.X # PR 226180
+BROKEN_FreeBSD_13= does not build on 13.X # PR 226180
USES= dos2unix gmake
USE_SDL= mixer image net sdl
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index b019c3036d0d..f4979a8ca1f7 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -22,6 +22,7 @@ BROKEN_mips64= fails to compile: cc1: unrecognized command line option -m32
BROKEN_powerpc64= fails to build: can't mangle function with unknown linkage (void*())
BROKEN_sparc64= fails to install: divide-by-zero error
BROKEN_FreeBSD_12= stack corruption in generated dmd tool caused by inode64 resulting in segfault
+BROKEN_FreeBSD_13= stack corruption in generated dmd tool caused by inode64 resulting in segfault
NOT_FOR_ARCHS= aarch64
NOT_FOR_ARCHS_REASON= no cpu specified, assuming X86
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index 8e2aede06247..d61be12efa3a 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -26,6 +26,7 @@ BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in t
BROKEN_FreeBSD_10_i386= segfaults during build
BROKEN_FreeBSD_11_i386= segfaults during build
BROKEN_FreeBSD_12_i386= segfaults during build
+BROKEN_FreeBSD_13_i386= segfaults during build
NOT_FOR_ARCHS= aarch64 armv6 armv7 sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this arch
diff --git a/mail/spamilter/Makefile b/mail/spamilter/Makefile
index 0b4ae6b80ae4..227dbd004ad1 100644
--- a/mail/spamilter/Makefile
+++ b/mail/spamilter/Makefile
@@ -49,6 +49,7 @@ IPFWMTAD_USES= ssl
.if ${PORT_OPTIONS:MIPFWMTAD}
BROKEN_FreeBSD_12= option IPFWMTAD needs old openssl
+BROKEN_FreeBSD_13= option IPFWMTAD needs old openssl
.endif
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
diff --git a/math/blitz++/Makefile b/math/blitz++/Makefile
index 6ce029b2c9b6..8b4d9c61bfcf 100644
--- a/math/blitz++/Makefile
+++ b/math/blitz++/Makefile
@@ -12,6 +12,7 @@ LICENSE= GPLv3 BSD3CLAUSE
LICENSE_COMB= multi
BROKEN_FreeBSD_12= fails to compile: ../blitz/blitz.h:58:12: 'iostream.h' file not found
+BROKEN_FreeBSD_13= fails to compile: ../blitz/blitz.h:58:12: 'iostream.h' file not found
GNU_CONFIGURE= yes
USES= gmake libtool pathfix python
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 61d0585db882..96ff87111b0a 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -12,6 +12,7 @@ COMMENT= Bible interface utilizing the sword framework
LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to compile: /usr/include/c++/v1/type_traits:1116:29: recursive template instantiation exceeded maximum depth of 25
+BROKEN_FreeBSD_13= fails to compile: /usr/include/c++/v1/type_traits:1116:29: recursive template instantiation exceeded maximum depth of 25
BUILD_DEPENDS= ${RUN_DEPENDS} \
docbook2html:textproc/docbook-utils \
diff --git a/multimedia/vdr-plugin-upnp/Makefile b/multimedia/vdr-plugin-upnp/Makefile
index 618fa22cac72..bb553f4245e0 100644
--- a/multimedia/vdr-plugin-upnp/Makefile
+++ b/multimedia/vdr-plugin-upnp/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_FreeBSD_12= fails to compile: inc/util.h:21:10: 'libavformat/avformat.h' file not found
+BROKEN_FreeBSD_13= fails to compile: inc/util.h:21:10: 'libavformat/avformat.h' file not found
LIB_DEPENDS= libavcodec0.so:multimedia/ffmpeg0 \
libboost_system.so:devel/boost-libs \
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 227d9ea9e61e..bdd4fe9913e4 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -15,6 +15,7 @@ EXPIRATION_DATE= 2018-12-31
BROKEN_FreeBSD_11= does not build due to access to kernel-private structure (error: member access into incomplete type 'struct in6_ifaddr')
BROKEN_FreeBSD_12= does not build due to access to kernel-private structure (error: member access into incomplete type 'struct in6_ifaddr')
+BROKEN_FreeBSD_13= does not build due to access to kernel-private structure (error: member access into incomplete type 'struct in6_ifaddr')
USES= cmake gettext kde:4 qt:4 shebangfix tar:xz
SHEBANG_FILES= src/kconf_update/*.pl
diff --git a/net/openafs/Makefile b/net/openafs/Makefile
index 184d7c834573..fea2470dbc6b 100644
--- a/net/openafs/Makefile
+++ b/net/openafs/Makefile
@@ -79,7 +79,7 @@ FUSE_CONFIGURE_OFF= --disable-fuse-client
CFLAGS+= -mstackrealign
.endif
-.if ${OSREL} == "11.0" || ${OSREL} == "11.1" || ${OSREL} == "12.0"
+.if ${OSREL:R} >= 11
# Upstream does not support the client on 11 and newer
CONFIGURE_ARGS += --disable-kernel-module
PLIST_SUB+= KMOD="@comment "
diff --git a/net/userfw/Makefile b/net/userfw/Makefile
index 0ada6ac33711..6b94df88ad13 100644
--- a/net/userfw/Makefile
+++ b/net/userfw/Makefile
@@ -19,6 +19,7 @@ BROKEN_powerpc= fails to compile
BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
BROKEN_FreeBSD_11= fails to build on FreeBSD 11+
BROKEN_FreeBSD_12= fails to build on FreeBSD 11+
+BROKEN_FreeBSD_13= fails to build on FreeBSD 11+
DEPRECATED= Does not build on FreeBSD 11+
EXPIRATION_DATE= 2018-10-31
diff --git a/print/pdftk/Makefile b/print/pdftk/Makefile
index 84cb73435671..d49e35e454c8 100644
--- a/print/pdftk/Makefile
+++ b/print/pdftk/Makefile
@@ -14,6 +14,7 @@ COMMENT= Simple tool for doing everyday things with PDF documents
LICENSE= GPLv2
BROKEN_FreeBSD_12= gcj6: internal compiler error: Segmentation fault (program ecj1)
+BROKEN_FreeBSD_13= gcj6: internal compiler error: Segmentation fault (program ecj1)
# Get GCC version suffix without the dot in USE_GCC
CSUFF= ${_USE_GCC:S/.//}
diff --git a/security/krb5-114/Makefile b/security/krb5-114/Makefile
index 3a42e9981826..5105001951da 100644
--- a/security/krb5-114/Makefile
+++ b/security/krb5-114/Makefile
@@ -22,6 +22,7 @@ DEPRECATED= EOL twelve months after release of krb5-1.16
EXPIRATION_DATE= 2018-12-31
BROKEN_FreeBSD_12= Fails to build after import of openssl111
+BROKEN_FreeBSD_13= Fails to build after import of openssl111
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= OpenSSL >= 1.1.0 unsupported.
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 2a8b44a59512..40de0562aecf 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= RFC1413 identification server
BROKEN_FreeBSD_12= fails to compile: k_freebsd2.c: storage size of 'pcbp' isn't known
+BROKEN_FreeBSD_13= fails to compile: k_freebsd2.c: storage size of 'pcbp' isn't known
CONFLICTS_INSTALL= fakeident-[0-9]*
diff --git a/security/revealrk/Makefile b/security/revealrk/Makefile
index c9af6dbed2f7..5635bb0aa42e 100644
--- a/security/revealrk/Makefile
+++ b/security/revealrk/Makefile
@@ -11,6 +11,7 @@ COMMENT= Search hidden procs/rootkits from cron with low false positive rate
LICENSE= GPLv3
BROKEN_FreeBSD_12= fails to compile: revealrk.c: 'struct xtcpcb' has no member named 'xt_socket'
+BROKEN_FreeBSD_13= fails to compile: revealrk.c: 'struct xtcpcb' has no member named 'xt_socket'
PLIST_FILES= bin/revealrk man/man1/revealrk.1.gz
diff --git a/sysutils/asmem/Makefile b/sysutils/asmem/Makefile
index 6fc6affc3e54..b10813b81fdc 100644
--- a/sysutils/asmem/Makefile
+++ b/sysutils/asmem/Makefile
@@ -13,6 +13,7 @@ COMMENT= AfterStep look-n-feel memory utilization monitor
LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
+BROKEN_FreeBSD_13= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
USE_XORG= xpm
GNU_CONFIGURE= yes
diff --git a/sysutils/asmon/Makefile b/sysutils/asmon/Makefile
index e3967d0f928d..2a43c186ddbf 100644
--- a/sysutils/asmon/Makefile
+++ b/sysutils/asmon/Makefile
@@ -13,6 +13,7 @@ COMMENT= Swallowable applet monitors the CPU usage, memory, and swap, etc
LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
+BROKEN_FreeBSD_13= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_mips= fails to compile: asmon.c: storage size of 'sum' isn't known
BROKEN_mips64= fails to compile: asmon.c: storage size of 'sum' isn't known
BROKEN_powerpc64= fails to compile: asmon.c: storage size of 'sum' isn't known
diff --git a/sysutils/bsdmoted/Makefile b/sysutils/bsdmoted/Makefile
index e1dc94648d36..1ac9df14a499 100644
--- a/sysutils/bsdmoted/Makefile
+++ b/sysutils/bsdmoted/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_powerpc64= does not build: warning Make sure new member of socket address initialized
BROKEN_FreeBSD_11= does not build (bluetooth changes in 11.x need to be handled)
BROKEN_FreeBSD_12= does not build (bluetooth changes in 11.x need to be handled)
+BROKEN_FreeBSD_13= does not build (bluetooth changes in 11.x need to be handled)
DEPRECATED= does not build on FreeBSD 11+
EXPIRATION_DATE= 2018-10-31
diff --git a/sysutils/cfengine310/Makefile b/sysutils/cfengine310/Makefile
index 8c82e6760fc4..f709d29e5fca 100644
--- a/sysutils/cfengine310/Makefile
+++ b/sysutils/cfengine310/Makefile
@@ -18,6 +18,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-9]-* cfengine31[1-9]-*
.if !defined(MASTERDIR)
diff --git a/sysutils/cfengine311/Makefile b/sysutils/cfengine311/Makefile
index a9c9335b607a..e7ff2aebb5b4 100644
--- a/sysutils/cfengine311/Makefile
+++ b/sysutils/cfengine311/Makefile
@@ -19,6 +19,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-9]-* cfengine31[02-9]-*
.if !defined(MASTERDIR)
diff --git a/sysutils/cfengine312/Makefile b/sysutils/cfengine312/Makefile
index 22a24ae8fda1..8605f2389dc5 100644
--- a/sysutils/cfengine312/Makefile
+++ b/sysutils/cfengine312/Makefile
@@ -18,6 +18,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-9]-* cfengine31[013-9]-*
.if !defined(MASTERDIR)
diff --git a/sysutils/cfengine32/Makefile b/sysutils/cfengine32/Makefile
index 0914b7cbbf49..5a5bc24f845e 100644
--- a/sysutils/cfengine32/Makefile
+++ b/sysutils/cfengine32/Makefile
@@ -18,6 +18,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
diff --git a/sysutils/cfengine33/Makefile b/sysutils/cfengine33/Makefile
index d897f16be0ef..279ae2ff3053 100644
--- a/sysutils/cfengine33/Makefile
+++ b/sysutils/cfengine33/Makefile
@@ -17,6 +17,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
FETCH_BEFORE_ARGS= -o ${DISTDIR}/${DISTFILES}
diff --git a/sysutils/cfengine34/Makefile b/sysutils/cfengine34/Makefile
index 1752437b7fe8..b3330a5eefbe 100644
--- a/sysutils/cfengine34/Makefile
+++ b/sysutils/cfengine34/Makefile
@@ -16,6 +16,7 @@ CPE_VENDOR= gnu
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-35-9]-* cfengine31[0-9]-*
.if !defined(MASTERDIR)
diff --git a/sysutils/cfengine35/Makefile b/sysutils/cfengine35/Makefile
index bf9ac91d1d10..ece61cd9ec74 100644
--- a/sysutils/cfengine35/Makefile
+++ b/sysutils/cfengine35/Makefile
@@ -15,6 +15,7 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
diff --git a/sysutils/cfengine36/Makefile b/sysutils/cfengine36/Makefile
index 2eafad6dc96f..d0eafeb362d7 100644
--- a/sysutils/cfengine36/Makefile
+++ b/sysutils/cfengine36/Makefile
@@ -16,6 +16,7 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
CONFLICTS= cfengine-2* cfengine3[0-57-9]-* cfengine31[0-9]-*
.if !defined(MASTERDIR)
diff --git a/sysutils/cfengine37/Makefile b/sysutils/cfengine37/Makefile
index ef8199482b86..0e1522570153 100644
--- a/sysutils/cfengine37/Makefile
+++ b/sysutils/cfengine37/Makefile
@@ -14,6 +14,7 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
diff --git a/sysutils/cfengine38/Makefile b/sysutils/cfengine38/Makefile
index 3015dfc0d106..2801e978a32d 100644
--- a/sysutils/cfengine38/Makefile
+++ b/sysutils/cfengine38/Makefile
@@ -15,6 +15,7 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
diff --git a/sysutils/cfengine39/Makefile b/sysutils/cfengine39/Makefile
index 275c371636cd..fd1e6e068781 100644
--- a/sysutils/cfengine39/Makefile
+++ b/sysutils/cfengine39/Makefile
@@ -14,6 +14,7 @@ COMMENT= Systems administration tool for networks
DEPRECATED= OpenSSL 1.1.X is not supported.
EXPIRATION_DATE= 2021-09-30
BROKEN_FreeBSD_12= openssl111 is not supported
+BROKEN_FreeBSD_13= openssl111 is not supported
LICENSE= GPLv3
diff --git a/sysutils/muse/Makefile b/sysutils/muse/Makefile
index 025ce9ba6597..29acf52e2879 100644
--- a/sysutils/muse/Makefile
+++ b/sysutils/muse/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= freebsd@spatula.net
COMMENT= Shows memory usage data
BROKEN_FreeBSD_12= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
+BROKEN_FreeBSD_13= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_mips= fails to compile: muse.c: storage size of 'vmstats' isn't known
BROKEN_mips64= fails to compile: muse.c: storage size of 'vmstats' isn't known
BROKEN_powerpc64= fails to compile: muse.c: storage size of 'vmstats' isn't known
diff --git a/sysutils/pcbsd-utils-qt5/Makefile b/sysutils/pcbsd-utils-qt5/Makefile
index 15df5ce32119..548f6fef5fbb 100644
--- a/sysutils/pcbsd-utils-qt5/Makefile
+++ b/sysutils/pcbsd-utils-qt5/Makefile
@@ -12,6 +12,7 @@ COMMENT= PC-BSD Qt5 Utilities
LICENSE= BSD3CLAUSE
BROKEN_FreeBSD_12= fails to compile: netif.cpp: error: use of undeclared identifier 'IFM_FDDI'
+BROKEN_FreeBSD_13= fails to compile: netif.cpp: error: use of undeclared identifier 'IFM_FDDI'
BUILD_DEPENDS= sphinx-build:textproc/py-sphinx \
${PYTHON_PKGNAMEPREFIX}sphinx-intl>=0:textproc/py-sphinx-intl@${PY_FLAVOR} \
diff --git a/sysutils/qjail4/Makefile b/sysutils/qjail4/Makefile
index 2cadc5eb72c2..625d814a2915 100644
--- a/sysutils/qjail4/Makefile
+++ b/sysutils/qjail4/Makefile
@@ -27,6 +27,7 @@ NO_ARCH= yes
IGNORE_FreeBSD_11= Only for FreeBSD 10.x
IGNORE_FreeBSD_12= Only for FreeBSD 10.x
+IGNORE_FreeBSD_13= Only for FreeBSD 10.x
do-install:
.for i in qjail qjail.vnet.be qjail.vnet.ng
diff --git a/sysutils/scprotect/Makefile b/sysutils/scprotect/Makefile
index c02364aef69d..f8a94777458a 100644
--- a/sysutils/scprotect/Makefile
+++ b/sysutils/scprotect/Makefile
@@ -11,6 +11,7 @@ COMMENT= Protect process from killing when the swap space is exhausted
BROKEN_FreeBSD_11= does not build on FreeBSD 11.x+
BROKEN_FreeBSD_12= does not build on FreeBSD 11.x+: scprotect.c: 'sysctl__' undeclared (first use in this function)
+BROKEN_FreeBSD_13= does not build on FreeBSD 11.x+: scprotect.c: 'sysctl__' undeclared (first use in this function)
DEPRECATED= Does not build on FreeBSD 11+
EXPIRATION_DATE= 2018-10-31
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index a4c30baa83ca..5acd142b9a61 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -17,6 +17,7 @@ BROKEN_armv7= fails to link: testmain uses VFP register arguments, dict.o does
BROKEN_mips64= fails to link: relocation truncated to fit: R_MIPS_26 against `__assert@@FBSD_1.0'
BROKEN_powerpc64= fails to build: ficl/Makefile line 25: Could not find bsd.stand.mk
BROKEN_FreeBSD_12= fails to build: ficl/Makefile line 13: Could not find bsd.stand.mk
+BROKEN_FreeBSD_13= fails to build: ficl/Makefile line 13: Could not find bsd.stand.mk
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source files in ${SRC_BASE}
diff --git a/sysutils/syslog-ng36/Makefile b/sysutils/syslog-ng36/Makefile
index 5d302b31ba28..5efa1a50df01 100644
--- a/sysutils/syslog-ng36/Makefile
+++ b/sysutils/syslog-ng36/Makefile
@@ -56,6 +56,7 @@ CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
.if ${PORT_OPTIONS:MOPENSSL}
BROKEN_FreeBSD_12= Fails to build with openssl111
+BROKEN_FreeBSD_13= Fails to build with openssl111
USES+= ssl
CONFIGURE_ARGS+= --enable-ssl
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
diff --git a/sysutils/syslog-ng37/Makefile b/sysutils/syslog-ng37/Makefile
index 7aa3e7348571..34569d6384a1 100644
--- a/sysutils/syslog-ng37/Makefile
+++ b/sysutils/syslog-ng37/Makefile
@@ -24,6 +24,7 @@ BUILD_DEPENDS= xsltproc:textproc/libxslt
DEPRECATED= No longer officially supported by Balabit, does not support openssl111
EXPIRATION_DATE= 2018-12-31
BROKEN_FreeBSD_12= fails to build with openssl111
+BROKEN_FreeBSD_13= fails to build with openssl111
BROKEN_powerpc64= fails to link: Internal error: Segmentation fault (program ld)
BROKEN_sparc64= fails to link: Internal error: Segmentation fault (program ld)
diff --git a/sysutils/wmmemfree/Makefile b/sysutils/wmmemfree/Makefile
index 6aec862de113..26d025083ab7 100644
--- a/sysutils/wmmemfree/Makefile
+++ b/sysutils/wmmemfree/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Memory and swap monitoring dockapp
BROKEN_FreeBSD_12= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
+BROKEN_FreeBSD_13= fails to compile: read_mem.c: invalid use of undefined type 'struct vmmeter'
BROKEN_mips= fails to compile: mem_freebsd.c: storage size of 'vm' isn't known
BROKEN_mips64= fails to compile: mem_freebsd.c: storage size of 'vm' isn't known
BROKEN_powerpc64= fails to compile: mem_freebsd.c: storage size of 'vm' isn't known
diff --git a/sysutils/xosview/Makefile b/sysutils/xosview/Makefile
index e38223218995..2e6b2ead04c3 100644
--- a/sysutils/xosview/Makefile
+++ b/sysutils/xosview/Makefile
@@ -12,6 +12,7 @@ LICENSE= BSD4CLAUSE GPLv2
LICENSE_COMB= multi
BROKEN_FreeBSD_12= Due to changes in sys/vmmeter.h (r328134)
+BROKEN_FreeBSD_13= Due to changes in sys/vmmeter.h (r328134)
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= uses x86-specific hardware resources
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index eccf12847f84..5837f8f5679a 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -13,6 +13,7 @@ COMMENT= Fast and flexible web server
LICENSE= GPLv2
BROKEN_FreeBSD_12= fails to configure: Unable to detect data struct is used by crypt_r
+BROKEN_FreeBSD_13= fails to configure: Unable to detect data struct is used by crypt_r
USE_GITHUB= yes
GH_PROJECT= webserver