aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-11-07 11:14:53 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-11-07 11:14:53 +0000
commit382e5bbebd999a81ce306a2f2ec58b09018796fd (patch)
treea4bfb91b64e21b660c1e88224126eb1f27104da6
parent5d2695005ebddc727765ff813c40bdce01ef2be6 (diff)
downloadports-382e5bbebd999a81ce306a2f2ec58b09018796fd.tar.gz
ports-382e5bbebd999a81ce306a2f2ec58b09018796fd.zip
Notes
-rw-r--r--x11-toolkits/py-qt/Makefile9
-rw-r--r--x11-toolkits/py-qt/distinfo4
-rw-r--r--x11-toolkits/py-qt/pkg-plist5
3 files changed, 13 insertions, 5 deletions
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index 8f583a8fe793..004086c16929 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -5,14 +5,13 @@
# $FreeBSD$
PORTNAME= qt
-PORTVERSION= 3.12
-PORTREVISION= 1
+PORTVERSION= 3.13
CATEGORIES= x11-toolkits python
MASTER_SITES= http://www.river-bank.demon.co.uk/download/PyQt/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyQt-x11-gpl-${PORTVERSION}
-MAINTAINER= eugos@gmx.net
+MAINTAINER= danny@ricin.com
COMMENT= Python bindings for the Qt toolkit
LIB_DEPENDS= qscintilla.5:${PORTSDIR}/x11-toolkits/qscintilla
@@ -36,4 +35,8 @@ do-configure:
-n ${X11BASE}/include -o ${X11BASE}/lib \
-v ${PREFIX}/share/sip)
+post-install:
+ @${PYTHON_CMD} -c "import pyqtconfig"
+ @${PYTHON_CMD} -O -c "import pyqtconfig"
+
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-qt/distinfo b/x11-toolkits/py-qt/distinfo
index c7d2c326679e..754bbfe9605e 100644
--- a/x11-toolkits/py-qt/distinfo
+++ b/x11-toolkits/py-qt/distinfo
@@ -1,2 +1,2 @@
-MD5 (PyQt-x11-gpl-3.12.tar.gz) = 0869e68c24ee6e46ae74d3244e7ec299
-SIZE (PyQt-x11-gpl-3.12.tar.gz) = 760165
+MD5 (PyQt-x11-gpl-3.13.tar.gz) = a4145b39742a4d9df9b6bf06495f75f5
+SIZE (PyQt-x11-gpl-3.13.tar.gz) = 763066
diff --git a/x11-toolkits/py-qt/pkg-plist b/x11-toolkits/py-qt/pkg-plist
index 377ac7a22b43..63ab0348106f 100644
--- a/x11-toolkits/py-qt/pkg-plist
+++ b/x11-toolkits/py-qt/pkg-plist
@@ -1,6 +1,8 @@
bin/pylupdate
bin/pyuic
%%PYTHON_SITELIBDIR%%/pyqtconfig.py
+%%PYTHON_SITELIBDIR%%/pyqtconfig.pyc
+%%PYTHON_SITELIBDIR%%/pyqtconfig.pyo
%%PYTHON_SITELIBDIR%%/qt.so
%%PYTHON_SITELIBDIR%%/qtcanvas.so
%%PYTHON_SITELIBDIR%%/qtext.so
@@ -86,6 +88,7 @@ share/sip/qt/qmemarray.sip
share/sip/qt/qmenubar.sip
share/sip/qt/qmenudata.sip
share/sip/qt/qmessagebox.sip
+share/sip/qt/qmetaobject.sip
share/sip/qt/qmime.sip
share/sip/qt/qmotifplusstyle.sip
share/sip/qt/qmotifstyle.sip
@@ -168,6 +171,7 @@ share/sip/qt/qtranslator.sip
share/sip/qt/qurl.sip
share/sip/qt/qurlinfo.sip
share/sip/qt/qurloperator.sip
+share/sip/qt/quuid.sip
share/sip/qt/qvalidator.sip
share/sip/qt/qvaluelist.sip
share/sip/qt/qvariant.sip
@@ -201,6 +205,7 @@ share/sip/qtext/qextscintillacommand.sip
share/sip/qtext/qextscintillacommandset.sip
share/sip/qtext/qextscintilladocument.sip
share/sip/qtext/qextscintillalexer.sip
+share/sip/qtext/qextscintillalexerbash.sip
share/sip/qtext/qextscintillalexercpp.sip
share/sip/qtext/qextscintillalexercsharp.sip
share/sip/qtext/qextscintillalexerhtml.sip