aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-24 13:03:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-24 13:03:30 +0000
commit38ccf246f52c3f1801e1468a169a24fa44d4009f (patch)
treef2fb0ef5bcd9240307dea2984758da0987b586f7
parent856ccec5913f8a1fe10efad8ff4d274e5cf2f3b4 (diff)
downloadports-38ccf246f52c3f1801e1468a169a24fa44d4009f.tar.gz
ports-38ccf246f52c3f1801e1468a169a24fa44d4009f.zip
Notes
-rw-r--r--devel/nuitka/Makefile2
-rw-r--r--devel/nuitka/distinfo6
-rw-r--r--devel/nuitka/files/patch-nuitka_build_SingleExe.scons26
3 files changed, 15 insertions, 19 deletions
diff --git a/devel/nuitka/Makefile b/devel/nuitka/Makefile
index 37310d5f37a9..b1042a31c40b 100644
--- a/devel/nuitka/Makefile
+++ b/devel/nuitka/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nuitka
-PORTVERSION= 0.5.22
+PORTVERSION= 0.5.24.4
CATEGORIES= devel python
MASTER_SITES= http://nuitka.net/releases/
DISTNAME= Nuitka-${PORTVERSION}
diff --git a/devel/nuitka/distinfo b/devel/nuitka/distinfo
index 4e2176a25a28..c2e5dcf27efd 100644
--- a/devel/nuitka/distinfo
+++ b/devel/nuitka/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471339534
-SHA256 (Nuitka-0.5.22.tar.bz2) = 9d4bce77c15e7aefba9ce934dc99ccdfd3106ef7cda09fba3769713a8ae086bd
-SIZE (Nuitka-0.5.22.tar.bz2) = 1203830
+TIMESTAMP = 1482515433
+SHA256 (Nuitka-0.5.24.4.tar.bz2) = ebeda4fe6efab02ac330222caaad7cfdd56b596e850c8e6dcaec292256c2c277
+SIZE (Nuitka-0.5.24.4.tar.bz2) = 1224571
diff --git a/devel/nuitka/files/patch-nuitka_build_SingleExe.scons b/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
index 5f333335ffe3..312def1e2713 100644
--- a/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
+++ b/devel/nuitka/files/patch-nuitka_build_SingleExe.scons
@@ -1,6 +1,6 @@
---- nuitka/build/SingleExe.scons.orig 2016-04-24 12:07:33 UTC
+--- nuitka/build/SingleExe.scons.orig 2016-12-10 11:05:24 UTC
+++ nuitka/build/SingleExe.scons
-@@ -110,9 +110,11 @@ uninstalled_python = getBoolOption("unin
+@@ -108,9 +108,11 @@ uninstalled_python = getBoolOption("unin
# Unstriped mode: Do not remove debug symbols.
unstripped_mode = getBoolOption("unstripped_mode", False)
@@ -14,21 +14,17 @@
clang_mode = True
# MinGW compiler mode, optional and interesting to Windows only.
-@@ -448,7 +450,7 @@ orig_cxx_version = env.get("CXXVERSION",
- if "g++" in (env["CXX"] or "") and "clang" not in (env["CXX"] or ""):
- gpp_version, compiler_arch = getGccVersion()
-
-- if gpp_version is None or int(gpp_version.replace('.', "")) < 440:
-+ if gpp_version is None or int(gpp_version.replace('.', "")) < 421:
- env["CXX"] = None
- elif win_target and compiler_arch != target_arch:
- env["CXX"] = None
-@@ -594,7 +596,7 @@ if "g++" in env["CXX"] and "clang" not i
+@@ -618,11 +620,11 @@ if gcc_mode and "clang" not in the_compi
# binary if it's not high enough. This is esp. useful under Debian which
# allows all compiler to exist next to each other and where g++ might not be
# good enough, but g++-4.5 would be.
-- if gpp_version < 440:
-+ if gpp_version < 421:
+- if gcc_version < "4.4":
++ if gcc_version < "4.2.1":
sys.exit(
"""\
- The g++ compiler %s (version %s) doesn't have the sufficient \
+ The gcc compiler %s (version %s) doesn't have the sufficient \
+-version (>= 4.4).""" % (env["CXX"], gcc_version)
++version (>= 4.2.1).""" % (env["CXX"], gcc_version)
+ )
+
+ # Older g++ complains about aliasing with Py_True and Py_False, but we don't