aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2021-06-22 18:32:49 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2021-06-22 18:37:54 +0000
commit3e10bb3eb73c13e52195e395e6d5150a37430c69 (patch)
treec3852c9380d096b7f11f939525baceb7471e5e19
parent99d908b22ee60aff6bad4d92f4b3ec14343d10c4 (diff)
downloadports-3e10bb3eb73c13e52195e395e6d5150a37430c69.tar.gz
ports-3e10bb3eb73c13e52195e395e6d5150a37430c69.zip
sysutils/py-salt: install zsh and bash completion files
Approved by: maintainer (cherry picked from commit 667772286cef83ac5592d3adf7267e51c5f3f2cf)
-rw-r--r--sysutils/py-salt/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index f8666be6b742..8ae87d94e147 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= salt
PORTVERSION= 3002.6
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -60,8 +61,8 @@ SUB_FILES= pkg-message
# Upstream archive contains files with UTF-8 names
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
-OPTIONS_DEFINE= AWS TCP ZEROMQ
-OPTIONS_DEFAULT=ZEROMQ
+OPTIONS_DEFINE= AWS BASH TCP ZEROMQ ZSH
+OPTIONS_DEFAULT= BASH ZEROMQ ZSH
AWS_DESC= Install dependencies required for Amazon Web Services
TCP_DESC= Install dependencies required for TCP transport
@@ -78,6 +79,9 @@ ZEROMQ_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.2.0:net/py-pyzmq@${PY_FLAV
ZEROMQ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.2.0:net/py-pyzmq@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycryptodomex>=3.9.7:security/py-pycryptodomex@${PY_FLAVOR}
+BASH_PLIST_FILES= share/bash-completion/completions/salt
+ZSH_PLIST_FILES= share/zsh/site-functions/_salt
+
post-patch:
.for file in conf/minion conf/master doc/man/salt-key.1 \
doc/man/salt-cp.1 doc/man/salt-minion.1 doc/man/salt-syndic.1 \
@@ -89,6 +93,16 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e 's|yumpkg5|pkgng|' ${WRKSRC}/conf/minion
+do-install-BASH-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions/
+ ${INSTALL_DATA} ${WRKSRC}/pkg/salt.bash \
+ ${STAGEDIR}${PREFIX}/share/bash-completion/completions/salt
+
+do-install-ZSH-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${WRKSRC}/pkg/zsh_completion.zsh \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_salt
+
post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/conf/master ${STAGEDIR}${ETCDIR}/master.sample