aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Timofeev <timp87@gmail.com>2021-06-23 21:26:32 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-23 21:29:37 +0000
commit3e55273e25e24d0707265e48545a31016e749db3 (patch)
treeeedee42b1bcbc1381b1b38a4996ba50aae857db4
parent3a4ec26f17b5742bfe91d9f2ab633e5d032a4a30 (diff)
downloadports-3e55273e25e24d0707265e48545a31016e749db3.tar.gz
ports-3e55273e25e24d0707265e48545a31016e749db3.zip
security/py-requests-credssp: Fix dependencies
The module requires and uses spnego for NTLM. PR: 256361 Approved by: maintainer timeout (cherry picked from commit b774f59d2df7d9df10c3b39f68796360e79c89e8)
-rw-r--r--security/py-requests-credssp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/py-requests-credssp/Makefile b/security/py-requests-credssp/Makefile
index 1c561a0841a4..7abb1f763bb1 100644
--- a/security/py-requests-credssp/Makefile
+++ b/security/py-requests-credssp/Makefile
@@ -1,6 +1,7 @@
PORTNAME= requests-credssp
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,12 +11,12 @@ COMMENT= Authentication handler for using CredSSP with Python Requests
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ntlm-auth>=0:security/py-ntlm-auth@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>=16.0.0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1:devel/py-pyasn1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyspnego>0:security/py-pyspnego@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils