aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShane <FreeBSD@ShaneWare.Biz>2021-06-15 15:17:41 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-15 15:22:06 +0000
commit4c97793261f24c42244f904b4dbfe50bbb734fb4 (patch)
treef54337dabc6d5f005ad3732743831d6acf2bd756
parent52617d7bda4f806b6f26e03506182411dcc8b877 (diff)
downloadports-4c97793261f24c42244f904b4dbfe50bbb734fb4.tar.gz
ports-4c97793261f24c42244f904b4dbfe50bbb734fb4.zip
devel/godot2: disable internal libs
Remove use of python2 for scons, builds fine with py3 scons Disable use of internal png, freetype and zlib. This matches ports for godot v3 and fixes build on powerpc64le. PR: 254867 Approved by: maintainer MFH: 2021Q2 (cherry picked from commit 56c603914f70b67f04164958ab80f7a0ebd2c0e0)
-rw-r--r--devel/godot2/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/godot2/Makefile b/devel/godot2/Makefile
index 2203e4b3e134..2a8a2733dd6a 100644
--- a/devel/godot2/Makefile
+++ b/devel/godot2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= godot
DISTVERSION= 2.1.6
+PORTREVISION= 1
DISTVERSIONSUFFIX= -stable
CATEGORIES= devel games
PKGNAMESUFFIX?= 2
@@ -22,14 +23,16 @@ RUN_DEPENDS= xdg-user-dir:devel/xdg-user-dirs \
xdg-open:devel/xdg-utils \
xmessage:x11/xmessage
-USES= compiler:c++11-lib gl pkgconfig scons:python2 ssl xorg
+USES= compiler:c++11-lib gl pkgconfig scons ssl xorg
USE_XORG= x11 xcursor xi xinerama xrandr
USE_GL= gl glu
USE_GITHUB= yes
GH_ACCOUNT= godotengine
-MAKE_ARGS+= platform=x11 builtin_speex=no builtin_libmpcdec=no verbose=yes
+MAKE_ARGS+= platform=x11 builtin_freetype=no builtin_libmpcdec=no \
+ builtin_libpng=no builtin_openssl=no builtin_speex=no \
+ builtin_zlib=no verbose=yes
MAKE_ARGS+= ${MAKE_ARGS_${CHOSEN_COMPILER_TYPE}}
MAKE_ARGS_clang= use_llvm=yes
CXXFLAGS+= -DGLEW_NO_GLU -DRTAUDIO_ENABLED -DCRIOGET_NOT_NEEDED