aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-04-16 17:18:00 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-04-16 17:18:00 +0000
commit67a6b983c3ce847e6a18048d7a2adc369c44bb02 (patch)
tree853813c305da03ad8a14d8963e74ef99f478cf37
parentbb447968c9342b56d6e30f684ef63eca9e123b22 (diff)
downloadports-67a6b983c3ce847e6a18048d7a2adc369c44bb02.tar.gz
ports-67a6b983c3ce847e6a18048d7a2adc369c44bb02.zip
mail/postgrey: fix conflict of PG_USER variable with PostgreSQL
Please note: 20180416: AFFECTS: users of mail/postgrey AUTHOR: ports.maintainer@evilphi.com If you use any of the optional make.conf variables to specify the postgrey user, group, db dir, or run dir when building the port, you will need to change the prefix from PG_ to POSTGREY_*. The variables were renamed to solve a namespace collision with the PostgreSQL ports. PR: 227261 Submitted by: Melissa Pilgrim <ports.maintainer@evilphi.com> (maintainer) Reported by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=467493
-rw-r--r--UPDATING9
-rw-r--r--mail/postgrey/Makefile34
-rw-r--r--mail/postgrey/pkg-plist4
3 files changed, 28 insertions, 19 deletions
diff --git a/UPDATING b/UPDATING
index d4b76d89bf0c..01b6965aa404 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,15 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20180416:
+ AFFECTS: users of mail/postgrey
+ AUTHOR: ports.maintainer@evilphi.com
+
+ If you use any of the optional make.conf variables to specify the
+ postgrey user, group, db dir, or run dir when building the port, you will
+ need to change the prefix from PG_ to POSTGREY_*. The variables were
+ renamed to solve a namespace collision with the PostgreSQL ports.
+
20180412:
AFFECTS: users of devel/php-composer
AUTHOT: madpilot@FreeBSD.org
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 4a965dda0fd7..b81f66e14832 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -3,7 +3,7 @@
PORTNAME= postgrey
PORTVERSION= 1.37
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://postgrey.schweikert.ch/pub/ \
http://postgrey.schweikert.ch/pub/old/
@@ -30,21 +30,21 @@ NO_BUILD= yes
POD2MAN?= pod2man
PORTDOCS= README Changes README.exim
-PG_DBDIR?= /var/db/postgrey
-PG_GROUP?= postgrey
-PG_RUNDIR?= /var/run/postgrey
-PG_USER?= postgrey
+POSTGREY_DBDIR?= /var/db/postgrey
+POSTGREY_GROUP?= postgrey
+POSTGREY_RUNDIR?= /var/run/postgrey
+POSTGREY_USER?= postgrey
-SUB_LIST= PG_DBDIR=${PG_DBDIR} \
- PG_RUNDIR=${PG_RUNDIR}
+SUB_LIST= POSTGREY_DBDIR=${POSTGREY_DBDIR} \
+ POSTGREY_RUNDIR=${POSTGREY_RUNDIR}
-PLIST_SUB+= PG_DBDIR=${PG_DBDIR} \
- PG_GROUP=${PG_GROUP} \
- PG_RUNDIR=${PG_RUNDIR} \
- PG_USER=${PG_USER}
+PLIST_SUB+= POSTGREY_DBDIR=${POSTGREY_DBDIR} \
+ POSTGREY_GROUP=${POSTGREY_GROUP} \
+ POSTGREY_RUNDIR=${POSTGREY_RUNDIR} \
+ POSTGREY_USER=${POSTGREY_USER}
-USERS= ${PG_USER}
-GROUPS= ${PG_GROUP}
+USERS= ${POSTGREY_USER}
+GROUPS= ${POSTGREY_GROUP}
MANPAGES= postgrey.1 policy-test.1 postgreyreport.1
ETCFILES= whitelist_clients whitelist_recipients
@@ -54,11 +54,11 @@ SHEBANG_FILES= postgrey policy-test contrib/postgreyreport
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's#nogroup#${PG_GROUP}#' \
+ @${REINPLACE_CMD} -e 's#nogroup#${POSTGREY_GROUP}#' \
-e 's#/etc/main.cf#/etc/postfix/main.cf#' ${WRKSRC}/postgrey
@${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' \
${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
- @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PG_DBDIR}#' \
+ @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${POSTGREY_DBDIR}#' \
${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
do-install:
@@ -69,8 +69,8 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${STAGEDIR}${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport \
${STAGEDIR}${PREFIX}/sbin
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/postfix ${STAGEDIR}${PG_DBDIR} \
- ${STAGEDIR}${PG_RUNDIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/postfix ${STAGEDIR}${POSTGREY_DBDIR} \
+ ${STAGEDIR}${POSTGREY_RUNDIR}
.for i in ${ETCFILES}
${INSTALL_DATA} ${WRKSRC}/postgrey_${i} \
${STAGEDIR}${PREFIX}/etc/postfix/postgrey_${i}.sample
diff --git a/mail/postgrey/pkg-plist b/mail/postgrey/pkg-plist
index abffab1d1914..36a1bdbb84de 100644
--- a/mail/postgrey/pkg-plist
+++ b/mail/postgrey/pkg-plist
@@ -7,5 +7,5 @@ sbin/postgrey
sbin/policy-test
sbin/postgreyreport
@dir etc/postfix
-@dir(%%PG_USER%%,%%PG_GROUP%%,750) %%PG_DBDIR%%
-@dir(%%PG_USER%%,%%PG_GROUP%%,750) %%PG_RUNDIR%%
+@dir(%%POSTGREY_USER%%,%%POSTGREY_GROUP%%,750) %%POSTGREY_DBDIR%%
+@dir(%%POSTGREY_USER%%,%%POSTGREY_GROUP%%,750) %%POSTGREY_RUNDIR%%