aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-05-08 17:04:15 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-05-08 17:04:15 +0000
commit8f44911ca6552512de31daadca959fdc0228b4b0 (patch)
tree1449155b6de3f6f15ae7586dd188fe11e255967c
parent221c84a5138f2ac5163b8127999ec6b11af526dd (diff)
downloadports-8f44911ca6552512de31daadca959fdc0228b4b0.tar.gz
ports-8f44911ca6552512de31daadca959fdc0228b4b0.zip
Notes
-rw-r--r--devel/tcl-trf/Makefile2
-rw-r--r--devel/tcl-trf/files/patch-rmd12824
2 files changed, 25 insertions, 1 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index 9c487beaacb7..da639302552e 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Trf
PORTVERSION= 2.1p2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel tcl${TCL_VER:S/.//}
MASTER_SITES= http://www.oche.de/~akupries/soft/trf/download/
PKGNAMEPREFIX= tcl-
diff --git a/devel/tcl-trf/files/patch-rmd128 b/devel/tcl-trf/files/patch-rmd128
new file mode 100644
index 000000000000..0936f10bf452
--- /dev/null
+++ b/devel/tcl-trf/files/patch-rmd128
@@ -0,0 +1,24 @@
+Patch obtained from the TRF's CVS... Many thanks to Denis Shaposhnikov
+for finding it.
+
+TRF's RIPEMD160 implementation suffered from the same problem, but this
+port does not use it.
+
+ -mi
+
+--- generic/rmd128.c Wed Aug 9 15:13:18 2000
++++ generic/rmd128.c Mon May 8 12:52:04 2006
+@@ -46,5 +46,5 @@
+ typedef struct ripemd_context {
+ dword state [5]; /* state variables of ripemd-128 */
+- byte buf [CHUNK_SIZE]; /* buffer of 15-dword's */
++ byte buf [CHUNK_SIZE]; /* buffer of 16-dword's */
+ byte byteCount; /* number of bytes in buffer */
+ dword lowc; /* lower half of a 64bit counter */
+@@ -235,5 +235,5 @@
+ } /* k == CHUNK_SIZE => internal buffer was empty, so skip it entirely */
+
+- while (bufLen > CHUNK_SIZE) {
++ while (bufLen >= CHUNK_SIZE) {
+ CountLength (ctx, CHUNK_SIZE);
+