aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid O'Rourke <dor.bsd@xm0.uk>2021-06-15 14:53:45 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-06-15 14:55:34 +0000
commit914092bdcf3ca9e6dfd2915038e252aec8880780 (patch)
tree24db34ec344b16623fdaa593a48a7a3ae1dcaa49
parentb8723f121c7719284b01a1c32a725528d5e9023f (diff)
downloadports-914092bdcf3ca9e6dfd2915038e252aec8880780.tar.gz
ports-914092bdcf3ca9e6dfd2915038e252aec8880780.zip
multimedia/libhdhomerun: Update to 20200907
Changes https://www.silicondust.com/support/downloads/software-changelog/ PR: 251088 Approved by: maintainer MFH: 2021Q2 (cherry picked from commit 63bb888a3d08b7298e9563a73dd371f40d9838a7)
-rw-r--r--multimedia/libhdhomerun/Makefile3
-rw-r--r--multimedia/libhdhomerun/distinfo6
-rw-r--r--multimedia/libhdhomerun/files/patch-hdhomerun__discover.c35
3 files changed, 4 insertions, 40 deletions
diff --git a/multimedia/libhdhomerun/Makefile b/multimedia/libhdhomerun/Makefile
index f32bfd5f2b9f..126481e18e23 100644
--- a/multimedia/libhdhomerun/Makefile
+++ b/multimedia/libhdhomerun/Makefile
@@ -1,7 +1,6 @@
PORTNAME= libhdhomerun
-PORTVERSION= 20190621
-PORTREVISION= 1
+PORTVERSION= 20200907
CATEGORIES= multimedia
MASTER_SITES= https://download.silicondust.com/hdhomerun/
DISTNAME= ${PORTNAME}_${PORTVERSION}
diff --git a/multimedia/libhdhomerun/distinfo b/multimedia/libhdhomerun/distinfo
index d81a9b6bec5f..2bb77b2f9efc 100644
--- a/multimedia/libhdhomerun/distinfo
+++ b/multimedia/libhdhomerun/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1569315689
-SHA256 (libhdhomerun_20190621.tgz) = 9a60f663b00de5f820bdb85806662e25f22da248b14942e33a8b43a0331f855a
-SIZE (libhdhomerun_20190621.tgz) = 50817
+TIMESTAMP = 1623768784
+SHA256 (libhdhomerun_20200907.tgz) = cbaeb779c5a4e07db45310ef4271872bcb7c472402ebc3c58e224653c09400ed
+SIZE (libhdhomerun_20200907.tgz) = 51014
diff --git a/multimedia/libhdhomerun/files/patch-hdhomerun__discover.c b/multimedia/libhdhomerun/files/patch-hdhomerun__discover.c
deleted file mode 100644
index 088440edc395..000000000000
--- a/multimedia/libhdhomerun/files/patch-hdhomerun__discover.c
+++ /dev/null
@@ -1,35 +0,0 @@
-# Backport FreeBSD broadcast patch
-# https://github.com/Silicondust/libhdhomerun/commit/b0e5d5f5c8e2bf37dea34beb014e08ebb598ebf6
-
---- hdhomerun_discover.c.orig 2019-09-30 16:45:23 UTC
-+++ hdhomerun_discover.c
-@@ -183,7 +183,8 @@ static bool hdhomerun_discover_send(struct hdhomerun_d
- unsigned int i;
- for (i = 1; i < ds->sock_count; i++) {
- struct hdhomerun_discover_sock_t *dss = &ds->socks[i];
--
-+ uint32_t send_ip = target_ip;
-+
- if (target_ip != 0xFFFFFFFF) {
- if (dss->subnet_mask == 0) {
- continue;
-@@ -193,7 +194,18 @@ static bool hdhomerun_discover_send(struct hdhomerun_d
- }
- }
-
-- result |= hdhomerun_discover_send_internal(ds, dss, target_ip, device_type, device_id);
-+#if defined(IP_ONESBCAST)
-+ /* FreeBSD special handling - send subnet broadcast */
-+ if (target_ip == 0xFFFFFFFF) {
-+ send_ip = dss->local_ip | ~dss->subnet_mask;
-+
-+ if ((send_ip == 0x00000000) || (send_ip == 0xFFFFFFFF)) {
-+ continue;
-+ }
-+ }
-+#endif
-+
-+ result |= hdhomerun_discover_send_internal(ds, dss, send_ip, device_type, device_id);
- }
-
- /*