aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:25:33 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:25:33 +0000
commit9619fa8313432f4c5aeb71cfa83b805a939f4a2c (patch)
tree6373c5c790efec30020ece5a96a7d29c4c977ec2
parent3ed8c29cfca93666aa8cdd5cfb11c939216566f0 (diff)
downloadports-9619fa8313432f4c5aeb71cfa83b805a939f4a2c.tar.gz
ports-9619fa8313432f4c5aeb71cfa83b805a939f4a2c.zip
Notes
-rw-r--r--x11-toolkits/bakery/Makefile13
-rw-r--r--x11-toolkits/bakery/distinfo2
-rw-r--r--x11-toolkits/bakery/files/patch-bakery_App_App.h11
-rw-r--r--x11-toolkits/bakery/files/patch-bakery_FileSelection_FileSelection.h11
-rw-r--r--x11-toolkits/bakery/pkg-descr6
-rw-r--r--x11-toolkits/bakery/pkg-plist52
6 files changed, 41 insertions, 54 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index 2dc5a6d99b0a..e3928db1b993 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= bakery
-PORTVERSION= 1.0.2
+PORTVERSION= 1.3.11
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A C++ Application Framework for use with Gnome--
+COMMENT= A C++ Application Framework for use with Gtkmm
-LIB_DEPENDS= gnomemm-1.2.10:${PORTSDIR}/x11-toolkits/gnome--
-
-IGNORE= "Obsolete; will be upgraded to 1.3.x after the 5.2 freeze"
+LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+ gconfmm-2.0:${PORTSDIR}/devel/gconfmm \
+ glademm-2.0:${PORTSDIR}/devel/libglademm \
+ xml\\+\\+-0.1:${PORTSDIR}/textproc/libxml++
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack gnometarget
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/x11-toolkits/bakery/distinfo b/x11-toolkits/bakery/distinfo
index 4e9f92c4b547..9960570ef273 100644
--- a/x11-toolkits/bakery/distinfo
+++ b/x11-toolkits/bakery/distinfo
@@ -1 +1 @@
-MD5 (bakery-1.0.2.tar.gz) = 1d69d3f206e9c579baf64d03ba91ad83
+MD5 (bakery-1.3.11.tar.gz) = 1ca70f933c8f5432e996b94e9f6f81a7
diff --git a/x11-toolkits/bakery/files/patch-bakery_App_App.h b/x11-toolkits/bakery/files/patch-bakery_App_App.h
deleted file mode 100644
index fe5482eaccc5..000000000000
--- a/x11-toolkits/bakery/files/patch-bakery_App_App.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- bakery/App/App.h.orig Sun Dec 1 20:26:16 2002
-+++ bakery/App/App.h Sun Dec 1 20:26:11 2002
-@@ -19,6 +19,8 @@
- #ifndef BAKERY_APP_H
- #define BAKERY_APP_H
-
-+using namespace std;
-+
- #include <gnome--.h>
- #include "libgnome/gnome-util.h" //For ::gnome_pixmap_file().
- #include <gtk--.h>
diff --git a/x11-toolkits/bakery/files/patch-bakery_FileSelection_FileSelection.h b/x11-toolkits/bakery/files/patch-bakery_FileSelection_FileSelection.h
deleted file mode 100644
index 387feceabfb7..000000000000
--- a/x11-toolkits/bakery/files/patch-bakery_FileSelection_FileSelection.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- bakery/FileSelection/FileSelection.h.orig Wed Dec 4 12:58:55 2002
-+++ bakery/FileSelection/FileSelection.h Wed Dec 4 12:59:02 2002
-@@ -43,7 +43,7 @@
- : public Gtk::FileSelection
- {
- public:
-- FileSelection(const Gtk::nstring& title = 0);
-+ FileSelection(const Gtk::nstring&);
- virtual ~FileSelection();
-
- virtual bool run(); //returns false if nothing was selected.
diff --git a/x11-toolkits/bakery/pkg-descr b/x11-toolkits/bakery/pkg-descr
index f25efbd3f5be..611f10d25597 100644
--- a/x11-toolkits/bakery/pkg-descr
+++ b/x11-toolkits/bakery/pkg-descr
@@ -1,11 +1,9 @@
-Bakery is a C++ Framework for creating GNOME applications using
-Gnome-- and Gtk--.
+Bakery is a C++ Framework for creating applications using Gtkmm.
- provides a Document/View architecture, but it doesn't force you to
use the whole architecture.
- provides default functionality, which can be easily customized.
-- makes it easy to start developing GNOME applications.
+- makes it easy to start developing GTK+ applications.
- gives your application structure.
-- will provide easy access to GNOME technologies such as Bonobo and GConf.
WWW: http://bakery.sourceforge.net/
diff --git a/x11-toolkits/bakery/pkg-plist b/x11-toolkits/bakery/pkg-plist
index bd3c77a2eb36..ddf8b06d21d6 100644
--- a/x11-toolkits/bakery/pkg-plist
+++ b/x11-toolkits/bakery/pkg-plist
@@ -1,21 +1,31 @@
-bin/bakery-config
-include/bakery-1.0/bakery/App/App.h
-include/bakery-1.0/bakery/App/App_WithDoc.h
-include/bakery-1.0/bakery/App/Dialog_OfferSave.h
-include/bakery-1.0/bakery/App/Dialog_OverwriteFile.h
-include/bakery-1.0/bakery/Document/Document.h
-include/bakery-1.0/bakery/FileSelection/FileSelection.h
-include/bakery-1.0/bakery/View/View.h
-include/bakery-1.0/bakery/View/ViewBase.h
-include/bakery-1.0/bakery/View/View_Composite.h
-include/bakery-1.0/bakery/bakery.h
-lib/libbakery.a
-lib/libbakery.so
-lib/libbakery-1.0.so.5
-share/aclocal/bakery.m4
-@dirrm include/bakery-1.0/bakery/View
-@dirrm include/bakery-1.0/bakery/FileSelection
-@dirrm include/bakery-1.0/bakery/Document
-@dirrm include/bakery-1.0/bakery/App
-@dirrm include/bakery-1.0/bakery
-@dirrm include/bakery-1.0
+include/bakery-2.0/bakery/App/App.h
+include/bakery-2.0/bakery/App/AppInstanceManager.h
+include/bakery-2.0/bakery/App/App_Gtk.h
+include/bakery-2.0/bakery/App/App_WithDoc.h
+include/bakery-2.0/bakery/App/App_WithDoc_Gtk.h
+include/bakery-2.0/bakery/App/Dialog_OfferSave.h
+include/bakery-2.0/bakery/App/Dialog_OverwriteFile.h
+include/bakery-2.0/bakery/App/GtkDialogs.h
+include/bakery-2.0/bakery/Configuration/Association.h
+include/bakery-2.0/bakery/Configuration/AssociationBase.h
+include/bakery-2.0/bakery/Configuration/Client.h
+include/bakery-2.0/bakery/Configuration/Dialog_Preferences.h
+include/bakery-2.0/bakery/Document/Document.h
+include/bakery-2.0/bakery/Document/Document_XML.h
+include/bakery-2.0/bakery/Utilities/BusyCursor.h
+include/bakery-2.0/bakery/View/View.h
+include/bakery-2.0/bakery/View/ViewBase.h
+include/bakery-2.0/bakery/View/View_Composite.h
+include/bakery-2.0/bakery/bakery.h
+include/bakery-2.0/bakery/init.h
+lib/libbakery-1.3.a
+lib/libbakery-1.3.so
+lib/libbakery-1.3.so.11
+libdata/pkgconfig/bakery-2.0.pc
+@dirrm include/bakery-2.0/bakery/View
+@dirrm include/bakery-2.0/bakery/Utilities
+@dirrm include/bakery-2.0/bakery/Document
+@dirrm include/bakery-2.0/bakery/Configuration
+@dirrm include/bakery-2.0/bakery/App
+@dirrm include/bakery-2.0/bakery
+@dirrm include/bakery-2.0