aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-09 16:45:33 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-09 16:45:33 +0000
commit982ae473195a02d9f8dbcce24e592d961c2637c1 (patch)
tree2140eb769832642efa6467ee3ce2ae0908fc4c9a
parent17b54d4ed8d6bf7e33d4cb403c8b373caf2b75dc (diff)
downloadports-982ae473195a02d9f8dbcce24e592d961c2637c1.tar.gz
ports-982ae473195a02d9f8dbcce24e592d961c2637c1.zip
Notes
-rw-r--r--net/samba3/Makefile54
-rw-r--r--net/samba3/distinfo5
-rw-r--r--net/samba3/files/patch-Makefile.in31
-rw-r--r--net/samba3/files/patch-configure.in66
-rw-r--r--net/samba3/files/patch-nsswitch_pam_winbind.c36
-rw-r--r--net/samba3/files/patch-pam_smbpass88
-rw-r--r--net/samba3/files/patch-smbd_aio.c33
-rw-r--r--net/samba3/files/patch-smbd_statvfs.c47
-rw-r--r--net/samba3/files/samba.sh.sample7
-rw-r--r--net/samba3/files/smb.conf.default5
-rw-r--r--net/samba3/pkg-plist19
11 files changed, 340 insertions, 51 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 7f4f031df443..fbff1d47d1ea 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= samba
-PORTVERSION?= 3.0.20b
+PORTVERSION?= 3.0.21a
PORTREVISION?= 0
PORTEPOCH?= 1
CATEGORIES?= net
@@ -20,8 +20,8 @@ COMMENT?= A free SMB and CIFS client and server for UNIX
CONFLICTS?= ja-samba-2.* ja-samba-3.* samba-2.* sharity-light-1.*
USE_ICONV= yes
-GNU_CONFIGURE= yes
-#USE_AUTOTOOLS= autoconf:259 autoheader:259
+#GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:259 autoheader:259
LATEST_LINK?= ${PKGNAMEPREFIX}${PORTNAME}3${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
@@ -54,8 +54,25 @@ CONFIGURE_ARGS+= --exec-prefix=${PREFIX} \
CONFIGURE_ARGS+= --with-libiconv=${LOCALBASE}
-.if !defined(SAMBA_SUBPORT)
+.if defined(SAMBA_SUBPORT)
+# Switch off all extra functionality
+CONFIGURE_ARGS+= --disable-cups
+
+CONFIGURE_ARGS+= --without-ldap
+CONFIGURE_ARGS+= --without-krb5
+CONFIGURE_ARGS+= --without-ads
+
+CONFIGURE_ARGS+= --without-winbind
+CONFIGURE_ARGS+= --without-syslog
+CONFIGURE_ARGS+= --without-quotas
+CONFIGURE_ARGS+= --without-utmp
+CONFIGURE_ARGS+= --without-ldapsam
+CONFIGURE_ARGS+= --without-pam
+CONFIGURE_ARGS+= --without-pam_smbpass
+CONFIGURE_ARGS+= --without-aio-support
+.else
+# Samba server itself
OPTIONS= LDAP "With LDAP support" on \
ADS "With Active Directory support" off \
CUPS "With CUPS printing support" on \
@@ -82,7 +99,8 @@ OPTIONS= LDAP "With LDAP support" on \
USE_RC_SUBR= yes
CONFIGURE_ARGS+= --with-pam --with-readline --with-sendfile-support \
- --without-libsmbclient --without-python
+ --without-libsmbclient --without-libmsrpc \
+ --without-libsmbsharemodes --without-python
.if !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
@@ -198,7 +216,8 @@ CONFIGURE_ARGS+= --with-acl-support
.endif
.if defined(WITH_AIO_SUPPORT)
-CONFIGURE_ARGS+= --with-aio-support
+# Yes, it doesn't work for now
+CONFIGURE_ARGS+= --without-aio-support
.endif
.if !defined(WITHOUT_POPT)
@@ -207,16 +226,11 @@ LIB_DEPENDS+= popt.0:${PORTSDIR}/devel/popt
CONFIGURE_ARGS+= --with-included-popt
.endif
-# !SAMBA_SUBPORT
-.endif
-
-# Common part
-
# For 4.8 - 4.11 combination of Kerberos and OpenLDAP is broken
# due the conflict between system and OpenSSL port libcrypto libraries
.if ${OSVERSION} > 470103 && ${OSVERSION} < 500000
.if defined(WITH_ADS)
-IGNORE= "Broken dependency between OpenSSL, OpenLDAP and Heimdal for FreeBSD 4.x. Disable ADS support"
+IGNORE= broken dependency between OpenSSL, OpenLDAP and Heimdal for FreeBSD 4.x. Disable ADS support
.endif
WITHOUT_ADS= on
.endif
@@ -251,18 +265,18 @@ CONFIGURE_ARGS+= --with-ldap
CONFIGURE_ARGS+= --without-ldap
.endif
-.if !defined(SAMBA_SUBPORT)
MAN1= findsmb.1 log2pcap.1 nmblookup.1 ntlm_auth.1 profiles.1 \
rpcclient.1 smbcacls.1 smbclient.1 smbcontrol.1 smbcquotas.1 \
smbget.1 smbsh.1 smbstatus.1 smbtar.1 smbtree.1 testparm.1 \
- testprns.1 vfstest.1
+ vfstest.1
MAN5= lmhosts.5 smb.conf.5 smbgetrc.5 smbpasswd.5
MAN7= samba.7
-MAN8= nmbd.8 smbd.8 net.8 pdbedit.8 smbpasswd.8 smbspool.8 \
- swat.8 tdbdump.8 tdbbackup.8
+MAN8= net.8 nmbd.8 pdbedit.8 smbd.8 smbpasswd.8 smbspool.8 \
+ swat.8 tdbbackup.8 tdbdump.8
.if !defined(WITHOUT_WINBIND)
MAN1+= wbinfo.1
-MAN8+= pam_winbind.8 winbindd.8
+MAN7+= pam_winbind.7
+MAN8+= winbindd.8
.endif
.if !defined(WITHOUT_WINBIND)
@@ -294,10 +308,9 @@ pre-fetch:
post-patch:
@${RM} -rf ${WRKDIR}/${DISTNAME}/examples/LDAP/smbldap-tools-*
@${RM} -rf ${WRKDIR}/${DISTNAME}/examples/libsmbclient
+ @${RM} -rf ${WRKDIR}/${DISTNAME}/examples/libmsrpc
@${RM} -rf ${WRKDIR}/${DISTNAME}/swat/lang
- -@${MV} -f ${WRKDIR}/${DISTNAME}/docs/htmldocs/manpages-3 \
- ${WRKDIR}/${DISTNAME}/docs/htmldocs/manpages
- @${RM} -f ${WRKDIR}/${DISTNAME}/docs/htmldocs/manpages/libsmbclient.8.html
+ @${RM} -f ${WRKDIR}/${DISTNAME}/docs/htmldocs/manpages/libsmbclient.7.html
@${FIND} ${WRKSRC} -name CVS -o -name .cvsignore | ${XARGS} ${RM}
@${FIND} ${WRKDIR}/${DISTNAME} -type d | ${XARGS} ${CHMOD} u+w,a+rx
@${FIND} ${WRKDIR}/${DISTNAME} -type f | ${XARGS} ${CHMOD} u+w,a+r
@@ -383,6 +396,7 @@ post-install:
WHATSNEW.txt docs/THANKS docs/history
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/${f} ${DOCSDIR}
.endfor
+# !NOPORTDOCS
.endif
@${CAT} ${PKGMESSAGE}
# !SAMBA_SUBPORT
diff --git a/net/samba3/distinfo b/net/samba3/distinfo
index 89b5f43f6cd9..3b6e3c64191d 100644
--- a/net/samba3/distinfo
+++ b/net/samba3/distinfo
@@ -1,2 +1,3 @@
-MD5 (samba-3.0.20b.tar.gz) = 39c0cae08fe0224cb003aa0af97d3050
-SIZE (samba-3.0.20b.tar.gz) = 17165513
+MD5 (samba-3.0.21a.tar.gz) = b5306d2681e97e4499daf7845581d116
+SHA256 (samba-3.0.21a.tar.gz) = 8f4902db38b20601cc3315fe9516a9380b067678c5a6828bd67e5a8bc46b097c
+SIZE (samba-3.0.21a.tar.gz) = 17524018
diff --git a/net/samba3/files/patch-Makefile.in b/net/samba3/files/patch-Makefile.in
index b91e88f6b97f..009b68c5fc0a 100644
--- a/net/samba3/files/patch-Makefile.in
+++ b/net/samba3/files/patch-Makefile.in
@@ -1,25 +1,14 @@
---- Makefile.in.orig Tue Jul 12 18:42:55 2005
-+++ Makefile.in Fri Jul 22 04:03:37 2005
-@@ -97,6 +97,7 @@
- LIBSMBCLIENT_MAJOR=0
- LIBSMBCLIENT_MINOR=1
+--- Makefile.in.orig Wed Dec 14 13:45:49 2005
++++ Makefile.in Sun Jan 1 03:35:30 2006
+@@ -676,6 +676,7 @@
-+NSS_VERSION=1
-
- FLAGS1 = $(CFLAGS) @FLAGS1@ -Iinclude -I$(srcdir)/include -I$(srcdir)/ubiqx @SMBWRAP_INC@ -I. $(CPPFLAGS) -I$(srcdir)
- FLAGS2 =
-@@ -987,8 +988,8 @@
- @SONAMEFLAG@`basename $@`
+ CAC_PICOBJS = $(CAC_OBJ:.o=.@PICSUFFIX@)
- bin/libsmbclient.@SHLIBEXT@: $(LIBSMBCLIENT_PICOBJS)
-- @echo Linking libsmbclient shared library $@
-- @$(SHLD) $(LDSHFLAGS) -o $@ $(LIBSMBCLIENT_PICOBJS) $(LDFLAGS) $(LIBS) \
-+ @echo Linking libsmbclient shared library $@.$(LIBSMBCLIENT_MAJOR)
-+ @$(SHLD) $(LDSHFLAGS) -o $@.$(LIBSMBCLIENT_MAJOR) $(LIBSMBCLIENT_PICOBJS) $(LDFLAGS) $(LIBS) \
- $(KRB5LIBS) $(LDAP_LIBS) \
- @SONAMEFLAG@`basename $@`.$(LIBSMBCLIENT_MAJOR)
++NSS_VERSION=1
-@@ -1082,13 +1083,13 @@
+ PAM_SMBPASS_OBJ_0 = pam_smbpass/pam_smb_auth.o pam_smbpass/pam_smb_passwd.o \
+ pam_smbpass/pam_smb_acct.o pam_smbpass/support.o \
+@@ -1172,13 +1173,13 @@
@WINBIND_NSS@: $(WINBIND_NSS_PICOBJS)
@echo "Linking $@"
@$(SHLD) $(WINBIND_NSS_LDSHFLAGS) -o $@ $(WINBIND_NSS_PICOBJS) \
@@ -35,11 +24,11 @@
nsswitch/pam_winbind.@SHLIBEXT@: $(PAM_WINBIND_PICOBJ) bin/.dummy
@echo "Linking $@"
-@@ -1295,7 +1296,7 @@
+@@ -1389,7 +1390,7 @@
bin/t_snprintf@EXEEXT@: lib/snprintf.c
$(CC) $(FLAGS) @PIE_LDFLAGS@ -o $@ $(DYNEXP) -DTEST_SNPRINTF lib/snprintf.c -lm
--install: installbin installman installscripts installdat installswat installmodules @INSTALLCLIENT@
+-install: installbin installman installscripts installdat installswat installmodules @INSTALL_LIBSMBCLIENT@ @INSTALL_LIBMSRPC@
+install: installbin installscripts installdat installswat installmodules
install-everything: install installmodules
diff --git a/net/samba3/files/patch-configure.in b/net/samba3/files/patch-configure.in
new file mode 100644
index 000000000000..0aac713614cc
--- /dev/null
+++ b/net/samba3/files/patch-configure.in
@@ -0,0 +1,66 @@
+--- configure.in.orig Tue Jul 12 18:42:55 2005
++++ configure.in Tue Jul 26 19:19:40 2005
+@@ -909,6 +909,21 @@
+ AC_DEFINE(HAVE_SIG_ATOMIC_T_TYPE,1,[Whether we have the atomic_t variable type])
+ fi
+
++AC_CACHE_CHECK([for struct sigevent type],samba_cv_struct_sigevent, [
++ AC_TRY_COMPILE([
++#include <sys/types.h>
++#if STDC_HEADERS
++#include <stdlib.h>
++#include <stddef.h>
++#endif
++#include <signal.h>],[struct sigevent s;],
++ samba_cv_struct_sigevent=yes,samba_cv_struct_sigevent=no)])
++if test x"$samba_cv_struct_sigevent" = x"yes"; then
++ AC_DEFINE(HAVE_STRUCT_SIGEVENT,1,[Whether we have the struct sigevent])
++ AC_CHECK_MEMBERS([struct sigevent.sigev_value.sival_ptr,struct sigevent.sigev_value.sigval_ptr],,,
++ [#include <signal.h>])
++fi
++
+ AC_CACHE_CHECK([for struct timespec type],samba_cv_struct_timespec, [
+ AC_TRY_COMPILE([
+ #include <sys/types.h>
+@@ -4104,30 +4119,28 @@
+
+ case "$host_os" in
+ *)
+- AC_CHECK_LIB(rt,aio_read,[AIO_LIBS="$ACL_LIBS -lrt"])
++ ac_cv_save_LIBS=$LIBS
++ AC_SEARCH_LIBS(aio_read, [rt], [
++ if test "$ac_cv_search_aio_read" != "none required"; then
++ LIBS="$LIBS $ac_cv_search_aio_read"
++ fi
++ ])
+ AC_CACHE_CHECK([for asynchronous io support],samba_cv_HAVE_AIO,[
+- aio_LIBS=$LIBS
+- LIBS="$LIBS -lrt"
+ AC_TRY_LINK([#include <sys/types.h>
+ #include <aio.h>],
+ [ struct aiocb a; return aio_read(&a);],
+-samba_cv_HAVE_AIO=yes,samba_cv_HAVE_AIO=no)
+- LIBS=$aio_LIBS])
++samba_cv_HAVE_AIO=yes,samba_cv_HAVE_AIO=no)])
+ AC_CACHE_CHECK([for 64-bit asynchronous io support],samba_cv_HAVE_AIO64,[
+- aio_LIBS=$LIBS
+- LIBS="$LIBS -lrt"
+ AC_TRY_LINK([#include <sys/types.h>
+ #include <aio.h>],
+ [ struct aiocb64 a; return aio_read64(&a);],
+-samba_cv_HAVE_AIO64=yes,samba_cv_HAVE_AIO64=no)
+- LIBS=$aio_LIBS])
++samba_cv_HAVE_AIO64=yes,samba_cv_HAVE_AIO64=no)])
++
+ if test x"$samba_cv_HAVE_AIO64" = x"yes"; then
+ AC_DEFINE(HAVE_AIOCB64,1,[Whether 64 bit aio is available])
+- AC_DEFINE(WITH_AIO, 1, [Using asynchronous io])
+- LIBS="$LIBS -lrt"
++ AC_DEFINE(WITH_AIO,1,[Using asynchronous io])
+ elif test x"$samba_cv_HAVE_AIO" = x"yes"; then
+- AC_DEFINE(WITH_AIO, 1, [Using asynchronous io])
+- LIBS="$LIBS -lrt"
++ AC_DEFINE(WITH_AIO,1,[Using asynchronous io])
+ fi
+ ;;
+ esac
diff --git a/net/samba3/files/patch-nsswitch_pam_winbind.c b/net/samba3/files/patch-nsswitch_pam_winbind.c
new file mode 100644
index 000000000000..d0101bc7175e
--- /dev/null
+++ b/net/samba3/files/patch-nsswitch_pam_winbind.c
@@ -0,0 +1,36 @@
+--- nsswitch/pam_winbind.c.orig Thu Sep 29 23:52:42 2005
++++ nsswitch/pam_winbind.c Mon Jan 2 03:40:23 2006
+@@ -86,7 +86,7 @@
+ struct pam_response *resp;
+
+ pmsg[0] = &msg[0];
+- msg[0].msg = text;
++ msg[0].msg = CONST_DISCARD(char *, text);
+ msg[0].msg_style = type;
+
+ resp = NULL;
+@@ -359,7 +359,7 @@
+ if (comment != NULL) {
+ pmsg[0] = &msg[0];
+ msg[0].msg_style = PAM_TEXT_INFO;
+- msg[0].msg = comment;
++ msg[0].msg = CONST_DISCARD(char *, comment);
+ i = 1;
+ } else {
+ i = 0;
+@@ -367,13 +367,13 @@
+
+ pmsg[i] = &msg[i];
+ msg[i].msg_style = PAM_PROMPT_ECHO_OFF;
+- msg[i++].msg = prompt1;
++ msg[i++].msg = CONST_DISCARD(char *, prompt1);
+ replies = 1;
+
+ if (prompt2 != NULL) {
+ pmsg[i] = &msg[i];
+ msg[i].msg_style = PAM_PROMPT_ECHO_OFF;
+- msg[i++].msg = prompt2;
++ msg[i++].msg = CONST_DISCARD(char *, prompt2);
+ ++replies;
+ }
+ /* so call the conversation expecting i responses */
diff --git a/net/samba3/files/patch-pam_smbpass b/net/samba3/files/patch-pam_smbpass
new file mode 100644
index 000000000000..15e1292ad26c
--- /dev/null
+++ b/net/samba3/files/patch-pam_smbpass
@@ -0,0 +1,88 @@
+--- pam_smbpass/general.h.orig Fri Feb 25 18:59:30 2005
++++ pam_smbpass/general.h Mon Jan 2 03:47:49 2006
+@@ -50,10 +50,6 @@
+ #define set(x,ctrl) (ctrl = ((ctrl)&smb_args[x].mask)|smb_args[x].flag)
+ #define unset(x,ctrl) (ctrl &= ~(smb_args[x].flag))
+
+-#ifndef __linux__
+-#define strncasecmp(s1,s2,n) StrnCaseCmp(s1,s2,n)
+-#endif
+-
+ /* the generic mask */
+ #define _ALL_ON_ (~0U)
+
+--- pam_smbpass/pam_smb_auth.c.orig Tue Oct 18 04:44:59 2005
++++ pam_smbpass/pam_smb_auth.c Mon Jan 2 03:47:49 2006
+@@ -163,7 +163,7 @@
+
+ retval = PAM_SUCCESS;
+
+- pam_get_data(pamh, "smb_setcred_return", (const void **) &pretval);
++ pam_get_data(pamh, "smb_setcred_return", (void **) &pretval);
+ if(pretval) {
+ retval = *pretval;
+ SAFE_FREE(pretval);
+--- pam_smbpass/pam_smb_passwd.c.orig Thu Jul 28 15:19:44 2005
++++ pam_smbpass/pam_smb_passwd.c Mon Jan 2 03:47:49 2006
+@@ -224,7 +224,7 @@
+ (const void **)&pass_old );
+ } else {
+ retval = pam_get_data( pamh, _SMB_OLD_AUTHTOK,
+- (const void **)&pass_old );
++ (void **)&pass_old );
+ if (retval == PAM_NO_MODULE_DATA) {
+ pass_old = NULL;
+ retval = PAM_SUCCESS;
+--- pam_smbpass/support.c.orig Thu Jul 28 15:19:44 2005
++++ pam_smbpass/support.c Mon Jan 2 03:47:49 2006
+@@ -114,7 +114,7 @@
+ struct pam_response *resp;
+
+ pmsg[0] = &msg[0];
+- msg[0].msg = text;
++ msg[0].msg = CONST_DISCARD(char *, text);
+ msg[0].msg_style = type;
+ resp = NULL;
+
+@@ -384,7 +384,7 @@
+ if (newauth != NULL) {
+
+ /* any previous failures for this user ? */
+- pam_get_data(pamh, data_name, (const void **) &old);
++ pam_get_data(pamh, data_name, (void **) &old);
+
+ if (old != NULL) {
+ newauth->count = old->count + 1;
+@@ -515,7 +515,7 @@
+ if (comment != NULL && off(SMB__QUIET, ctrl)) {
+ pmsg[0] = &msg[0];
+ msg[0].msg_style = PAM_TEXT_INFO;
+- msg[0].msg = comment;
++ msg[0].msg = CONST_DISCARD(char *, comment);
+ i = 1;
+ } else {
+ i = 0;
+@@ -523,12 +523,12 @@
+
+ pmsg[i] = &msg[i];
+ msg[i].msg_style = PAM_PROMPT_ECHO_OFF;
+- msg[i++].msg = prompt1;
++ msg[i++].msg = CONST_DISCARD(char *, prompt1);
+
+ if (prompt2 != NULL) {
+ pmsg[i] = &msg[i];
+ msg[i].msg_style = PAM_PROMPT_ECHO_OFF;
+- msg[i++].msg = prompt2;
++ msg[i++].msg = CONST_DISCARD(char *, prompt2);
+ expect = 2;
+ } else
+ expect = 1;
+@@ -594,7 +594,7 @@
+
+ retval = pam_set_data( pamh, data_name, (void *) token, _cleanup );
+ if (retval != PAM_SUCCESS
+- || (retval = pam_get_data( pamh, data_name, (const void **)&item ))
++ || (retval = pam_get_data( pamh, data_name, (void **)&item ))
+ != PAM_SUCCESS)
+ {
+ _log_err( LOG_CRIT, "error manipulating password data [%s]"
diff --git a/net/samba3/files/patch-smbd_aio.c b/net/samba3/files/patch-smbd_aio.c
new file mode 100644
index 000000000000..785ea368425b
--- /dev/null
+++ b/net/samba3/files/patch-smbd_aio.c
@@ -0,0 +1,33 @@
+--- smbd/aio.c.orig Tue Jan 3 03:03:05 2006
++++ smbd/aio.c Tue Jan 3 03:06:52 2006
+@@ -25,7 +25,17 @@
+
+ /* The signal we'll use to signify aio done. */
+ #ifndef RT_SIGNAL_AIO
+-#define RT_SIGNAL_AIO (SIGRTMIN+3)
++#ifndef SIGRTMIN
++#define SIGRTMIN NSIG
++#endif
++#define RT_SIGNAL_AIO (SIGRTMIN+3)
++#endif
++
++#ifndef HAVE_STRUCT_SIGEVENT_SIGEV_VALUE_SIVAL_PTR
++#ifdef HAVE_STRUCT_SIGEVENT_SIGEV_VALUE_SIGVAL_PTR
++#define sival_int sigval_int
++#define sival_ptr sigval_ptr
++#endif
+ #endif
+
+ /****************************************************************************
+@@ -497,6 +507,11 @@
+ static BOOL handle_aio_completed(struct aio_extra *aio_ex, int *perr)
+ {
+ int err;
++
++ if(!aio_ex) {
++ DEBUG(3, ("handle_aio_completed: Non-existing aio_ex passed\n"));
++ return False;
++ }
+
+ /* Ensure the operation has really completed. */
+ if (SMB_VFS_AIO_ERROR(aio_ex->fsp, &aio_ex->acb) == EINPROGRESS) {
diff --git a/net/samba3/files/patch-smbd_statvfs.c b/net/samba3/files/patch-smbd_statvfs.c
new file mode 100644
index 000000000000..bfd733806251
--- /dev/null
+++ b/net/samba3/files/patch-smbd_statvfs.c
@@ -0,0 +1,47 @@
+--- smbd/statvfs.c.orig Wed Nov 9 19:28:55 2005
++++ smbd/statvfs.c Thu Jan 5 04:26:54 2006
+@@ -3,6 +3,7 @@
+ VFS API's statvfs abstraction
+ Copyright (C) Alexander Bokovoy 2005
+ Copyright (C) Steve French 2005
++ Copyright (C) Timur I. Bakeyev 2005
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+@@ -41,6 +42,27 @@
+ }
+ return result;
+ }
++#elif defined(FREEBSD)
++static int bsd_statvfs(const char *path, vfs_statvfs_struct *statbuf)
++{
++ struct statfs statfs_buf;
++ int result;
++
++ result = statfs(path, &statfs_buf);
++
++ if (!result) {
++ statbuf->OptimalTransferSize = statfs_buf.f_iosize;
++ statbuf->BlockSize = statfs_buf.f_bsize;
++ statbuf->TotalBlocks = statfs_buf.f_blocks;
++ statbuf->BlocksAvail = statfs_buf.f_bfree;
++ statbuf->UserBlocksAvail = statfs_buf.f_bavail;
++ statbuf->TotalFileNodes = statfs_buf.f_files;
++ statbuf->FreeFileNodes = statfs_buf.f_ffree;
++ statbuf->FsIdentifier =
++ (((SMB_BIG_UINT)statfs_buf.f_fsid.val[0]<<32) & 0xffffffff00000000LL) | (SMB_BIG_UINT)statfs_buf.f_fsid.val[1];
++ }
++ return result;
++}
+ #endif
+
+ /*
+@@ -53,6 +75,8 @@
+ {
+ #if defined(LINUX)
+ return linux_statvfs(path, statbuf);
++#elif defined(FREEBSD)
++ return bsd_statvfs(path, statbuf);
+ #else
+ /* BB change this to return invalid level */
+ #ifdef EOPNOTSUPP
diff --git a/net/samba3/files/samba.sh.sample b/net/samba3/files/samba.sh.sample
index 26214e3844e3..ad4fc591fde1 100644
--- a/net/samba3/files/samba.sh.sample
+++ b/net/samba3/files/samba.sh.sample
@@ -5,7 +5,7 @@
# PROVIDE: nmbd smbd
%%WINBIND%%# PROVIDE: winbindd
-# REQUIRE: NETWORKING SERVERS named %%CUPS%%
+# REQUIRE: NETWORKING SERVERS named ldconfig %%CUPS%%
# BEFORE: DAEMON
# KEYWORD: shutdown
@@ -65,9 +65,8 @@ nmbd_precmd() {
# XXX: Never delete winbindd_idmap, winbindd_cache and group_mapping
if [ -d "%%SAMBA_LOCKDIR%%" ]; then
echo "Starting SAMBA: removing stale tdbs :"
- for file in connections.tdb locking.tdb messages.tdb \
- sessionid.tdb unexpected.tdb brlock.tdb \
- namelist.debug
+ for file in connections.tdb messages.tdb sessionid.tdb \
+ unexpected.tdb brlock.tdb locking.tdb namelist.debug
do
rm -vf "%%SAMBA_LOCKDIR%%/$file"
done
diff --git a/net/samba3/files/smb.conf.default b/net/samba3/files/smb.conf.default
index e85a61724d2c..3bc81ba5dca5 100644
--- a/net/samba3/files/smb.conf.default
+++ b/net/samba3/files/smb.conf.default
@@ -165,6 +165,11 @@
; map system = no
; map archive = no
+# Use inherited ACLs for directories
+; nt acl support = yes
+; inherit acls = yes
+; map acl inherit = yes
+
# These scripts are used on a domain controller or stand-alone
# machine to add or delete corresponding unix accounts
; add user script = /usr/sbin/useradd %u
diff --git a/net/samba3/pkg-plist b/net/samba3/pkg-plist
index 40676bcc201e..160ba6bb0688 100644
--- a/net/samba3/pkg-plist
+++ b/net/samba3/pkg-plist
@@ -1,3 +1,4 @@
+bin/eventlogadm
bin/findsmb
bin/make_smbpasswd
bin/net
@@ -10,6 +11,7 @@ bin/smbcacls
bin/smbclient
bin/smbcontrol
bin/smbcquotas
+bin/smbget
bin/smbpasswd
bin/smbspool
bin/smbstatus
@@ -79,6 +81,15 @@ sbin/swat
%%EXAMPLESDIR%%/pdb/mysql/smb.conf
%%EXAMPLESDIR%%/pdb/sambapdb.dtd
%%EXAMPLESDIR%%/pdb/test.c
+%%EXAMPLESDIR%%/perfcounter/Makefile
+%%EXAMPLESDIR%%/perfcounter/perf.h
+%%EXAMPLESDIR%%/perfcounter/perf_writer.c
+%%EXAMPLESDIR%%/perfcounter/perf_writer_cpu.c
+%%EXAMPLESDIR%%/perfcounter/perf_writer_disk.c
+%%EXAMPLESDIR%%/perfcounter/perf_writer_mem.c
+%%EXAMPLESDIR%%/perfcounter/perf_writer_process.c
+%%EXAMPLESDIR%%/perfcounter/perf_writer_util.c
+%%EXAMPLESDIR%%/perfcounter/perfcountd.init
%%EXAMPLESDIR%%/printer-accounting/README
%%EXAMPLESDIR%%/printer-accounting/acct-all
%%EXAMPLESDIR%%/printer-accounting/acct-sum
@@ -93,6 +104,7 @@ sbin/swat
%%EXAMPLESDIR%%/scripts/debugging/linux/backtrace
%%EXAMPLESDIR%%/scripts/debugging/solaris/README
%%EXAMPLESDIR%%/scripts/debugging/solaris/solaris-oops.sh
+%%EXAMPLESDIR%%/scripts/eventlog/parselog.pl
%%EXAMPLESDIR%%/scripts/printing/cups/smbaddprinter.pl
%%EXAMPLESDIR%%/scripts/printing/cups/smbdelprinter.pl
%%EXAMPLESDIR%%/scripts/shares/perl/modify_samba_config.pl
@@ -124,12 +136,14 @@ sbin/swat
@dirrm %%EXAMPLESDIR%%/scripts/shares
@dirrm %%EXAMPLESDIR%%/scripts/printing/cups
@dirrm %%EXAMPLESDIR%%/scripts/printing
+@dirrm %%EXAMPLESDIR%%/scripts/eventlog
@dirrm %%EXAMPLESDIR%%/scripts/debugging/solaris
@dirrm %%EXAMPLESDIR%%/scripts/debugging/linux
@dirrm %%EXAMPLESDIR%%/scripts/debugging
@dirrm %%EXAMPLESDIR%%/scripts
@dirrm %%EXAMPLESDIR%%/printing
@dirrm %%EXAMPLESDIR%%/printer-accounting
+@dirrm %%EXAMPLESDIR%%/perfcounter
@dirrm %%EXAMPLESDIR%%/pdb/mysql
@dirrm %%EXAMPLESDIR%%/pdb
@dirrm %%EXAMPLESDIR%%/nss
@@ -169,7 +183,6 @@ sbin/swat
%%PORTDOCS%%%%DOCSDIR%%/registry/Win9X-CacheHandling.reg
%%PORTDOCS%%%%DOCSDIR%%/registry/WinME_PlainPassword.reg
%%PORTDOCS%%%%DOCSDIR%%/registry/WinXP_PlainPassword.reg
-%%PORTDOCS%%%%DOCSDIR%%/registry/WinXP_SignOrSeal.reg
%%PORTDOCS%%%%DOCSDIR%%/registry/WindowsTerminalServer.reg
%%PORTDOCS%%@dirrm %%DOCSDIR%%/registry
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@@ -376,7 +389,6 @@ share/swat/help/Samba3-HOWTO/type.html
share/swat/help/Samba3-HOWTO/unicode.html
share/swat/help/Samba3-HOWTO/upgrading-to-3.0.html
share/swat/help/Samba3-HOWTO/winbind.html
-share/swat/help/manpages/editreg.1.html
share/swat/help/manpages/findsmb.1.html
share/swat/help/manpages/index.html
share/swat/help/manpages/lmhosts.5.html
@@ -386,7 +398,7 @@ share/swat/help/manpages/net.8.html
share/swat/help/manpages/nmbd.8.html
share/swat/help/manpages/nmblookup.1.html
share/swat/help/manpages/ntlm_auth.1.html
-share/swat/help/manpages/pam_winbind.8.html
+share/swat/help/manpages/pam_winbind.7.html
share/swat/help/manpages/pdbedit.8.html
share/swat/help/manpages/profiles.1.html
share/swat/help/manpages/rpcclient.1.html
@@ -413,7 +425,6 @@ share/swat/help/manpages/swat.8.html
share/swat/help/manpages/tdbbackup.8.html
share/swat/help/manpages/tdbdump.8.html
share/swat/help/manpages/testparm.1.html
-share/swat/help/manpages/testprns.1.html
share/swat/help/manpages/umount.cifs.8.html
share/swat/help/manpages/vfstest.1.html
share/swat/help/manpages/wbinfo.1.html