aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-22 17:39:44 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-22 18:20:35 +0000
commit99d908b22ee60aff6bad4d92f4b3ec14343d10c4 (patch)
treea279c268df5847a8125e7520304573574e5841f6
parentbed2eb0dbe41cb39a14c2ecd2e5973f8e3e502c0 (diff)
downloadports-99d908b22ee60aff6bad4d92f4b3ec14343d10c4.tar.gz
ports-99d908b22ee60aff6bad4d92f4b3ec14343d10c4.zip
graphics/mesa-devel: unbreak standalone after e502b6db284d0
llvm-config found: NO found '9.0.1' but need '>= 11.0.0' Run-time dependency LLVM found: NO (tried cmake and config-tool) Looking for a fallback subproject for the dependency llvm (modules: bitwriter, engine, mcdisassembler, mcjit, core, executionengine, scalaropts, transformutils, instcombine, amdgpu, native, bitreader, ipo, asmparser) meson.build:1604:2: ERROR: Neither a subproject directory nor a llvm.wrap file was found. (cherry picked from commit b0b997e3fc350bd39184128d1ec9434893e819d1)
-rw-r--r--graphics/mesa-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index bed053d28028..d792a5a272b2 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -93,7 +93,6 @@ anv_DESC= Haswell and newer
radv_DESC= Southern Islands and newer (implies LLVM)
COINST_DESC= Allow co-installation with another Mesa port
-COINST_VARS= LLVM_DEFAULT=11 # chase intel-compute-runtime
COINST_MESON_ON= -Degl-lib-suffix=${PKGNAMESUFFIX}
COINST_PLIST_SUB= SUFFIX=${PKGNAMESUFFIX}
COINST_SUB_FILES= libmap.conf
@@ -145,6 +144,13 @@ ZSTD_DESC= Use ZSTD for shader cache
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
ZSTD_MESON_ENABLED= zstd
+.include <bsd.port.options.mk>
+
+# Ignore Mk/bsd.default-versions.mk but respect make.conf(5)
+.if !defined(DEFAULT_VERSIONS) || ! ${DEFAULT_VERSIONS:Mllvm*}
+LLVM_DEFAULT= 11 # chase intel-compute-runtime
+.endif
+
post-extract:
# Work around Meson lookup order e.g., llvm-config
.if defined(BINARY_ALIAS)