aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 08:30:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-03 08:30:56 +0000
commit9b079b4d1528c86452ffdcfa65470111d77c5684 (patch)
tree8572b457f1dbc9731fd60ec66e14bd85f5136ac4
parentb3fb0c72c03546e312c443de99d9246c106afc93 (diff)
downloadports-9b079b4d1528c86452ffdcfa65470111d77c5684.tar.gz
ports-9b079b4d1528c86452ffdcfa65470111d77c5684.zip
Notes
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/emovix/Makefile24
-rw-r--r--multimedia/emovix/distinfo1
-rw-r--r--multimedia/emovix/files/patch-Makefile.am11
-rw-r--r--multimedia/emovix/files/patch-Makefile.in11
-rw-r--r--multimedia/emovix/pkg-descr7
-rw-r--r--multimedia/emovix/pkg-plist229
7 files changed, 284 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 894201c1a42d..43e40367923c 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -14,6 +14,7 @@
SUBDIR += dvdauthor
SUBDIR += dvdrip
SUBDIR += dvts
+ SUBDIR += emovix
SUBDIR += enjoympeg
SUBDIR += ffmpeg
SUBDIR += ffmpeg045
diff --git a/multimedia/emovix/Makefile b/multimedia/emovix/Makefile
new file mode 100644
index 000000000000..b788f0e9e1e1
--- /dev/null
+++ b/multimedia/emovix/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: k3b
+# Date created: 2003/10/31
+# Whom: Heiner <h.eichmann@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emovix
+PORTVERSION= 0.8.0
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= movix
+
+MAINTAINER= h.eichmann@gmx.de
+COMMENT= A mini linux distro to create bootable video CDs
+
+BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
+ cdrecord:${PORTSDIR}/sysutils/cdrtools
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/emovix/distinfo b/multimedia/emovix/distinfo
new file mode 100644
index 000000000000..fc1872e47019
--- /dev/null
+++ b/multimedia/emovix/distinfo
@@ -0,0 +1 @@
+MD5 (emovix-0.8.0.tar.gz) = 09c8eed368004a3e1bdb5de21a51e6e7
diff --git a/multimedia/emovix/files/patch-Makefile.am b/multimedia/emovix/files/patch-Makefile.am
new file mode 100644
index 000000000000..6fb9159fe15b
--- /dev/null
+++ b/multimedia/emovix/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am.orig Sat Sep 13 01:14:52 2003
++++ Makefile.am Mon Oct 20 22:35:00 2003
+@@ -24,7 +24,7 @@
+ for i in `find $(distdir) -name .cvsignore` ; do rm -rf $$i; done;
+
+ install-data-local:
+- cp -a {boot-messages,mplayer-fonts,keyboard-i18n} $(emovix_share_dir)
++ for i in boot-messages mplayer-fonts keyboard-i18n; do cp -r $$i $(emovix_share_dir); done;
+ for language in boot-messages/[a-z]* ; do perl -pw -i -e "s/MoviX +v[\.\w]+/MoviX v$(MOVIX_VERSION)/" $(emovix_share_dir)/$$language/mxhelp.txt ; done;
+
+ uninstall-local:
diff --git a/multimedia/emovix/files/patch-Makefile.in b/multimedia/emovix/files/patch-Makefile.in
new file mode 100644
index 000000000000..8d5c525b8c1c
--- /dev/null
+++ b/multimedia/emovix/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Sep 13 01:15:31 2003
++++ Makefile.in Mon Oct 20 22:34:04 2003
+@@ -516,7 +516,7 @@
+ for i in `find $(distdir) -name .cvsignore` ; do rm -rf $$i; done;
+
+ install-data-local:
+- cp -a {boot-messages,mplayer-fonts,keyboard-i18n} $(emovix_share_dir)
++ for i in boot-messages mplayer-fonts keyboard-i18n; do cp -r $$i $(emovix_share_dir); done;
+ for language in boot-messages/[a-z]* ; do perl -pw -i -e "s/MoviX +v[\.\w]+/MoviX v$(MOVIX_VERSION)/" $(emovix_share_dir)/$$language/mxhelp.txt ; done;
+
+ uninstall-local:
diff --git a/multimedia/emovix/pkg-descr b/multimedia/emovix/pkg-descr
new file mode 100644
index 000000000000..267ddc274fc6
--- /dev/null
+++ b/multimedia/emovix/pkg-descr
@@ -0,0 +1,7 @@
+A micro Linux distro meant to be embedded in a CD together with all
+video/audio files you want, so that the CD will be able to boot and
+automagically play all of its own files.
+
+eMoviX CDs be written with K3b.
+
+WWW: http://movix.sourceforge.net/
diff --git a/multimedia/emovix/pkg-plist b/multimedia/emovix/pkg-plist
new file mode 100644
index 000000000000..cd7837c5dcad
--- /dev/null
+++ b/multimedia/emovix/pkg-plist
@@ -0,0 +1,229 @@
+bin/lf-mkmovixiso
+bin/mkmovixiso
+bin/movix-conf
+bin/movix-files
+bin/movix-version
+share/emovix/boot-messages/README.encoding
+share/emovix/boot-messages/de/credits.txt
+share/emovix/boot-messages/de/help.txt
+share/emovix/boot-messages/de/mphelp.txt
+share/emovix/boot-messages/de/mxhelp.txt
+share/emovix/boot-messages/de/trblst.txt
+share/emovix/boot-messages/de/trblst2.txt
+share/emovix/boot-messages/en/credits.txt
+share/emovix/boot-messages/en/help.txt
+share/emovix/boot-messages/en/mphelp.txt
+share/emovix/boot-messages/en/mxhelp.txt
+share/emovix/boot-messages/en/trblst.txt
+share/emovix/boot-messages/en/trblst.txt~
+share/emovix/boot-messages/en/trblst2.txt
+share/emovix/boot-messages/es/credits.txt
+share/emovix/boot-messages/es/mphelp.txt
+share/emovix/boot-messages/es/mxhelp.txt
+share/emovix/boot-messages/es/trblst.txt
+share/emovix/boot-messages/esp/credits.txt
+share/emovix/boot-messages/esp/mphelp.txt
+share/emovix/boot-messages/esp/mxhelp.txt
+share/emovix/boot-messages/esp/trblst.txt
+share/emovix/boot-messages/fr/credits.txt
+share/emovix/boot-messages/fr/help.txt
+share/emovix/boot-messages/fr/mphelp.txt
+share/emovix/boot-messages/fr/mxhelp.txt
+share/emovix/boot-messages/fr/trblst.txt
+share/emovix/boot-messages/fr/trblst2.txt
+share/emovix/boot-messages/hu/credits.txt
+share/emovix/boot-messages/hu/help.txt
+share/emovix/boot-messages/hu/mphelp.txt
+share/emovix/boot-messages/hu/mxhelp.txt
+share/emovix/boot-messages/hu/trblst.txt
+share/emovix/boot-messages/hu/trblst2.txt
+share/emovix/boot-messages/it/credits.txt
+share/emovix/boot-messages/it/help.txt
+share/emovix/boot-messages/it/mphelp.txt
+share/emovix/boot-messages/it/mxhelp.txt
+share/emovix/boot-messages/it/trblst.txt
+share/emovix/boot-messages/it/trblst2.txt
+share/emovix/boot-messages/jp/credits.txt
+share/emovix/boot-messages/jp/mphelp.txt
+share/emovix/boot-messages/jp/mxhelp.txt
+share/emovix/boot-messages/jp/trblst.txt
+share/emovix/boot-messages/nl/credits.txt
+share/emovix/boot-messages/nl/mphelp.txt
+share/emovix/boot-messages/nl/mxhelp.txt
+share/emovix/boot-messages/nl/trblst.txt
+share/emovix/boot-messages/pl/credits.txt
+share/emovix/boot-messages/pl/mphelp.txt
+share/emovix/boot-messages/pl/mxhelp.txt
+share/emovix/boot-messages/pl/trblst.txt
+share/emovix/boot-messages/pl/trblst2.txt
+share/emovix/boot-messages/pt/credits.txt
+share/emovix/boot-messages/pt/mphelp.txt
+share/emovix/boot-messages/pt/mxhelp.txt
+share/emovix/boot-messages/pt/trblst.txt
+share/emovix/boot-messages/sar/credits.txt
+share/emovix/boot-messages/sar/mphelp.txt
+share/emovix/boot-messages/sar/mxhelp.txt
+share/emovix/boot-messages/sar/trblst.txt
+share/emovix/isolinux/credits.txt
+share/emovix/isolinux/initrd.gz
+share/emovix/isolinux/iso.sort
+share/emovix/isolinux/isolinux.bin
+share/emovix/isolinux/isolinux.cfg
+share/emovix/isolinux/kernel/vmlinuz
+share/emovix/isolinux/movix.lss
+share/emovix/isolinux/movix.msg
+share/emovix/isolinux/mphelp.txt
+share/emovix/isolinux/mxhelp.txt
+share/emovix/isolinux/trblst.txt
+share/emovix/keyboard-i18n/README
+share/emovix/keyboard-i18n/de/bootkey.map
+share/emovix/keyboard-i18n/de/shellkey.map
+share/emovix/keyboard-i18n/es/bootkey.map
+share/emovix/keyboard-i18n/es/shellkey.map
+share/emovix/keyboard-i18n/fr/bootkey.map
+share/emovix/keyboard-i18n/fr/shellkey.map
+share/emovix/keyboard-i18n/hu/bootkey.map
+share/emovix/keyboard-i18n/hu/shellkey.map
+share/emovix/keyboard-i18n/it/bootkey.map
+share/emovix/keyboard-i18n/it/shellkey.map
+share/emovix/keyboard-i18n/nl/bootkey.map
+share/emovix/keyboard-i18n/nl/shellkey.map
+share/emovix/keyboard-i18n/pt/bootkey.map
+share/emovix/keyboard-i18n/pt/shellkey.map
+share/emovix/keyboard-i18n/us/bootkey.map
+share/emovix/keyboard-i18n/us/shellkey.map
+share/emovix/movix/bugReport.sh
+share/emovix/movix/config
+share/emovix/movix/input.conf
+share/emovix/movix/isapnpmodules.sh
+share/emovix/movix/lircd.conf
+share/emovix/movix/lircrc
+share/emovix/movix/manpage.txt
+share/emovix/movix/menu.conf
+share/emovix/movix/mixer.pl
+share/emovix/movix/movix-files
+share/emovix/movix/movix.pl
+share/emovix/movix/profile
+share/emovix/movix/rc.lirc
+share/emovix/movix/rc.movix
+share/emovix/movix/setHardware.pl
+share/emovix/movix/showisapnpmodules.sh
+share/emovix/movix/showpcimodules.sh
+share/emovix/mplayer-fonts/FreeMonoBoldOblique.ttf
+share/emovix/mplayer-fonts/FreeSansBold.ttf
+share/emovix/mplayer-fonts/FreeSansBoldOblique.ttf
+share/emovix/mplayer-fonts/FreeSansOblique.ttf
+share/emovix/mplayer-fonts/FreeSerifBoldItalic.ttf
+share/emovix/mplayer-fonts/FreeSerifItalic.ttf
+share/emovix/mplayer-fonts/Vera.ttf
+share/emovix/mplayer-fonts/VeraBd.ttf
+share/emovix/mplayer-fonts/VeraIt.ttf
+share/emovix/mplayer-fonts/VeraMoBd.ttf
+share/emovix/mplayer-fonts/VeraMoIt.ttf
+share/emovix/mplayer-fonts/VeraMono.ttf
+share/emovix/mplayer-fonts/VeraSe.ttf
+share/emovix/mplayer-fonts/VeraSeBd.ttf
+share/emovix/mplayer-fonts/centralEU-cp1250/cp1250-a.raw
+share/emovix/mplayer-fonts/centralEU-cp1250/cp1250-b.raw
+share/emovix/mplayer-fonts/centralEU-cp1250/font.desc
+share/emovix/mplayer-fonts/centralEU-cp1250/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/centralEU-cp1250/osd-mplayer-b.raw
+share/emovix/mplayer-fonts/centralEU-cp1250/runme
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/font.desc
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/iso-8859-2-a.raw
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/iso-8859-2-b.raw
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/osd-mplayer-b.raw
+share/emovix/mplayer-fonts/centralEU-iso-8859-2/runme
+share/emovix/mplayer-fonts/cyrillic/arial-26-cyr-a.raw
+share/emovix/mplayer-fonts/cyrillic/arial-26-cyr-b.raw
+share/emovix/mplayer-fonts/cyrillic/arial-26i-cyr-a.raw
+share/emovix/mplayer-fonts/cyrillic/arial-26i-cyr-b.raw
+share/emovix/mplayer-fonts/cyrillic/arial-cyr-italic.desc
+share/emovix/mplayer-fonts/cyrillic/font.desc
+share/emovix/mplayer-fonts/czech/arpi_a.raw
+share/emovix/mplayer-fonts/czech/arpi_b.raw
+share/emovix/mplayer-fonts/czech/arpi_hun_a.raw
+share/emovix/mplayer-fonts/czech/arpi_hun_b.raw
+share/emovix/mplayer-fonts/czech/arpi_osd_a.raw
+share/emovix/mplayer-fonts/czech/arpi_osd_b.raw
+share/emovix/mplayer-fonts/czech/arpi_progress_a.raw
+share/emovix/mplayer-fonts/czech/arpi_progress_b.raw
+share/emovix/mplayer-fonts/czech/cz_a.raw
+share/emovix/mplayer-fonts/czech/cz_b.raw
+share/emovix/mplayer-fonts/czech/font.desc
+share/emovix/mplayer-fonts/czech/kato_large.desc
+share/emovix/mplayer-fonts/czech/kato_large_a.raw
+share/emovix/mplayer-fonts/czech/kato_large_b.raw
+share/emovix/mplayer-fonts/czech/kato_large_cz_a.raw
+share/emovix/mplayer-fonts/czech/kato_large_cz_b.raw
+share/emovix/mplayer-fonts/czech/kato_medium.desc
+share/emovix/mplayer-fonts/czech/kato_medium_a.raw
+share/emovix/mplayer-fonts/czech/kato_medium_b.raw
+share/emovix/mplayer-fonts/czech/kato_medium_cz_a.raw
+share/emovix/mplayer-fonts/czech/kato_medium_cz_b.raw
+share/emovix/mplayer-fonts/czech/kato_small.desc
+share/emovix/mplayer-fonts/czech/large.desc
+share/emovix/mplayer-fonts/czech/medium.desc
+share/emovix/mplayer-fonts/czech/small.desc
+share/emovix/mplayer-fonts/greek/font.desc
+share/emovix/mplayer-fonts/greek/iso-8859-7-a.raw
+share/emovix/mplayer-fonts/greek/iso-8859-7-b.raw
+share/emovix/mplayer-fonts/greek/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/greek/osd-mplayer-b.raw
+share/emovix/mplayer-fonts/hebrew/font.desc
+share/emovix/mplayer-fonts/hebrew/iso-8859-1-a.raw
+share/emovix/mplayer-fonts/hebrew/iso-8859-1-b.raw
+share/emovix/mplayer-fonts/hebrew/iso-8859-8-a.raw
+share/emovix/mplayer-fonts/hebrew/iso-8859-8-b.raw
+share/emovix/mplayer-fonts/hebrew/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/hebrew/osd-mplayer-b.raw
+share/emovix/mplayer-fonts/polish/font.desc
+share/emovix/mplayer-fonts/polish/iso-8859-2-a.raw
+share/emovix/mplayer-fonts/polish/iso-8859-2-b.raw
+share/emovix/mplayer-fonts/polish/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/polish/osd-mplayer-b.raw
+share/emovix/mplayer-fonts/russian/font.desc
+share/emovix/mplayer-fonts/russian/koi8-r-a.raw
+share/emovix/mplayer-fonts/russian/koi8-r-b.raw
+share/emovix/mplayer-fonts/turkish/font.desc
+share/emovix/mplayer-fonts/turkish/iso-8859-9-a.raw
+share/emovix/mplayer-fonts/turkish/iso-8859-9-b.raw
+share/emovix/mplayer-fonts/turkish/osd-mplayer-a.raw
+share/emovix/mplayer-fonts/turkish/osd-mplayer-b.raw
+@dirrm share/emovix/mplayer-fonts/turkish
+@dirrm share/emovix/mplayer-fonts/russian
+@dirrm share/emovix/mplayer-fonts/polish
+@dirrm share/emovix/mplayer-fonts/hebrew
+@dirrm share/emovix/mplayer-fonts/greek
+@dirrm share/emovix/mplayer-fonts/czech
+@dirrm share/emovix/mplayer-fonts/cyrillic
+@dirrm share/emovix/mplayer-fonts/centralEU-iso-8859-2
+@dirrm share/emovix/mplayer-fonts/centralEU-cp1250
+@dirrm share/emovix/mplayer-fonts
+@dirrm share/emovix/movix
+@dirrm share/emovix/keyboard-i18n/us
+@dirrm share/emovix/keyboard-i18n/pt
+@dirrm share/emovix/keyboard-i18n/nl
+@dirrm share/emovix/keyboard-i18n/it
+@dirrm share/emovix/keyboard-i18n/hu
+@dirrm share/emovix/keyboard-i18n/fr
+@dirrm share/emovix/keyboard-i18n/es
+@dirrm share/emovix/keyboard-i18n/de
+@dirrm share/emovix/keyboard-i18n
+@dirrm share/emovix/isolinux/kernel
+@dirrm share/emovix/isolinux
+@dirrm share/emovix/boot-messages/sar
+@dirrm share/emovix/boot-messages/pt
+@dirrm share/emovix/boot-messages/pl
+@dirrm share/emovix/boot-messages/nl
+@dirrm share/emovix/boot-messages/jp
+@dirrm share/emovix/boot-messages/it
+@dirrm share/emovix/boot-messages/hu
+@dirrm share/emovix/boot-messages/fr
+@dirrm share/emovix/boot-messages/esp
+@dirrm share/emovix/boot-messages/es
+@dirrm share/emovix/boot-messages/en
+@dirrm share/emovix/boot-messages/de
+@dirrm share/emovix/boot-messages
+@dirrm share/emovix