aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-24 12:52:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-24 12:52:48 +0000
commita385653e01933b970157da63341fecced813a72a (patch)
tree7b832d27cbc62a51edc092641df8a13c71201732
parent263d06b737b767109d4873b2e31d9fb992940a0b (diff)
downloadports-a385653e01933b970157da63341fecced813a72a.tar.gz
ports-a385653e01933b970157da63341fecced813a72a.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/beediff/Makefile43
-rw-r--r--textproc/beediff/distinfo3
-rw-r--r--textproc/beediff/files/patch-beediff.pro11
-rw-r--r--textproc/beediff/pkg-descr5
5 files changed, 63 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 2695c2986dee..ece8ae6be05a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -27,6 +27,7 @@
SUBDIR += bbe
SUBDIR += be-aspell
SUBDIR += bedic-data
+ SUBDIR += beediff
SUBDIR += bg-aspell
SUBDIR += bib2html
SUBDIR += bibtex2html
diff --git a/textproc/beediff/Makefile b/textproc/beediff/Makefile
new file mode 100644
index 000000000000..0ba0ad84fabd
--- /dev/null
+++ b/textproc/beediff/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: beediff
+# Date created: 2008-03-23
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beediff
+PORTVERSION= 1.5
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.beesoft.org/download/
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= QT4 based diff frontend
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build rcc_build qmake_build
+HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/beediff share/pixmaps/beediff.png
+
+DESKTOP_ENTRIES="BeeDiff" "diff frontend" "beediff.png" \
+ "beediff" "" false
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE}
+
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/beediff ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/img/beediff.png ${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>
diff --git a/textproc/beediff/distinfo b/textproc/beediff/distinfo
new file mode 100644
index 000000000000..7f719513642a
--- /dev/null
+++ b/textproc/beediff/distinfo
@@ -0,0 +1,3 @@
+MD5 (beediff_1.5_src.tar.gz) = 153a0877136068126d076b578f3d38c1
+SHA256 (beediff_1.5_src.tar.gz) = 76a924c9a94067fd424d8a151fbaefbe0e22672fd3baa22db4eacd4286de9088
+SIZE (beediff_1.5_src.tar.gz) = 70094
diff --git a/textproc/beediff/files/patch-beediff.pro b/textproc/beediff/files/patch-beediff.pro
new file mode 100644
index 000000000000..5deffc248c40
--- /dev/null
+++ b/textproc/beediff/files/patch-beediff.pro
@@ -0,0 +1,11 @@
+--- ./beediff.pro.orig 2008-03-16 14:40:25.000000000 +0300
++++ ./beediff.pro 2008-03-23 11:23:02.000000000 +0300
+@@ -1,8 +1,5 @@
+ TEMPLATE = app
+ CONFIG += qt release warn_on x11
+-QMAKE_CXXFLAGS = -march=pentium
+-QMAKE_CXXFLAGS_DEBUG = -O0 -g
+-QMAKE_CXXFLAGS_RELEASE = -O3
+ OBJECTS_DIR = ./tmp
+ MOC_DIR = ./tmp
+ SOURCES = \
diff --git a/textproc/beediff/pkg-descr b/textproc/beediff/pkg-descr
new file mode 100644
index 000000000000..a954ca2a1762
--- /dev/null
+++ b/textproc/beediff/pkg-descr
@@ -0,0 +1,5 @@
+BeeDiff is a graphical file comparator. User have a possibility
+to compare and merge a two text files. All differences are highlighted
+in colors.
+
+WWW: http://www.beesoft.org/beediff.html