aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-03 13:27:58 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-03 13:27:58 +0000
commita69872a608282262fb22d26d186e3358a691bee1 (patch)
treecaf194709e280c4bc19e79d9a94b0cc4f0671203
parentf741c167024a347ceb160e30863e31c74513a95f (diff)
downloadports-a69872a608282262fb22d26d186e3358a691bee1.tar.gz
ports-a69872a608282262fb22d26d186e3358a691bee1.zip
Notes
-rw-r--r--dns/bind911/Makefile8
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind911/files/patch-bin_tests_system_dlzexternal_Makefile.in2
-rw-r--r--dns/bind911/files/patch-configure8
-rw-r--r--dns/bind911/pkg-plist7
6 files changed, 26 insertions, 21 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 82d801f40107..f78d7c57c4f2 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -29,7 +29,7 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.0b2
+ISCVERSION= 9.11.0b3
MAKE_JOBS_UNSAFE= yes
@@ -72,7 +72,7 @@ OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= RRL DLZ_FILESYSTEM
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
- MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
+ MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE LMDB
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -99,6 +99,7 @@ MINCACHE_DESC= Use the mincachettl patch
PORTREVISION_DESC= Show PORTREVISION in the version string
FETCHLIMIT_DESC= Enable the query quotas for resolvers
QUERYTRACE_DESC= Enable the very verbose query tracelogging
+LMDB_DESC= Use LMDB for zone management
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -130,6 +131,9 @@ SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
SSL_USES= ssl
SSL_CONFIGURE_OFF= --disable-openssl-version-check --without-openssl
+LMDB_CONFIGURE_WITH= lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
+
NEWSTATS_CONFIGURE_ENABLE= newstats
IDN_USES= iconv
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index 49b5975336d9..d18fed57f6fb 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1468926742
-SHA256 (bind-9.11.0b2.tar.gz) = 440e7fa7c4e241c13028699ab107fc4c3efd1719012b1af356d39db5ab49109d
-SIZE (bind-9.11.0b2.tar.gz) = 9714852
+TIMESTAMP = 1470224272
+SHA256 (bind-9.11.0b3.tar.gz) = 7c1d0d3465755c0cfb990c9bfff33f33c7cef9a16e320e7e3a5eb7c506d9e993
+SIZE (bind-9.11.0b3.tar.gz) = 9735747
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index d0009bb61f45..5ace6372efac 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2016-07-14 01:31:01 UTC
+--- bin/named/config.c.orig 2016-07-28 12:26:36 UTC
+++ bin/named/config.c
-@@ -151,6 +151,8 @@ options {\n\
+@@ -152,6 +152,8 @@ options {\n\
lame-ttl 600;\n\
servfail-ttl 1;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 90%;\n\
---- bin/named/server.c.orig 2016-07-14 01:31:01 UTC
+--- bin/named/server.c.orig 2016-07-28 12:26:36 UTC
+++ bin/named/server.c
-@@ -3549,6 +3549,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3567,6 +3567,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,9 +28,9 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-07-14 01:31:01 UTC
+--- lib/dns/include/dns/view.h.orig 2016-07-28 12:26:36 UTC
+++ lib/dns/include/dns/view.h
-@@ -145,6 +145,8 @@ struct dns_view {
+@@ -146,6 +146,8 @@ struct dns_view {
isc_boolean_t requestnsid;
isc_boolean_t sendcookie;
dns_ttl_t maxcachettl;
@@ -39,7 +39,7 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2016-07-14 01:31:01 UTC
+--- lib/dns/resolver.c.orig 2016-07-28 12:26:36 UTC
+++ lib/dns/resolver.c
@@ -5431,6 +5431,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -60,7 +60,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-07-14 01:31:01 UTC
+--- lib/isccfg/namedconf.c.orig 2016-07-28 12:26:36 UTC
+++ lib/isccfg/namedconf.c
@@ -1707,6 +1707,8 @@ view_clauses[] = {
{ "nosit-udp-size", &cfg_type_uint32, CFG_CLAUSEFLAG_OBSOLETE },
diff --git a/dns/bind911/files/patch-bin_tests_system_dlzexternal_Makefile.in b/dns/bind911/files/patch-bin_tests_system_dlzexternal_Makefile.in
index 8d9fcefc5c53..d7b87fd655d6 100644
--- a/dns/bind911/files/patch-bin_tests_system_dlzexternal_Makefile.in
+++ b/dns/bind911/files/patch-bin_tests_system_dlzexternal_Makefile.in
@@ -1,4 +1,4 @@
---- bin/tests/system/dlzexternal/Makefile.in.orig 2016-06-27 17:38:13 UTC
+--- bin/tests/system/dlzexternal/Makefile.in.orig 2016-07-28 12:26:36 UTC
+++ bin/tests/system/dlzexternal/Makefile.in
@@ -35,7 +35,7 @@ OBJS = ${DLOPENOBJS}
@BIND9_MAKE_RULES@
diff --git a/dns/bind911/files/patch-configure b/dns/bind911/files/patch-configure
index 2a3cfe4da1eb..acbca13679c7 100644
--- a/dns/bind911/files/patch-configure
+++ b/dns/bind911/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2016-07-14 01:31:01 UTC
+--- configure.orig 2016-07-28 12:26:36 UTC
+++ configure
-@@ -14338,27 +14338,9 @@ done
+@@ -14341,27 +14341,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -14401,47 +14383,7 @@ $as_echo "no" >&6; } ;;
+@@ -14404,47 +14386,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -22318,7 +22260,7 @@ $as_echo "" >&6; }
+@@ -22448,7 +22390,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind911/pkg-plist b/dns/bind911/pkg-plist
index 03d26fc1dacb..5a0dfcccabb2 100644
--- a/dns/bind911/pkg-plist
+++ b/dns/bind911/pkg-plist
@@ -1,9 +1,11 @@
+bin/arpaname
bin/bind9-config
bin/delv
bin/dig
bin/host
bin/isc-config.sh
bin/mdig
+bin/named-rrchecker
bin/nslookup
bin/nsupdate
include/bind9/check.h
@@ -270,7 +272,6 @@ man/man1/arpaname.1.gz
man/man1/bind9-config.1.gz
man/man1/delv.1.gz
man/man1/dig.1.gz
-man/man1/dnstap-read.1.gz
man/man1/host.1.gz
man/man1/isc-config.sh.1.gz
man/man1/mdig.1.gz
@@ -383,6 +384,7 @@ man/man8/named-checkconf.8.gz
man/man8/named-checkzone.8.gz
man/man8/named-compilezone.8.gz
man/man8/named-journalprint.8.gz
+%%LMDB%%man/man8/named-nzd2nzf.8.gz
man/man8/named.8.gz
man/man8/nsec3hash.8.gz
%%NATIVE_PKCS11%%man/man8/pkcs11-destroy.8.gz
@@ -392,7 +394,6 @@ man/man8/nsec3hash.8.gz
man/man8/rndc-confgen.8.gz
man/man8/rndc.8.gz
man/man8/tsig-keygen.8.gz
-sbin/arpaname
sbin/ddns-confgen
%%PYTHON%%sbin/dnssec-checkds
%%PYTHON%%sbin/dnssec-coverage
@@ -413,7 +414,7 @@ sbin/named-checkconf
sbin/named-checkzone
sbin/named-compilezone
sbin/named-journalprint
-sbin/named-rrchecker
+%%LMDB%%sbin/named-nzd2nzf
sbin/nsec3hash
%%NATIVE_PKCS11%%sbin/pkcs11-destroy
%%NATIVE_PKCS11%%sbin/pkcs11-keygen