aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2013-04-02 11:06:55 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2013-04-02 11:06:55 +0000
commitb6615d025aff80c23ef65a1b537db4ccf7ba99cf (patch)
treed75c8adca2e4878fb7e98d656302e7219f8cd306
parent96730c894d156aa9d9710c77a19e3a430580985e (diff)
downloadports-b6615d025aff80c23ef65a1b537db4ccf7ba99cf.tar.gz
ports-b6615d025aff80c23ef65a1b537db4ccf7ba99cf.zip
Notes
-rw-r--r--www/anyterm/Makefile11
-rw-r--r--www/anyterm/files/patch-libpbe-src-SmtpClient.cc10
-rw-r--r--www/anyterm/files/patch-libpbe-src-URI.cc28
-rw-r--r--www/anyterm/files/patch-libpbe-src-ip.cc10
-rw-r--r--www/anyterm/files/patch-libpbe-src-parse_http_request.cc28
5 files changed, 80 insertions, 7 deletions
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index 548e31ce5de3..7d8661bcd863 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: anyterm
-# Date created: 19 November 2009
-# Whom: Douglas Thrift
-#
+# Created by: Douglas Thrift
# $FreeBSD$
-#
PORTNAME= anyterm
PORTVERSION= 1.1.29
@@ -16,15 +12,16 @@ EXTRACT_SUFX= .tbz2
MAINTAINER= douglas@douglasthrift.net
COMMENT= A terminal emulator on a Web page
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
-
LICENSE= GPLv2
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:${PORTSDIR}/devel/boost-libs
+
MAN1= anytermd.1
USE_RC_SUBR= anytermd
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
+USE_GCC= any
ALL_TARGET= default_target
PLIST_FILES= sbin/anytermd
diff --git a/www/anyterm/files/patch-libpbe-src-SmtpClient.cc b/www/anyterm/files/patch-libpbe-src-SmtpClient.cc
new file mode 100644
index 000000000000..d5bd0790e65f
--- /dev/null
+++ b/www/anyterm/files/patch-libpbe-src-SmtpClient.cc
@@ -0,0 +1,10 @@
+--- libpbe/src/SmtpClient.cc.orig 2008-05-24 14:24:47.000000000 +0200
++++ libpbe/src/SmtpClient.cc 2013-03-30 17:41:19.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include <syslog.h>
+ #include <unistd.h>
++#include <stdio.h>
+
+ #ifdef __OpenBSD__
+ // Is this really needed?
diff --git a/www/anyterm/files/patch-libpbe-src-URI.cc b/www/anyterm/files/patch-libpbe-src-URI.cc
new file mode 100644
index 000000000000..547787444a16
--- /dev/null
+++ b/www/anyterm/files/patch-libpbe-src-URI.cc
@@ -0,0 +1,28 @@
+--- libpbe/src/URI.cc.orig 2008-11-09 15:16:16.000000000 +0100
++++ libpbe/src/URI.cc 2013-03-30 17:45:57.000000000 +0100
+@@ -18,11 +18,11 @@
+
+ #include "URI.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/home/classic/actor/insert_at_actor.hpp>
++#include <boost/spirit/home/classic/dynamic/if.hpp>
++#include <boost/spirit/home/classic/utility/loops.hpp>
++#include <boost/spirit/home/classic/iterator/multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -30,7 +30,7 @@
+ #include <map>
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {
diff --git a/www/anyterm/files/patch-libpbe-src-ip.cc b/www/anyterm/files/patch-libpbe-src-ip.cc
new file mode 100644
index 000000000000..646bd962faa8
--- /dev/null
+++ b/www/anyterm/files/patch-libpbe-src-ip.cc
@@ -0,0 +1,10 @@
+--- libpbe/src/ip.cc.orig 2008-12-18 21:18:43.000000000 +0100
++++ libpbe/src/ip.cc 2013-03-30 17:48:22.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include <sys/un.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <string.h>
+
+ using namespace std;
+
diff --git a/www/anyterm/files/patch-libpbe-src-parse_http_request.cc b/www/anyterm/files/patch-libpbe-src-parse_http_request.cc
new file mode 100644
index 000000000000..8c21fb35dfad
--- /dev/null
+++ b/www/anyterm/files/patch-libpbe-src-parse_http_request.cc
@@ -0,0 +1,28 @@
+--- libpbe/src/parse_http_request.cc.orig 2013-03-30 16:57:51.000000000 +0100
++++ libpbe/src/parse_http_request.cc 2013-03-30 17:11:49.000000000 +0100
+@@ -18,11 +18,11 @@
+
+ #include "parse_http_request.hh"
+
+-#include <boost/spirit.hpp>
+-#include <boost/spirit/actor/insert_at_actor.hpp>
+-#include <boost/spirit/dynamic/if.hpp>
+-#include <boost/spirit/utility/loops.hpp>
+-#include <boost/spirit/iterator/multi_pass.hpp>
++#include <boost/spirit/include/classic.hpp>
++#include <boost/spirit/home/classic/actor/insert_at_actor.hpp>
++#include <boost/spirit/home/classic/dynamic/if.hpp>
++#include <boost/spirit/home/classic/utility/loops.hpp>
++#include <boost/spirit/home/classic/iterator/multi_pass.hpp>
+
+ #include <boost/lexical_cast.hpp>
+ #include <boost/scoped_array.hpp>
+@@ -31,7 +31,7 @@
+
+
+ using namespace std;
+-using namespace boost::spirit;
++using namespace boost::spirit::classic;
+
+
+ namespace pbe {