aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-05-17 01:06:46 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-05-17 01:06:46 +0000
commitc2e9b4e7ea5f2c95744a141a0c70e65e0c7a3060 (patch)
tree03c58218b7223b49948de40b1d527e666ae596f6
parent10ce60facd6c9aa3eea1a3a61db19c93ebe4d7fc (diff)
downloadports-c2e9b4e7ea5f2c95744a141a0c70e65e0c7a3060.tar.gz
ports-c2e9b4e7ea5f2c95744a141a0c70e65e0c7a3060.zip
Notes
-rw-r--r--net-mgmt/collectd/Makefile36
-rw-r--r--net-mgmt/collectd/distinfo4
-rw-r--r--net-mgmt/collectd/pkg-plist4
-rw-r--r--net-mgmt/collectd5/Makefile36
-rw-r--r--net-mgmt/collectd5/distinfo4
-rw-r--r--net-mgmt/collectd5/pkg-plist4
6 files changed, 76 insertions, 12 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index f766aced3895..2184730a1db8 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= collectd
-PORTVERSION= 4.9.5
+PORTVERSION= 4.10.3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -24,6 +24,8 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
APACHE "Input: Apache mod_status (libcurl)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
CURL "Input: CURL generic web statistics" Off \
+ CURL_JSON "Input: CURL JSON generic web statistics" Off \
+ CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
NUTUPS "Input: NUT UPS daemon" Off \
@@ -47,8 +49,9 @@ USE_RC_SUBR= collectd collectdmon
USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
@@ -73,7 +76,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-conntrack \
--disable-contextswitch \
--disable-cpufreq \
- --disable-curl_json \
--disable-entropy \
--disable-fscache \
--disable-gmond \
@@ -91,6 +93,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-match_timediff \
--disable-match_value \
--disable-memcachec \
+ --disable-modbus \
--disable-multimeter \
--disable-netapp \
--disable-netlink \
@@ -101,6 +104,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-onewire \
--disable-oracle \
--disable-perl \
+ --disable-pinba \
--disable-python \
--disable-protocols \
--disable-routeros \
@@ -185,6 +189,30 @@ CONFIGURE_ARGS+=--disable-curl
PLIST_SUB+= CURL="@comment "
.endif
+.if defined(WITH_CURL_JSON)
+.if !defined(WITH_CURL)
+IGNORE= using CURL_JSON requires CURL support
+.endif
+CONFIGURE_ARGS+=--enable-curl_json
+LIB_DEPENDS+= yajl:${PORTSDIR}/devel/yajl
+PLIST_SUB+= CURL_JSON=""
+.else
+CONFIGURE_ARGS+=--disable-curl_json
+PLIST_SUB+= CURL_JSON="@comment "
+.endif
+
+.if defined(WITH_CURL_XML)
+.if !defined(WITH_CURL)
+IGNORE= using CURL_XML requires CURL support
+.endif
+CONFIGURE_ARGS+=--enable-curl_xml
+LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
+PLIST_SUB+= CURL_XML=""
+.else
+CONFIGURE_ARGS+=--disable-curl_xml
+PLIST_SUB+= CURL_XML="@comment "
+.endif
+
.if defined(WITH_DBI)
CONFIGURE_ARGS+=--enable-dbi --with-libdbi=${LOCALBASE}
LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi
diff --git a/net-mgmt/collectd/distinfo b/net-mgmt/collectd/distinfo
index e543e8c05363..7d330eacfb21 100644
--- a/net-mgmt/collectd/distinfo
+++ b/net-mgmt/collectd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (collectd-4.9.5.tar.gz) = a9ea4aabc2a65ecbf8bc1ed80d4510b40e188b82dec4ba232582880072b02359
-SIZE (collectd-4.9.5.tar.gz) = 1701068
+SHA256 (collectd-4.10.3.tar.gz) = 69797d19f1782b243d8737072171611ebb16f972dc0021402df66905b8746033
+SIZE (collectd-4.10.3.tar.gz) = 1743443
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index ed2bc78dc0ac..28264480642c 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -25,6 +25,10 @@ lib/collectd/csv.la
lib/collectd/csv.so
%%CURL%%lib/collectd/curl.la
%%CURL%%lib/collectd/curl.so
+%%CURL_JSON%%lib/collectd/curl_json.la
+%%CURL_JSON%%lib/collectd/curl_json.so
+%%CURL_XML%%lib/collectd/curl_xml.la
+%%CURL_XML%%lib/collectd/curl_xml.so
%%DBI%%lib/collectd/dbi.la
%%DBI%%lib/collectd/dbi.so
%%DISK%%lib/collectd/disk.la
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index f766aced3895..2184730a1db8 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= collectd
-PORTVERSION= 4.9.5
+PORTVERSION= 4.10.3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -24,6 +24,8 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
APACHE "Input: Apache mod_status (libcurl)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
CURL "Input: CURL generic web statistics" Off \
+ CURL_JSON "Input: CURL JSON generic web statistics" Off \
+ CURL_XML "Input: CURL XML generic web statistics" Off \
DBI "Input: database abstraction library" Off \
DISK "Input: Disk performance statistics" Off \
NUTUPS "Input: NUT UPS daemon" Off \
@@ -47,8 +49,9 @@ USE_RC_SUBR= collectd collectdmon
USE_LDCONFIG= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
@@ -73,7 +76,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-conntrack \
--disable-contextswitch \
--disable-cpufreq \
- --disable-curl_json \
--disable-entropy \
--disable-fscache \
--disable-gmond \
@@ -91,6 +93,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-match_timediff \
--disable-match_value \
--disable-memcachec \
+ --disable-modbus \
--disable-multimeter \
--disable-netapp \
--disable-netlink \
@@ -101,6 +104,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-onewire \
--disable-oracle \
--disable-perl \
+ --disable-pinba \
--disable-python \
--disable-protocols \
--disable-routeros \
@@ -185,6 +189,30 @@ CONFIGURE_ARGS+=--disable-curl
PLIST_SUB+= CURL="@comment "
.endif
+.if defined(WITH_CURL_JSON)
+.if !defined(WITH_CURL)
+IGNORE= using CURL_JSON requires CURL support
+.endif
+CONFIGURE_ARGS+=--enable-curl_json
+LIB_DEPENDS+= yajl:${PORTSDIR}/devel/yajl
+PLIST_SUB+= CURL_JSON=""
+.else
+CONFIGURE_ARGS+=--disable-curl_json
+PLIST_SUB+= CURL_JSON="@comment "
+.endif
+
+.if defined(WITH_CURL_XML)
+.if !defined(WITH_CURL)
+IGNORE= using CURL_XML requires CURL support
+.endif
+CONFIGURE_ARGS+=--enable-curl_xml
+LIB_DEPENDS+= xml2:${PORTSDIR}/textproc/libxml2
+PLIST_SUB+= CURL_XML=""
+.else
+CONFIGURE_ARGS+=--disable-curl_xml
+PLIST_SUB+= CURL_XML="@comment "
+.endif
+
.if defined(WITH_DBI)
CONFIGURE_ARGS+=--enable-dbi --with-libdbi=${LOCALBASE}
LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
index e543e8c05363..7d330eacfb21 100644
--- a/net-mgmt/collectd5/distinfo
+++ b/net-mgmt/collectd5/distinfo
@@ -1,2 +1,2 @@
-SHA256 (collectd-4.9.5.tar.gz) = a9ea4aabc2a65ecbf8bc1ed80d4510b40e188b82dec4ba232582880072b02359
-SIZE (collectd-4.9.5.tar.gz) = 1701068
+SHA256 (collectd-4.10.3.tar.gz) = 69797d19f1782b243d8737072171611ebb16f972dc0021402df66905b8746033
+SIZE (collectd-4.10.3.tar.gz) = 1743443
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index ed2bc78dc0ac..28264480642c 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -25,6 +25,10 @@ lib/collectd/csv.la
lib/collectd/csv.so
%%CURL%%lib/collectd/curl.la
%%CURL%%lib/collectd/curl.so
+%%CURL_JSON%%lib/collectd/curl_json.la
+%%CURL_JSON%%lib/collectd/curl_json.so
+%%CURL_XML%%lib/collectd/curl_xml.la
+%%CURL_XML%%lib/collectd/curl_xml.so
%%DBI%%lib/collectd/dbi.la
%%DBI%%lib/collectd/dbi.so
%%DISK%%lib/collectd/disk.la