aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-07-10 22:28:30 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-07-10 22:28:30 +0000
commitc893c9e13075524662894fed322ba09c2ecaab63 (patch)
tree0d5606636a1c87b3966c1304d5ec21656cd0acb0
parentcab52547411ac3b4dcb71c0bed8a6dc539316c6f (diff)
downloadports-c893c9e13075524662894fed322ba09c2ecaab63.tar.gz
ports-c893c9e13075524662894fed322ba09c2ecaab63.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--security/Makefile1
-rw-r--r--security/openvpn20/Makefile105
-rw-r--r--security/openvpn20/distinfo2
-rw-r--r--security/openvpn20/files/openvpn.in125
-rw-r--r--security/openvpn20/files/patch-CVE-2013-206174
-rw-r--r--security/openvpn20/files/patch-options.c29
-rw-r--r--security/openvpn20/files/patch-route.c10
-rw-r--r--security/openvpn20/files/patch-socket.h11
-rw-r--r--security/openvpn20/files/patch-t_cltsrv.sh11
-rw-r--r--security/openvpn20/files/pkg-message.in6
-rw-r--r--security/openvpn20/pkg-descr7
-rw-r--r--security/openvpn20/pkg-plist77
13 files changed, 1 insertions, 458 deletions
diff --git a/MOVED b/MOVED
index a3e47ce6c7d5..3d4494e0b14d 100644
--- a/MOVED
+++ b/MOVED
@@ -4425,3 +4425,4 @@ games/nethack34-qt|games/nethack34-gnome|2013-07-09|Uses unsupported QT version
audio/gdam||2013-07-10|Has expired: Broken for a while
devel/gnome-vfs1||2013-07-10|Has expired: No more depend on, No more supported upstream
textproc/ua-ispell|ukrainian/ispell|2013-07-10|Removed because it has been moved to ukrainian/ispell 12 years ago
+security/openvpn20|security/openvpn|2013-07-11|Has expired: Superseded by security/openvpn
diff --git a/security/Makefile b/security/Makefile
index e7c37266930d..4a183e266bdd 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -373,7 +373,6 @@
SUBDIR += openvpn-auth-radius
SUBDIR += openvpn-beta
SUBDIR += openvpn-devel
- SUBDIR += openvpn20
SUBDIR += openvpn22
SUBDIR += ophcrack
SUBDIR += opieprint
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
deleted file mode 100644
index bc29fb541159..000000000000
--- a/security/openvpn20/Makefile
+++ /dev/null
@@ -1,105 +0,0 @@
-# Created by: Matthias Andree <matthias.andree@gmx.de>
-# $FreeBSD$
-
-PORTNAME= openvpn
-PORTVERSION= 2.0.9
-PORTREVISION= 4
-CATEGORIES= security net
-# MASTER_SITES points to hosts in distinct data centers,
-# so just one MASTER_SITES entry should be OK.
-MASTER_SITES= http://openvpn.net/release/
-
-MAINTAINER= mandree@FreeBSD.org
-COMMENT= Secure IP/Ethernet tunnel daemon
-
-LICENSE= GPLv2
-
-DEPRECATED= Please migrate to a newer OpenVPN version
-EXPIRATION_DATE= 2013-07-11
-
-LATEST_LINK= openvpn20
-CONFLICTS_INSTALL= openvpn-2.[!0]* openvpn-beta-[0-9]* openvpn-devel-[0-9]*
-
-GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
- --with-lzo-headers=${LOCALBASE}/include
-
-MAN8= openvpn.8
-
-OPTIONS_DEFINE= PW_SAVE
-PW_SAVE_DESC= Interactive passwords may be read from a file
-
-USE_RC_SUBR= openvpn
-USE_LDCONFIG= ${PREFIX}/lib
-
-LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
-
-SUB_FILES= pkg-message
-SUB_LIST+= OSVERSION=${OSVERSION}
-
-.if defined(PACKAGE_BUILDING)
-WITHOUT_CHECK= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
-.ifdef (LOG_OPENVPN)
-CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
-.endif
-
-pre-fetch:
-.ifdef (LOG_OPENVPN)
- @${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
-.else
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " LOG_OPENVPN={Valid syslog facility, default LOG_DAEMON}"
- @${ECHO} " EXAMPLE: make LOG_OPENVPN=LOG_DAEMON"
- @${ECHO} ""
-.endif
-
-.if ${PORT_OPTIONS:MPW_SAVE}
-CONFIGURE_ARGS+= --enable-password-save
-.else
-CONFIGURE_ARGS+= --disable-password-save
-.endif
-
-post-patch:
- ${FIND} ${WRKSRC}/plugin -name Makefile \
- -exec ${REINPLACE_CMD} 's;gcc;${CC};g' '{}' +
-
-post-build:
- cd ${WRKSRC}/plugin/down-root && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS}
- cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
- @# self-tests here
-.if !defined(WITHOUT_CHECK)
- @${ECHO} ; ${ECHO} "### Note that you can skip these lengthy selftests with WITHOUT_CHECK=yes ###" ; ${ECHO}
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check
-.endif
-
-post-install:
- ${MKDIR} ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
- ${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam
-.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
- PORTS README
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
-.endfor
-.for dir in easy-rsa easy-rsa/2.0 sample-config-files
- ${MKDIR} ${DOCSDIR}/${dir}
- ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f \( -name '.*' -o -name Makefile \) -o -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
-.endfor
-.for dir in sample-scripts
- ${MKDIR} ${DOCSDIR}/${dir}
- ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_SCRIPT} \{\} ${DOCSDIR}/${dir} \;
-.endfor
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/security/openvpn20/distinfo b/security/openvpn20/distinfo
deleted file mode 100644
index f43f42dbf687..000000000000
--- a/security/openvpn20/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (openvpn-2.0.9.tar.gz) = 347c551e7c88affc1f4b7a4b715080253c9298dcc512ed29fe8ca5cd26d015d9
-SIZE (openvpn-2.0.9.tar.gz) = 669076
diff --git a/security/openvpn20/files/openvpn.in b/security/openvpn20/files/openvpn.in
deleted file mode 100644
index f4f1dbdbb7ad..000000000000
--- a/security/openvpn20/files/openvpn.in
+++ /dev/null
@@ -1,125 +0,0 @@
-#!/bin/sh
-#
-# openvpn.sh - load tun/tap driver and start OpenVPN daemon
-#
-# (C) Copyright 2005 - 2008, 2010 by Matthias Andree
-# based on suggestions by Matthias Grimm and Dirk Gouders
-# with multi-instance contribution from Denis Shaposhnikov, Gleb Kozyrev
-# and Vasil Dimov
-# softrestart feature suggested by Nick Hibma
-#
-# $FreeBSD$
-#
-# This program is free software; you can redistribute it and/or modify it under
-# the terms of the GNU General Public License as published by the Free Software
-# Foundation; either version 2 of the License, or (at your option) any later
-# version.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
-# FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
-# details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 51 Franklin
-# Street, Fifth Floor, Boston, MA 02110-1301, USA.
-
-# PROVIDE: openvpn
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-
-# -----------------------------------------------------------------------------
-#
-# This script supports running multiple instances of openvpn.
-# To run additional instances link this script to something like
-# % ln -s openvpn openvpn_foo
-# and define additional openvpn_foo_* variables in one of
-# /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/openvpn_foo
-#
-# Below NAME should be substituted with the name of this script. By default
-# it is openvpn, so read as openvpn_enable. If you linked the script to
-# openvpn_foo, then read as openvpn_foo_enable etc.
-#
-# The following variables are supported (defaults are shown).
-# You can place them in any of
-# /etc/rc.conf, /etc/rc.conf.local or /etc/rc.conf.d/NAME
-#
-# NAME_enable="NO" # set to YES to enable openvpn
-# NAME_if= # driver(s) to load, set to "tun", "tap" or "tun tap"
-# # it is OK to specify the if_ prefix.
-#
-# # optional:
-# NAME_flags= # additional command line arguments
-# NAME_configfile="%%PREFIX%%/etc/openvpn/NAME.conf" # --config file
-# NAME_dir="%%PREFIX%%/etc/openvpn" # --cd directory
-#
-# You also need to set NAME_configfile and NAME_dir, if the configuration
-# file and directory where keys and certificates reside differ from the above
-# settings.
-#
-# Note that we deliberately refrain from unloading drivers.
-#
-# For further documentation, please see openvpn(8).
-#
-
-. /etc/rc.subr
-
-case "$0" in
-/etc/rc*)
- # during boot (shutdown) $0 is /etc/rc (/etc/rc.shutdown),
- # so get the name of the script from $_file
- name="$_file"
- ;;
-*)
- name="$0"
- ;;
-esac
-
-name="${name##*/}"
-rcvar=${name}_enable
-
-stop_postcmd()
-{
- rm -f "$pidfile" || warn "Could not remove $pidfile."
-}
-
-softrestart()
-{
- sig_reload=USR1 run_rc_command reload
- exit $?
-}
-
-# reload: support SIGHUP to reparse configuration file
-# softrestart: support SIGUSR1 to reconnect without superuser privileges
-extra_commands="reload softrestart"
-softrestart_cmd="softrestart"
-
-# pidfile
-pidfile="/var/run/${name}.pid"
-
-# command and arguments
-command="%%PREFIX%%/sbin/openvpn"
-
-# run this last
-stop_postcmd="stop_postcmd"
-
-load_rc_config ${name}
-
-eval ": \${${name}_enable:=\"NO\"}"
-eval ": \${${name}_configfile:=\"%%PREFIX%%/etc/openvpn/${name}.conf\"}"
-eval ": \${${name}_dir:=\"%%PREFIX%%/etc/openvpn\"}"
-
-configfile="$(eval echo \${${name}_configfile})"
-dir="$(eval echo \${${name}_dir})"
-interfaces="$(eval echo \${${name}_if})"
-
-required_modules=
-for i in $interfaces ; do
- required_modules="$required_modules${required_modules:+" "}if_${i#if_}"
-done
-
-required_files=${configfile}
-
-command_args="--cd ${dir} --daemon ${name} --config ${configfile} --writepid ${pidfile}"
-
-run_rc_command "$1"
diff --git a/security/openvpn20/files/patch-CVE-2013-2061 b/security/openvpn20/files/patch-CVE-2013-2061
deleted file mode 100644
index fc622b37a131..000000000000
--- a/security/openvpn20/files/patch-CVE-2013-2061
+++ /dev/null
@@ -1,74 +0,0 @@
-commit 11d21349a4e7e38a025849479b36ace7c2eec2ee
-Author: Steffan Karger <steffan.karger@fox-it.com>
-Date: Tue Mar 19 13:01:50 2013 +0100
-
- Use constant time memcmp when comparing HMACs in openvpn_decrypt.
-
- Signed-off-by: Steffan Karger <steffan.karger@fox-it.com>
- Acked-by: Gert Doering <gert@greenie.muc.de>
- Signed-off-by: Gert Doering <gert@greenie.muc.de>
-
-diff --git a/src/openvpn/buffer.h b/src/openvpn/buffer.h
-index 7cae733..93efb09 100644
---- ./buffer.h~
-+++ ./buffer.h
-@@ -668,6 +668,10 @@ buf_read_u32 (struct buffer *buf, bool *good)
- }
- }
-
-+/**
-+ * Compare src buffer contents with match.
-+ * *NOT* constant time. Do not use when comparing HMACs.
-+ */
- static inline bool
- buf_string_match (const struct buffer *src, const void *match, int size)
- {
-@@ -676,6 +680,10 @@ buf_string_match (const struct buffer *src, const void *match, int size)
- return memcmp (BPTR (src), match, size) == 0;
- }
-
-+/**
-+ * Compare first size bytes of src buffer contents with match.
-+ * *NOT* constant time. Do not use when comparing HMACs.
-+ */
- static inline bool
- buf_string_match_head (const struct buffer *src, const void *match, int size)
- {
-diff --git a/src/openvpn/crypto.c b/src/openvpn/crypto.c
-index 405c0aa..d9adf5b 100644
---- ./crypto.c~
-+++ ./crypto.c
-@@ -65,6 +65,24 @@
- #define CRYPT_ERROR(format) \
- do { msg (D_CRYPT_ERRORS, "%s: " format, error_prefix); goto error_exit; } while (false)
-
-+/**
-+ * As memcmp(), but constant-time.
-+ * Returns 0 when data is equal, non-zero otherwise.
-+ */
-+static int
-+memcmp_constant_time (const void *a, const void *b, size_t size) {
-+ const uint8_t * a1 = a;
-+ const uint8_t * b1 = b;
-+ int ret = 0;
-+ size_t i;
-+
-+ for (i = 0; i < size; i++) {
-+ ret |= *a1++ ^ *b1++;
-+ }
-+
-+ return ret;
-+}
-+
- void
- openvpn_encrypt (struct buffer *buf, struct buffer work,
- const struct crypto_options *opt,
-@@ -244,7 +262,7 @@ openvpn_decrypt (struct buffer *buf, struct buffer work,
- hmac_ctx_final (ctx->hmac, local_hmac);
-
- /* Compare locally computed HMAC with packet HMAC */
-- if (memcmp (local_hmac, BPTR (buf), hmac_len))
-+ if (memcmp_constant_time (local_hmac, BPTR (buf), hmac_len))
- CRYPT_ERROR ("packet HMAC authentication failed");
-
- ASSERT (buf_advance (buf, hmac_len));
diff --git a/security/openvpn20/files/patch-options.c b/security/openvpn20/files/patch-options.c
deleted file mode 100644
index 4c6181f5c24d..000000000000
--- a/security/openvpn20/files/patch-options.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./options.c.orig 2011-06-20 23:21:51.000000000 +0200
-+++ ./options.c 2011-06-20 23:22:06.000000000 +0200
-@@ -3002,7 +3002,7 @@
- {
- if (options->inetd != -1)
- {
-- msg (msglevel, opterr);
-+ msg (msglevel, "%s", opterr);
- goto err;
- }
- else
-@@ -3012,7 +3012,7 @@
- {
- if (options->inetd != -1)
- {
-- msg (msglevel, opterr);
-+ msg (msglevel, "%s", opterr);
- goto err;
- }
- else
-@@ -3022,7 +3022,7 @@
- {
- if (name != NULL)
- {
-- msg (msglevel, opterr);
-+ msg (msglevel, "%s", opterr);
- goto err;
- }
- name = p[z];
diff --git a/security/openvpn20/files/patch-route.c b/security/openvpn20/files/patch-route.c
deleted file mode 100644
index 243445716b5c..000000000000
--- a/security/openvpn20/files/patch-route.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./route.c.orig 2006-04-05 08:13:55.000000000 +0200
-+++ ./route.c 2011-06-20 23:19:43.000000000 +0200
-@@ -1310,6 +1310,7 @@
-
- #elif defined(TARGET_FREEBSD)
-
-+#include <err.h>
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
diff --git a/security/openvpn20/files/patch-socket.h b/security/openvpn20/files/patch-socket.h
deleted file mode 100644
index 3030077c8ca2..000000000000
--- a/security/openvpn20/files/patch-socket.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./socket.h.orig 2005-11-01 12:06:11.000000000 +0100
-+++ ./socket.h 2013-01-11 21:51:45.000000000 +0100
-@@ -204,7 +204,7 @@
-
- #if PASSTOS_CAPABILITY
- /* used to get/set TOS. */
-- uint8_t ptos;
-+ int ptos;
- bool ptos_defined;
- #endif
-
diff --git a/security/openvpn20/files/patch-t_cltsrv.sh b/security/openvpn20/files/patch-t_cltsrv.sh
deleted file mode 100644
index c5deea6254de..000000000000
--- a/security/openvpn20/files/patch-t_cltsrv.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./t_cltsrv.sh.orig 2011-07-20 22:10:38.000000000 +0200
-+++ ./t_cltsrv.sh 2011-07-20 22:10:52.000000000 +0200
-@@ -33,7 +33,7 @@
- echo "###"
- echo "### To run the test in a FreeBSD jail, you MUST add an IP alias for the jail's IP."
- echo "###"
-- exit 1
-+ exit 77
- fi
- fi
- ;;
diff --git a/security/openvpn20/files/pkg-message.in b/security/openvpn20/files/pkg-message.in
deleted file mode 100644
index 766203f9fc76..000000000000
--- a/security/openvpn20/files/pkg-message.in
+++ /dev/null
@@ -1,6 +0,0 @@
-### ------------------------------------------------------------------------
-### Edit /etc/rc.conf[.local] to start OpenVPN automatically at system
-### startup. See %%PREFIX%%/etc/rc.d/openvpn for details.
-### ------------------------------------------------------------------------
-### For compatibility information, see <http://openvpn.net/relnotes.html>
-### ------------------------------------------------------------------------
diff --git a/security/openvpn20/pkg-descr b/security/openvpn20/pkg-descr
deleted file mode 100644
index 751e62d362d1..000000000000
--- a/security/openvpn20/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-OpenVPN is a robust, scalable and highly configurable VPN (Virtual Private
-Network) daemon which can be used to securely link two or more private networks
-using an encrypted tunnel over the internet. It can operate over UDP or TCP,
-can use SSL or a pre-shared secret to authenticate peers, and in SSL mode, one
-server can handle many clients.
-
-WWW: http://openvpn.net/index.php/open-source.html
diff --git a/security/openvpn20/pkg-plist b/security/openvpn20/pkg-plist
deleted file mode 100644
index 868afe6a6755..000000000000
--- a/security/openvpn20/pkg-plist
+++ /dev/null
@@ -1,77 +0,0 @@
-sbin/openvpn
-lib/openvpn-auth-pam.so
-lib/openvpn-down-root.so
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.GPL
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/PORTS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-auth-pam
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-down-root
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/make-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/revoke-crt
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/inherit-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl-0.9.6.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/pkitool
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/whichopensslcnf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/README
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/client.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/firewall.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/home.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-client
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/loopback-server
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/office.up
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-shutdown.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/openvpn-startup.sh
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/server.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/static-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-home.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/tls-office.conf
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-client-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/xinetd-server-config
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/auth-pam.pl
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-start
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-stop
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/openvpn.init
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/verify-cn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-scripts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-config-files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/2.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa
-%%PORTDOCS%%@dirrm %%DOCSDIR%%