aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-07-04 14:41:05 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-07-04 14:41:05 +0000
commiteb1d4686d04498c1f9d685750dd8c05b2ce7a78d (patch)
treea2fd3bcd71a08a27f1d17964bf37779b2ed6342f
parent44797ea26988efe41cd25ee37ceb24f5f55c6b48 (diff)
downloadports-eb1d4686d04498c1f9d685750dd8c05b2ce7a78d.tar.gz
ports-eb1d4686d04498c1f9d685750dd8c05b2ce7a78d.zip
Notes
-rw-r--r--math/Makefile1
-rw-r--r--math/hfst/Makefile22
-rw-r--r--math/hfst/distinfo2
-rw-r--r--math/hfst/files/patch-tools-src-hfst-commandline.cc10
-rw-r--r--math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc10
-rw-r--r--math/hfst/pkg-descr5
-rw-r--r--math/hfst/pkg-plist195
7 files changed, 245 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 968629d0db99..c5f3db51dee5 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -163,6 +163,7 @@
SUBDIR += grpn
SUBDIR += gsl
SUBDIR += hexcalc
+ SUBDIR += hfst
SUBDIR += hs-Agda
SUBDIR += hs-NumInstances
SUBDIR += hs-categories
diff --git a/math/hfst/Makefile b/math/hfst/Makefile
new file mode 100644
index 000000000000..a6a4e7d7b051
--- /dev/null
+++ b/math/hfst/Makefile
@@ -0,0 +1,22 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= hfst
+PORTVERSION= 3.7.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}/${PORTNAME}/archive
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A toolkit for for processing natural language morphologies
+
+USES= pkgconfig shebangfix libtool
+USE_GNOME= glib20
+USE_GCC= yes
+USE_PYTHON= 2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-readline --with-unicode-handler=glib --enable-proc --enable-tagger --enable-xfst --enable-shuffle --enable-traverse
+SHEBANG_FILES= tools/src/hfst-tagger/src/hfst_tagger_compute_data_statistics.py
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/hfst/distinfo b/math/hfst/distinfo
new file mode 100644
index 000000000000..0892c3ead632
--- /dev/null
+++ b/math/hfst/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hfst-3.7.1.tar.gz) = 5a43c93ea03b6a6a64c4f94843ad9c53695e6bef80139293fb8a330e72eac4cf
+SIZE (hfst-3.7.1.tar.gz) = 3103743
diff --git a/math/hfst/files/patch-tools-src-hfst-commandline.cc b/math/hfst/files/patch-tools-src-hfst-commandline.cc
new file mode 100644
index 000000000000..437fc7c464af
--- /dev/null
+++ b/math/hfst/files/patch-tools-src-hfst-commandline.cc
@@ -0,0 +1,10 @@
+--- tools/src/hfst-commandline.cc.orig 2014-07-04 18:13:51.000000000 +0400
++++ tools/src/hfst-commandline.cc 2014-07-04 18:14:35.000000000 +0400
+@@ -21,6 +21,7 @@
+ # include <config.h>
+ #endif
+
++#define _WITH_GETLINE
+ #include <cassert>
+ #include <climits>
+ #include <cmath>
diff --git a/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc b/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc
new file mode 100644
index 000000000000..860d7f73e813
--- /dev/null
+++ b/math/hfst/files/patch-tools-src-parsers-XfstCompiler.cc
@@ -0,0 +1,10 @@
+--- tools/src/parsers/XfstCompiler.cc.orig 2014-07-04 18:26:59.000000000 +0400
++++ tools/src/parsers/XfstCompiler.cc 2014-07-04 18:27:09.000000000 +0400
+@@ -18,6 +18,7 @@
+ # include <config.h>
+ #endif
+
++#define _WITH_GETLINE
+ #include <string>
+ #include <map>
+ #include <list>
diff --git a/math/hfst/pkg-descr b/math/hfst/pkg-descr
new file mode 100644
index 000000000000..1c80c75f2f7b
--- /dev/null
+++ b/math/hfst/pkg-descr
@@ -0,0 +1,5 @@
+The Helsinki Finite-State Transducer toolkit is intended for processing
+natural language morphologies. The toolkit is demonstrated by wide-coverage
+implementations of a number of languages of varying morphological complexity.
+
+WWW: http://hfst.sourceforge.net/
diff --git a/math/hfst/pkg-plist b/math/hfst/pkg-plist
new file mode 100644
index 000000000000..5b10359e925f
--- /dev/null
+++ b/math/hfst/pkg-plist
@@ -0,0 +1,195 @@
+bin/hfst-affix-guessify
+bin/hfst-apertium-proc
+bin/hfst-build-tagger
+bin/hfst-compare
+bin/hfst-compose
+bin/hfst-compose-intersect
+bin/hfst-concatenate
+bin/hfst-conjunct
+bin/hfst-determinise
+bin/hfst-determinize
+bin/hfst-disjunct
+bin/hfst-edit-metadata
+bin/hfst-expand
+bin/hfst-format
+bin/hfst-fst2fst
+bin/hfst-fst2strings
+bin/hfst-fst2txt
+bin/hfst-grep
+bin/hfst-guess
+bin/hfst-guessify
+bin/hfst-head
+bin/hfst-info
+bin/hfst-intersect
+bin/hfst-invert
+bin/hfst-lexc
+bin/hfst-lookup
+bin/hfst-minimise
+bin/hfst-minimize
+bin/hfst-minus
+bin/hfst-multiply
+bin/hfst-name
+bin/hfst-open-input-file-for-tagger
+bin/hfst-optimised-lookup
+bin/hfst-optimized-lookup
+bin/hfst-pair-test
+bin/hfst-pmatch
+bin/hfst-pmatch2fst
+bin/hfst-proc
+bin/hfst-project
+bin/hfst-prune-alphabet
+bin/hfst-push-weights
+bin/hfst-regexp2fst
+bin/hfst-remove-epsilons
+bin/hfst-repeat
+bin/hfst-reverse
+bin/hfst-reweight
+bin/hfst-reweight-tagger
+bin/hfst-sfstpl2fst
+bin/hfst-shuffle
+bin/hfst-split
+bin/hfst-strings2fst
+bin/hfst-substitute
+bin/hfst-subtract
+bin/hfst-summarise
+bin/hfst-summarize
+bin/hfst-tag
+bin/hfst-tail
+bin/hfst-train-tagger
+bin/hfst-train-tagger-loc
+bin/hfst-train-tagger-system
+bin/hfst-traverse
+bin/hfst-twolc
+bin/hfst-twolc-loc
+bin/hfst-twolc-system
+bin/hfst-txt2fst
+bin/hfst-union
+bin/hfst-xfst
+bin/hfst_tagger_compute_data_statistics.py
+bin/htwolcpre1
+bin/htwolcpre2
+bin/htwolcpre3
+include/hfst/ComposeIntersectFst.h
+include/hfst/ComposeIntersectLexicon.h
+include/hfst/ComposeIntersectRule.h
+include/hfst/ComposeIntersectRulePair.h
+include/hfst/ConvertTransducerFormat.h
+include/hfst/FomaTransducer.h
+include/hfst/FormatSpecifiers.h
+include/hfst/HarmonizeUnknownAndIdentitySymbols.h
+include/hfst/HfstDataTypes.h
+include/hfst/HfstEpsilonHandler.h
+include/hfst/HfstExceptionDefs.h
+include/hfst/HfstExtractStrings.h
+include/hfst/HfstFastTransitionData.h
+include/hfst/HfstFlagDiacritics.h
+include/hfst/HfstInputStream.h
+include/hfst/HfstLookupFlagDiacritics.h
+include/hfst/HfstOlTransducer.h
+include/hfst/HfstOutputStream.h
+include/hfst/HfstSymbolDefs.h
+include/hfst/HfstTokenizer.h
+include/hfst/HfstTransducer.h
+include/hfst/HfstTransition.h
+include/hfst/HfstTransitionGraph.h
+include/hfst/HfstTropicalTransducerTransitionData.h
+include/hfst/HfstXeroxRules.h
+include/hfst/LexcCompiler.h
+include/hfst/LogWeightTransducer.h
+include/hfst/PmatchCompiler.h
+include/hfst/SfstTransducer.h
+include/hfst/TropicalWeightTransducer.h
+include/hfst/XreCompiler.h
+include/hfst/hfst.h
+include/hfst/hfst_apply_schemas.h
+include/hfst/implementations/ComposeIntersectFst.h
+include/hfst/implementations/ComposeIntersectLexicon.h
+include/hfst/implementations/ComposeIntersectRule.h
+include/hfst/implementations/ComposeIntersectRulePair.h
+include/hfst/implementations/ComposeIntersectUtilities.h
+include/hfst/implementations/ConvertTransducerFormat.h
+include/hfst/implementations/FomaTransducer.h
+include/hfst/implementations/HfstFastTransitionData.h
+include/hfst/implementations/HfstOlTransducer.h
+include/hfst/implementations/HfstTransition.h
+include/hfst/implementations/HfstTransitionGraph.h
+include/hfst/implementations/HfstTropicalTransducerTransitionData.h
+include/hfst/implementations/LogWeightTransducer.h
+include/hfst/implementations/SfstTransducer.h
+include/hfst/implementations/TropicalWeightTransducer.h
+include/hfst/implementations/compose_intersect/ComposeIntersectFst.h
+include/hfst/implementations/compose_intersect/ComposeIntersectLexicon.h
+include/hfst/implementations/compose_intersect/ComposeIntersectRule.h
+include/hfst/implementations/compose_intersect/ComposeIntersectRulePair.h
+include/hfst/implementations/compose_intersect/ComposeIntersectUtilities.h
+include/hfst/implementations/optimized-lookup/convert.h
+include/hfst/implementations/optimized-lookup/pmatch.h
+include/hfst/implementations/optimized-lookup/transducer.h
+include/hfst/parsers/LexcCompiler.h
+include/hfst/parsers/PmatchCompiler.h
+include/hfst/parsers/XreCompiler.h
+include/hfst/parsers/lexc-utils.h
+include/hfst/parsers/pmatch_utils.h
+include/hfst/parsers/xre_utils.h
+lib/libhfst.a
+lib/libhfst.so
+lib/libhfst.so.36
+lib/libhfst.so.36.0.0
+lib/pkgconfig/hfst.pc
+%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.py
+%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.pyc
+%%PYTHON_SITELIBDIR%%/hfst_tagger_compute_data_statistics.pyo
+%%PYTHON_SITELIBDIR%%/tagger_aux.py
+%%PYTHON_SITELIBDIR%%/tagger_aux.pyc
+%%PYTHON_SITELIBDIR%%/tagger_aux.pyo
+man/man1/hfst-apertium-proc.1.gz
+man/man1/hfst-calculate.1.gz
+man/man1/hfst-compare.1.gz
+man/man1/hfst-compose-intersect.1.gz
+man/man1/hfst-compose.1.gz
+man/man1/hfst-concatenate.1.gz
+man/man1/hfst-conjunct.1.gz
+man/man1/hfst-determinise.1.gz
+man/man1/hfst-determinize.1.gz
+man/man1/hfst-disjunct.1.gz
+man/man1/hfst-expand.1.gz
+man/man1/hfst-foma.1.gz
+man/man1/hfst-format.1.gz
+man/man1/hfst-fst2fst.1.gz
+man/man1/hfst-fst2strings.1.gz
+man/man1/hfst-fst2txt.1.gz
+man/man1/hfst-head.1.gz
+man/man1/hfst-intersect.1.gz
+man/man1/hfst-invert.1.gz
+man/man1/hfst-lexc-wrapper.1.gz
+man/man1/hfst-lexc.1.gz
+man/man1/hfst-lookup.1.gz
+man/man1/hfst-minimise.1.gz
+man/man1/hfst-minimize.1.gz
+man/man1/hfst-minus.1.gz
+man/man1/hfst-name.1.gz
+man/man1/hfst-proc.1.gz
+man/man1/hfst-project.1.gz
+man/man1/hfst-push-weights.1.gz
+man/man1/hfst-regexp2fst.1.gz
+man/man1/hfst-remove-epsilons.1.gz
+man/man1/hfst-repeat.1.gz
+man/man1/hfst-reverse.1.gz
+man/man1/hfst-sfstpl2fst.1.gz
+man/man1/hfst-split.1.gz
+man/man1/hfst-strings2fst.1.gz
+man/man1/hfst-substitute.1.gz
+man/man1/hfst-subtract.1.gz
+man/man1/hfst-summarise.1.gz
+man/man1/hfst-summarize.1.gz
+man/man1/hfst-tail.1.gz
+man/man1/hfst-txt2fst.1.gz
+man/man1/hfst-union.1.gz
+man/man1/hfst-xfst.1.gz
+share/aclocal/hfst.m4
+@dirrm include/hfst/implementations/compose_intersect
+@dirrm include/hfst/implementations/optimized-lookup
+@dirrm include/hfst/implementations
+@dirrm include/hfst/parsers
+@dirrm include/hfst
+@dirrmtry lib/pkgconfig