aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-14 16:25:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-14 16:25:21 +0000
commit054ac7ea5014455293b868fbf962996d6beef5e3 (patch)
tree07bb0ff9643ebd3d1234686814d66bf988752901
parentaea168d84548d96ab45ee9e1825476fba3f40bc9 (diff)
downloadports-054ac7ea5014455293b868fbf962996d6beef5e3.tar.gz
ports-054ac7ea5014455293b868fbf962996d6beef5e3.zip
Notes
-rw-r--r--net/avahi-app/Makefile54
-rw-r--r--net/avahi-app/files/patch-avahi-ui_Makefile.in28
-rw-r--r--net/avahi-app/pkg-plist15
-rw-r--r--net/avahi-autoipd/Makefile5
-rw-r--r--net/avahi-autoipd/pkg-plist3
-rw-r--r--net/avahi-gtk/Makefile11
-rw-r--r--net/avahi-gtk/pkg-plist3
-rw-r--r--net/avahi-gtk3/Makefile5
-rw-r--r--net/avahi-header/Makefile5
-rw-r--r--net/avahi-libdns/Makefile3
-rw-r--r--net/avahi-qt4/Makefile3
-rw-r--r--net/avahi-sharp/Makefile3
-rw-r--r--net/avahi/Makefile7
-rw-r--r--net/py-avahi/Makefile22
-rw-r--r--net/py-avahi/pkg-plist6
15 files changed, 94 insertions, 79 deletions
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 55140954c593..29e0d5c1aa84 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -15,17 +15,15 @@ COMMENT?= Service discovery on a local network
AVAHI_SLAVE?= no
.if ${AVAHI_SLAVE} != header
-BUILD_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS?= expat:${PORTSDIR}/textproc/expat2 \
- daemon.0:${PORTSDIR}/devel/libdaemon \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
- gdbm:${PORTSDIR}/databases/gdbm
-RUN_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS?= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libdaemon.so:${PORTSDIR}/devel/libdaemon \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libgdbm.so:${PORTSDIR}/databases/gdbm
USERS?= ${PORTNAME}
GROUPS?= ${USERS}
-USE_GNOME+= ltverhack glib20 intltool
+USE_GNOME+= ltverhack glib20 intltool introspection
USES= gettext gmake pathfix pkgconfig
USE_GNOME_SUBR= yes
USE_AUTOTOOLS= libtool
@@ -44,23 +42,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
.if ${AVAHI_SLAVE} == no
CONFLICTS= howl-[0-9]*
-MAN1= avahi-browse.1 avahi-publish.1 avahi-resolve.1 avahi-set-host-name.1
-MAN5= avahi-daemon.conf.5 avahi.service.5 avahi.hosts.5
-MAN8= avahi-daemon.8 avahi-dnsconfd.8 avahi-dnsconfd.action.8
-
-MLINKS= avahi-browse.1 avahi-browse-domains.1 \
- avahi-publish.1 avahi-publish-address.1 \
- avahi-publish.1 avahi-publish-service.1 \
- avahi-resolve.1 avahi-resolve-address.1 \
- avahi-resolve.1 avahi-resolve-host-name.1
-
DAEMON_CONFIG_FILES= hosts avahi-daemon.conf
.endif
USE_RC_SUBR=yes
.endif # !avahi-header
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${AVAHI_SLAVE} != header
@@ -141,33 +128,36 @@ pre-su-install: avahi-pre-su-install
avahi-pre-su-install:
.if ${AVAHI_SLAVE}=="no"
- @${MKDIR} ${PREFIX}/lib/avahi
- @${TOUCH} -f ${PREFIX}/lib/avahi/.keep
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/avahi
+ @${TOUCH} -f ${STAGEDIR}${PREFIX}/lib/avahi/.keep
.endif
post-install: avahi-post-install
avahi-post-install:
-.if ${AVAHI_SLAVE}!="no"
-.for f in ${MAN1} ${MAN2} ${MAN3} ${MAN4} ${MAN5} ${MAN6} ${MAN7} ${MAN8} ${MAN9}
- ${INSTALL_DATA} ${WRKSRC}/man/${f} ${PREFIX}/man/man${f:E}/${f}
+.if defined(MANPAGES)
+.for f in ${MANPAGES}
+ ${INSTALL_DATA} ${WRKSRC}/man/${f} ${STAGEDIR}${PREFIX}/man/man${f:E}/${f}
.endfor
.endif
.for f in ${AVAHI_PKGCONFIG}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/libdata/pkgconfig
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/libdata/pkgconfig
.endfor
- ${MKDIR} ${PREFIX}/etc/avahi
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/avahi
.for f in ${DAEMON_CONFIG_FILES}
${INSTALL_DATA} ${WRKSRC}/avahi-daemon/${f} \
- ${PREFIX}/etc/avahi/${f}.dist
- if [ ! -f ${PREFIX}/etc/avahi/${f} ]; then \
- ${INSTALL_DATA} ${WRKSRC}/avahi-daemon/${f} \
- ${PREFIX}/etc/avahi; \
- fi
+ ${STAGEDIR}${PREFIX}/etc/avahi/${f}.dist
.endfor
-.if ${AVAHI_SLAVE}=="no"
+.if ${AVAHI_SLAVE}==no
${INSTALL_DATA} ${FILESDIR}/org.freedesktop.Avahi.service \
- ${LOCALBASE}/share/dbus-1/system-services
+ ${STAGEDIR}${PREFIX}/share/dbus-1/system-services
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so*
+.elif ${AVAHI_SLAVE}==gtk3
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libavahi-ui-gtk3.so.0
+.elif ${AVAHI_SLAVE}==libdns
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libdns_sd.so.1
+.elif ${AVAHI_SLAVE}==qt4
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libavahi-qt4.so.1
.endif
.endif # avahi-header
diff --git a/net/avahi-app/files/patch-avahi-ui_Makefile.in b/net/avahi-app/files/patch-avahi-ui_Makefile.in
index ac34b5bb05de..dda4713b1c86 100644
--- a/net/avahi-app/files/patch-avahi-ui_Makefile.in
+++ b/net/avahi-app/files/patch-avahi-ui_Makefile.in
@@ -1,6 +1,6 @@
---- avahi-ui/Makefile.in.orig 2012-04-03 18:30:32.000000000 +0200
-+++ avahi-ui/Makefile.in 2012-04-03 18:33:59.000000000 +0200
-@@ -119,9 +119,7 @@ am__installdirs = "$(DESTDIR)$(libdir)"
+--- avahi-ui/Makefile.in.orig 2013-12-11 12:03:44.000000000 +0100
++++ avahi-ui/Makefile.in 2013-12-11 12:05:00.000000000 +0100
+@@ -125,9 +125,7 @@ am__installdirs = "$(DESTDIR)$(libdir)"
"$(DESTDIR)$(desktopdir)" "$(DESTDIR)$(avahiincludedir)"
LTLIBRARIES = $(lib_LTLIBRARIES)
am__DEPENDENCIES_1 =
@@ -11,7 +11,7 @@
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__DEPENDENCIES_1) \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__DEPENDENCIES_1)
am__libavahi_ui_gtk3_la_SOURCES_DIST = avahi-ui.h avahi-ui.c \
-@@ -142,9 +140,7 @@ libavahi_ui_gtk3_la_LINK = $(LIBTOOL) $(
+@@ -148,9 +146,7 @@ libavahi_ui_gtk3_la_LINK = $(LIBTOOL) $(
$(libavahi_ui_gtk3_la_LDFLAGS) $(LDFLAGS) -o $@
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@@HAVE_GTK3_TRUE@am_libavahi_ui_gtk3_la_rpath = -rpath \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@@HAVE_GTK3_TRUE@ $(libdir)
@@ -22,7 +22,7 @@
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__DEPENDENCIES_1) \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__DEPENDENCIES_1)
am__libavahi_ui_la_SOURCES_DIST = avahi-ui.h avahi-ui.c \
-@@ -166,12 +162,8 @@ am__bssh_SOURCES_DIST = bssh.c
+@@ -172,12 +168,8 @@ am__bssh_SOURCES_DIST = bssh.c
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@am_bssh_OBJECTS = bssh-bssh.$(OBJEXT)
bssh_OBJECTS = $(am_bssh_OBJECTS)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@@HAVE_GTK3_FALSE@bssh_DEPENDENCIES = $(am__DEPENDENCIES_1) \
@@ -35,7 +35,17 @@
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@@HAVE_GTK3_TRUE@ libavahi-ui-gtk3.la
bssh_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(LIBTOOLFLAGS) --mode=link $(CCLD) $(bssh_CFLAGS) $(CFLAGS) \
-@@ -482,9 +474,7 @@ EXTRA_DIST = $(desktop_DATA_in_in)
+@@ -464,8 +456,7 @@ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+
+ # This cool debug trap works on i386/gcc only
+-AM_CFLAGS = -I$(top_srcdir) -DG_DISABLE_DEPRECATED=1 \
+- -DGDK_DISABLE_DEPRECATED=1 -DGTK_DISABLE_DEPRECATED=1 \
++AM_CFLAGS = -I$(top_srcdir) \
+ '-DDEBUG_TRAP=__asm__("int $$3")' $(am__append_1)
+ pkglibdatadir = $(libdir)/avahi
+ desktopdir = $(datadir)/applications
+@@ -489,9 +480,7 @@ EXTRA_DIST = $(desktop_DATA_in_in)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__append_5) \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__append_10)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@libavahi_ui_la_LIBADD = $(AM_LDADD) \
@@ -46,7 +56,7 @@
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(GTK20_LIBS) \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__append_6)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@libavahi_ui_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBAVAHI_UI_VERSION_INFO)
-@@ -494,17 +484,15 @@ EXTRA_DIST = $(desktop_DATA_in_in)
+@@ -501,17 +490,15 @@ EXTRA_DIST = $(desktop_DATA_in_in)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__append_7) \
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@ $(am__append_11)
@HAVE_DBUS_TRUE@@HAVE_GLIB_TRUE@@HAVE_GTK2OR3_TRUE@libavahi_ui_gtk3_la_LIBADD = $(AM_LDADD) \
@@ -67,7 +77,7 @@
CLEANFILES = $(desktop_DATA) $(desktop_DATA_in)
all: all-am
-@@ -713,7 +701,7 @@ clean-libtool:
+@@ -711,7 +698,7 @@ clean-libtool:
-rm -rf .libs _libs
install-desktopDATA: $(desktop_DATA)
@$(NORMAL_INSTALL)
@@ -75,4 +85,4 @@
+@HAVE_GTK_TRUE@ test -z "$(desktopdir)" || $(MKDIR_P) "$(DESTDIR)$(desktopdir)"
@list='$(desktop_DATA)'; test -n "$(desktopdir)" || list=; \
for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
diff --git a/net/avahi-app/pkg-plist b/net/avahi-app/pkg-plist
index 4f3dd83596f8..d56a940716c3 100644
--- a/net/avahi-app/pkg-plist
+++ b/net/avahi-app/pkg-plist
@@ -102,6 +102,21 @@ libdata/pkgconfig/avahi-compat-howl.pc
libdata/pkgconfig/avahi-core.pc
libdata/pkgconfig/avahi-glib.pc
libdata/pkgconfig/avahi-gobject.pc
+man/man1/avahi-browse-domains.1.gz
+man/man1/avahi-browse.1.gz
+man/man1/avahi-publish-address.1.gz
+man/man1/avahi-publish-service.1.gz
+man/man1/avahi-publish.1.gz
+man/man1/avahi-resolve-address.1.gz
+man/man1/avahi-resolve-host-name.1.gz
+man/man1/avahi-resolve.1.gz
+man/man1/avahi-set-host-name.1.gz
+man/man5/avahi-daemon.conf.5.gz
+man/man5/avahi.hosts.5.gz
+man/man5/avahi.service.5.gz
+man/man8/avahi-daemon.8.gz
+man/man8/avahi-dnsconfd.8.gz
+man/man8/avahi-dnsconfd.action.8.gz
sbin/avahi-daemon
sbin/avahi-dnsconfd
%%DATADIR%%/avahi-service.dtd
diff --git a/net/avahi-autoipd/Makefile b/net/avahi-autoipd/Makefile
index 7647186153ca..0a92a959b6a3 100644
--- a/net/avahi-autoipd/Makefile
+++ b/net/avahi-autoipd/Makefile
@@ -9,7 +9,7 @@ PKGNAMESUFFIX= -autoipd
MAINTAINER= gnome@FreeBSD.org
COMMENT= IPv4LL network address configuration daemon
-LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
USERS= avahi-autoipd
GROUPS= ${USERS}
@@ -22,7 +22,6 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= autoipd
-MAN8= avahi-autoipd.8
+MANPAGES= avahi-autoipd.8
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-autoipd/pkg-plist b/net/avahi-autoipd/pkg-plist
index 1b558b08b699..f2104bbda044 100644
--- a/net/avahi-autoipd/pkg-plist
+++ b/net/avahi-autoipd/pkg-plist
@@ -1,3 +1,4 @@
etc/avahi/avahi-autoipd.action
sbin/avahi-autoipd
-@dirrm etc/avahi
+man/man8/avahi-autoipd.8.gz
+@dirrmtry etc/avahi
diff --git a/net/avahi-gtk/Makefile b/net/avahi-gtk/Makefile
index 349d34997b04..c56a136c8030 100644
--- a/net/avahi-gtk/Makefile
+++ b/net/avahi-gtk/Makefile
@@ -9,7 +9,7 @@ PKGNAMESUFFIX= -gtk
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gtk+ tools and bindings to the Avahi mDNS system
-LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
RUN_DEPENDS= avahi-header>=0.6:${PORTSDIR}/net/avahi-header
MASTERDIR= ${.CURDIR}/../avahi-app
@@ -21,12 +21,10 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= gtk
AVAHI_PKGCONFIG=avahi-ui.pc
-MAN1+= bssh.1
-MLINKS+= bssh.1 bvnc.1 \
- bssh.1 bshell.1
+MANPAGES= bssh.1
+
USE_GNOME+= libglade2
-NO_STAGE= yes
post-build:
@(cd ${WRKSRC}/avahi-discover-standalone; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
@@ -34,5 +32,8 @@ post-build:
post-install:
@(cd ${WRKSRC}/avahi-discover-standalone; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+ ${LN} -sf man/man1/bssh.1 ${STAGEDIR}${PREFIX}/man/man1/bvnc.1
+ ${LN} -sf man/man1/bssh.1 ${STAGEDIR}${PREFIX}/man/man1/bshell.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libavahi-ui.so.0
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-gtk/pkg-plist b/net/avahi-gtk/pkg-plist
index c4c08504a81d..1a0ab945031e 100644
--- a/net/avahi-gtk/pkg-plist
+++ b/net/avahi-gtk/pkg-plist
@@ -7,6 +7,9 @@ lib/libavahi-ui.la
lib/libavahi-ui.so
lib/libavahi-ui.so.0
libdata/pkgconfig/avahi-ui.pc
+man/man1/bshell.1.gz
+man/man1/bssh.1.gz
+man/man1/bvnc.1.gz
share/applications/bssh.desktop
share/applications/bvnc.desktop
%%DATADIR%%/interfaces/avahi-discover.ui
diff --git a/net/avahi-gtk3/Makefile b/net/avahi-gtk3/Makefile
index 8469f21653ae..2214cbb16287 100644
--- a/net/avahi-gtk3/Makefile
+++ b/net/avahi-gtk3/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= -gtk3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gtk+ 3 library to the Avahi mDNS system
-LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
RUN_DEPENDS= avahi-header>=0.6:${PORTSDIR}/net/avahi-header
MASTERDIR= ${.CURDIR}/../avahi-app
@@ -22,11 +22,10 @@ AVAHI_PKGCONFIG=avahi-ui-gtk3.pc
USE_GNOME+= gtk30
-NO_STAGE= yes
do-build:
@(cd ${WRKSRC}/avahi-ui; ${GMAKE} libavahi-ui-gtk3.la)
do-install:
- @(cd ${WRKSRC}/avahi-ui; ${GMAKE} install-libLTLIBRARIES)
+ @(cd ${WRKSRC}/avahi-ui; ${GMAKE} ${MAKE_ARGS} install-libLTLIBRARIES)
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-header/Makefile b/net/avahi-header/Makefile
index 2ce09e26400a..c01960844085 100644
--- a/net/avahi-header/Makefile
+++ b/net/avahi-header/Makefile
@@ -20,10 +20,9 @@ AVAHI_SLAVE= header
NO_BUILD= yes
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/include/avahi-ui
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/include/avahi-ui
${INSTALL_DATA} ${BUILD_WRKSRC}/avahi-ui.h \
- ${PREFIX}/include/avahi-ui/
+ ${STAGEDIR}/${PREFIX}/include/avahi-ui/
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-libdns/Makefile b/net/avahi-libdns/Makefile
index 54503270afd8..7b1566c45cba 100644
--- a/net/avahi-libdns/Makefile
+++ b/net/avahi-libdns/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= -libdns
MAINTAINER= gnome@FreeBSD.org
COMMENT= mDNSResponder compatibility from Avahi
-LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-compat-libdns_sd
@@ -21,5 +21,4 @@ AVAHI_PKGCONFIG=avahi-compat-libdns_sd.pc
CONFLICTS= mDNSResponder-[0-9]*
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-qt4/Makefile b/net/avahi-qt4/Makefile
index d73228a621af..f3576a54dab2 100644
--- a/net/avahi-qt4/Makefile
+++ b/net/avahi-qt4/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= -qt4
MAINTAINER= gnome@FreeBSD.org
COMMENT= Qt 4 bindings to the Avahi mDNS system
-LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-common.so:${PORTSDIR}/net/avahi-app
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-qt
@@ -20,5 +20,4 @@ AVAHI_SLAVE= qt4
USE_QT4= corelib moc_build
AVAHI_PKGCONFIG= avahi-qt4.pc
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-sharp/Makefile b/net/avahi-sharp/Makefile
index c60092ac63c4..0b11458cacd3 100644
--- a/net/avahi-sharp/Makefile
+++ b/net/avahi-sharp/Makefile
@@ -8,7 +8,7 @@ PKGNAMESUFFIX= -sharp
MAINTAINER= mono@FreeBSD.org
COMMENT= Mono bindings for Avahi service discovery
-LIB_DEPENDS= avahi-core:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-core.so:${PORTSDIR}/net/avahi-app
BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
@@ -21,7 +21,6 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= sharp
AVAHI_PKGCONFIG=avahi-sharp.pc
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} 's|@CLIENT_DLNAME@|libavahi-client.so|g; \
s|@COMMON_DLNAME@|libavahi-common.so|g; \
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index f0ac082c1917..5349dff917b2 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -11,7 +11,7 @@ DISTFILES= # empty
EXTRACT_ONLY= # empty
MAINTAINER= gnome@FreeBSD.org
-COMMENT= The "meta-port" for the Avahi service discovery suite
+COMMENT= "meta-port" for the Avahi service discovery suite
RUN_DEPENDS= avahi-resolve:${PORTSDIR}/net/avahi-app \
avahi-app>=0.6.31:${PORTSDIR}/net/avahi-app
@@ -23,8 +23,9 @@ GTK_DESC= Gtk+ tools and bindings
LIBDNS_DESC= Apple's mDNSResponder compatibility library
NO_BUILD= yes
+NO_INSTALL= yes
+NO_MTREE= yes
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MAUTOIPD}
@@ -51,6 +52,4 @@ RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-qt4.pc:${PORTSDIR}/net/avahi-
RUN_DEPENDS+= avahi-bookmarks:${PORTSDIR}/net/py-avahi
.endif
-do-install:
-
.include <bsd.port.mk>
diff --git a/net/py-avahi/Makefile b/net/py-avahi/Makefile
index 6961653e0ac7..4c28a4865191 100644
--- a/net/py-avahi/Makefile
+++ b/net/py-avahi/Makefile
@@ -1,7 +1,8 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/net/py-avahi/Makefile,v 1.4 2007/07/31 18:24:13 ahze Exp $
-PORTREVISION= 5
+
+PORTREVISION= 7
CATEGORIES= net gnome python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= # empty
@@ -11,12 +12,10 @@ COMMENT= Python interface to the Avahi mDNS system
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdbm>0:${PORTSDIR}/databases/py-gdbm \
${PYTHON_SITELIBDIR}/dbus/_dbus.py:${PORTSDIR}/devel/py-dbus
-LIB_DEPENDS= avahi-client.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdbm>0:${PORTSDIR}/databases/py-gdbm \
${PYTHON_SITELIBDIR}/dbus/_dbus.py:${PORTSDIR}/devel/py-dbus
-BROKEN= fails to install
-
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-python
INSTALL_WRKSRC= ${BUILD_WRKSRC}
@@ -25,11 +24,10 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= python
-USE_GNOME= gnomehack pygtk2
+USE_GNOME= pygtk2
USE_PYTHON= yes
-MAN1= avahi-bookmarks.1 avahi-discover.1
+MANPAGES= avahi-bookmarks.1 avahi-discover.1
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|@pkglibdir@|${DATADIR}|' \
${WRKSRC}/avahi-python/avahi/ServiceTypeDatabase.py.in
@@ -43,9 +41,11 @@ post-build:
${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET}
post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/service-type-database/service-types.db ${DATADIR}
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHONPREFIX_SITELIBDIR}/avahi
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHONPREFIX_SITELIBDIR}/avahi
+ @cd ${WRKSRC}/service-type-database && ${SETENV} ${MAKE_ENV} ${GMAKE} \
+ ${MAKE_FLAGS} Makefile ${MAKE_ARGS} install
+ (cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PREFIX} -f ${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,})
+ (cd ${STAGEDIR}${PREFIX} && ${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PREFIX} -f ${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,})
.include "${MASTERDIR}/Makefile"
diff --git a/net/py-avahi/pkg-plist b/net/py-avahi/pkg-plist
index 0a905e3acad5..80caca6956ca 100644
--- a/net/py-avahi/pkg-plist
+++ b/net/py-avahi/pkg-plist
@@ -1,5 +1,6 @@
bin/avahi-bookmarks
bin/avahi-discover
+lib/avahi/service-types.db
%%PYTHON_SITELIBDIR%%/avahi/ServiceTypeDatabase.py
%%PYTHON_SITELIBDIR%%/avahi/ServiceTypeDatabase.pyc
%%PYTHON_SITELIBDIR%%/avahi/ServiceTypeDatabase.pyo
@@ -9,8 +10,9 @@ bin/avahi-discover
%%PYTHON_SITELIBDIR%%/avahi_discover/__init__.py
%%PYTHON_SITELIBDIR%%/avahi_discover/__init__.pyc
%%PYTHON_SITELIBDIR%%/avahi_discover/__init__.pyo
+man/man1/avahi-bookmarks.1.gz
+man/man1/avahi-discover.1.gz
share/applications/avahi-discover.desktop
-%%DATADIR%%/service-types.db
-@dirrm %%DATADIR%%
+%%DATADIR%%/service-types
@dirrm %%PYTHON_SITELIBDIR%%/avahi_discover
@dirrm %%PYTHON_SITELIBDIR%%/avahi