aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-05-31 21:22:21 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-05-31 21:22:21 +0000
commit0c44aafe64ad1bcab52d9f46071d8d8dcbd224f2 (patch)
tree1421118bcfb33aaa8100cdac0e4f1e7515afee4d
parent69e4dade2267a1d2447f049d65b9921b59157e61 (diff)
downloadports-0c44aafe64ad1bcab52d9f46071d8d8dcbd224f2.tar.gz
ports-0c44aafe64ad1bcab52d9f46071d8d8dcbd224f2.zip
Notes
-rw-r--r--LEGAL1
-rw-r--r--multimedia/vtkmpeg2encode/Makefile37
-rw-r--r--multimedia/vtkmpeg2encode/pkg-descr2
3 files changed, 17 insertions, 23 deletions
diff --git a/LEGAL b/LEGAL
index ce290105d869..6bf660e12072 100644
--- a/LEGAL
+++ b/LEGAL
@@ -266,7 +266,6 @@ vice-* emulators/vice ROMs are copyrighted by Commodore Business Machines
VMware-vSphere-Perl* net/vmware-vsphere-cli May not be redistributed. Must accept license to download.
vpnc-* security/vpnc Redistribution is not allowed if linked against OpenSSL
vst_sdk2_3.zip audio/ardour Redistribution of the VST PlugIns SDK is not allowed
-vtkmpeg2encode.tar.gz multimedia/vtkmpeg2encode The MPEG2 format and all software that uses it is subject to patent restrictions
vwnc7.3.1/* lang/visualworks Do not redistribute
waeijiro-fpw-* japanese/waeijiro-fpw The original dictionary is not free
webcopy-* www/webcopy This program cannot be distributed if modified in any way. Don't sell for profit without written permission
diff --git a/multimedia/vtkmpeg2encode/Makefile b/multimedia/vtkmpeg2encode/Makefile
index 0a2e56f5a67a..28c1be1bb394 100644
--- a/multimedia/vtkmpeg2encode/Makefile
+++ b/multimedia/vtkmpeg2encode/Makefile
@@ -11,16 +11,16 @@ DISTNAME= vtkmpeg2encode
MAINTAINER= ports@FreeBSD.org
COMMENT= VTK MPEG2 encoding library
-NO_CDROM= the MPEG2 format and all software that uses it is subject to patent restrictions
-NO_PACKAGE= ${NO_CDROM}
+LICENSE= MPEG-2
+LICENSE_NAME= MPEG-2 license
+LICENSE_FILE= ${WRKSRC}/mpeg2enc.h
+LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
USES= cmake
USE_LDCONFIG= yes
CMAKE_ARGS?= -DBUILD_SHARED_LIBS:BOOL=ON
VTK_VERSION= 5.10.1
-MAN3= vtkmpeg2encode.3
-
SUB_FILES= vtkmpeg2encode.3
MPEGLIB= libvtkMPEG2Encode
@@ -34,32 +34,27 @@ PLIST_FILES= lib/${MPEGLIB}.so.${PORTVERSION} \
include/vtk-${VTK_VERSION:R}/mpeg2enc_global.h \
include/vtk-${VTK_VERSION:R}/mpeg2enc.h \
include/vtk-${VTK_VERSION:R}/mpeg2enc_config.h \
- include/vtk-${VTK_VERSION:R}/vlc.h
+ include/vtk-${VTK_VERSION:R}/vlc.h \
+ man/man3/vtkmpeg2encode.3.gz
-NO_STAGE= yes
post-build:
${MV} ${WRKSRC}/${MPEGLIB}.so ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION}
do-install:
- ${MKDIR} ${PREFIX}/include/vtk-${VTK_VERSION:R}
- ${INSTALL_DATA} ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION} ${PREFIX}/lib
- ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
- ${PREFIX}/lib/${MPEGLIB}.so.${VTK_VERSION:R}
- ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
- ${PREFIX}/lib/${MPEGLIB}.so.${VTK_VERSION:R:R}
- ${LN} -s ${PREFIX}/lib/${MPEGLIB}.so.${PORTVERSION} \
- ${PREFIX}/lib/${MPEGLIB}.so
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/vtk-${VTK_VERSION:R}
+ ${INSTALL_DATA} ${WRKSRC}/${MPEGLIB}.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib
+ ${LN} -s ${MPEGLIB}.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/${MPEGLIB}.so.${VTK_VERSION:R}
+ ${LN} -s ${MPEGLIB}.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/${MPEGLIB}.so.${VTK_VERSION:R:R}
+ ${LN} -s ${MPEGLIB}.so.${PORTVERSION} \
+ ${STAGEDIR}${PREFIX}/lib/${MPEGLIB}.so
${INSTALL_DATA} ${WRKSRC}/mpeg2encDllConfig.h \
${WRKSRC}/mpeg2enc_global.h \
${WRKSRC}/mpeg2enc.h \
${WRKSRC}/mpeg2enc_config.h \
${WRKSRC}/vlc.h \
- ${PREFIX}/include/vtk-${VTK_VERSION:R}
- ${INSTALL_MAN} ${WRKDIR}/vtkmpeg2encode.3 ${MANPREFIX}/man/man3
-
-post-install:
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
+ ${STAGEDIR}${PREFIX}/include/vtk-${VTK_VERSION:R}
+ ${INSTALL_MAN} ${WRKDIR}/vtkmpeg2encode.3 ${STAGEDIR}${MANPREFIX}/man/man3
.include <bsd.port.mk>
diff --git a/multimedia/vtkmpeg2encode/pkg-descr b/multimedia/vtkmpeg2encode/pkg-descr
index a6b3b3950410..3a6e938a12c1 100644
--- a/multimedia/vtkmpeg2encode/pkg-descr
+++ b/multimedia/vtkmpeg2encode/pkg-descr
@@ -1,3 +1,3 @@
VTK5 MPEG2 Encoder
-WWW: http://www.vtk.org/get-software.php#addons
+WWW: http://www.vtk.org/get-software.php#addons