aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 11:30:07 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-16 11:30:07 +0000
commit0c660d1e109641e83e33d7d368e2a7375cc20457 (patch)
tree4dc4e58a113da98b02f6692c192b80c30ff32190
parentd8474cbc89e6f324bd4c7c0174271e3e3abab9f7 (diff)
downloadports-0c660d1e109641e83e33d7d368e2a7375cc20457.tar.gz
ports-0c660d1e109641e83e33d7d368e2a7375cc20457.zip
Notes
-rw-r--r--devel/clanlib1/Makefile14
-rw-r--r--devel/clanlib1/files/patch-libc++20
2 files changed, 26 insertions, 8 deletions
diff --git a/devel/clanlib1/Makefile b/devel/clanlib1/Makefile
index 1b111ec5f762..a969160fd849 100644
--- a/devel/clanlib1/Makefile
+++ b/devel/clanlib1/Makefile
@@ -6,6 +6,7 @@ PORTVERSION= 1.0.0
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-1.0/
DISTNAME= ClanLib-${PORTVERSION}
+PKGNAMESUFFIX= 1
EXTRACT_SUFX= .tgz
MAINTAINER= c.petrik.sosa@gmail.com
@@ -14,17 +15,14 @@ COMMENT= Cross-platform game SDK
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- mikmod:${PORTSDIR}/audio/libmikmod \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libmikmod.so:${PORTSDIR}/audio/libmikmod \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
-LATEST_LINK= ${PORTNAME}1
-
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_XORG= x11 xi
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
USE_LDCONFIG= yes
USE_SDL= gfx
USE_GL= yes
diff --git a/devel/clanlib1/files/patch-libc++ b/devel/clanlib1/files/patch-libc++
new file mode 100644
index 000000000000..74bb358a0d60
--- /dev/null
+++ b/devel/clanlib1/files/patch-libc++
@@ -0,0 +1,20 @@
+--- Sources/GL/canvas_opengl.cpp.orig 2007-10-21 02:14:01.000000000 +0200
++++ Sources/GL/canvas_opengl.cpp 2013-09-16 13:21:42.874065134 +0200
+@@ -27,6 +27,7 @@
+ ** (if your name is missing here, please add it)
+ */
+
++#include <stdlib.h>
+ #include "Display/display_precomp.h"
+ #include "canvas_opengl.h"
+ #include "API/Core/System/error.h"
+--- Sources/Network/Socket/ip_address_getaddr.cpp.orig 2007-10-21 02:14:01.000000000 +0200
++++ Sources/Network/Socket/ip_address_getaddr.cpp 2013-09-16 13:22:11.882067224 +0200
+@@ -29,6 +29,7 @@
+
+ #ifdef USE_GETADDR
+
++#include <stdlib.h>
+ #include "ip_address_getaddr.h"
+ #include "API/Core/System/error.h"
+ #include "API/Core/System/mutex.h"