aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-12-18 07:57:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-12-18 07:57:31 +0000
commit142171e3f3b5957e2ffd7b3602e4ea4c4b62ad42 (patch)
tree3b34a790743d501df42bd56a9dd54de3486de358
parentd233d23153a79abe3de1d8486176c4d98ab09947 (diff)
downloadports-142171e3f3b5957e2ffd7b3602e4ea4c4b62ad42.tar.gz
ports-142171e3f3b5957e2ffd7b3602e4ea4c4b62ad42.zip
Notes
-rw-r--r--archivers/bzip/Makefile12
-rw-r--r--archivers/bzip2/Makefile9
-rw-r--r--archivers/deb2targz/Makefile8
-rw-r--r--archivers/deco/Makefile8
-rw-r--r--archivers/gzip/Makefile8
-rw-r--r--archivers/javatar/Makefile2
-rw-r--r--archivers/jzlib/Makefile6
-rw-r--r--archivers/kbackup/Makefile8
-rw-r--r--archivers/laszip/Makefile8
-rw-r--r--archivers/lbzip2/Makefile6
-rw-r--r--archivers/libcabinet/Makefile8
-rw-r--r--archivers/libmspack/Makefile8
-rw-r--r--archivers/libpar2/Makefile6
-rw-r--r--archivers/libzip/Makefile8
-rw-r--r--archivers/makeself/Makefile10
-rw-r--r--archivers/mar/Makefile8
-rw-r--r--archivers/mtf/Makefile13
-rw-r--r--archivers/p5-Archive-Extract-Libarchive/Makefile8
-rw-r--r--archivers/p5-Archive-Extract/Makefile8
-rw-r--r--archivers/paq/Makefile8
-rw-r--r--archivers/pecl-rar/Makefile8
-rw-r--r--archivers/ppmd/Makefile8
-rw-r--r--archivers/ruby-bz2/Makefile10
-rw-r--r--archivers/ruby-lha/Makefile12
-rw-r--r--archivers/ruby-zip/Makefile8
-rw-r--r--archivers/rvm/Makefile9
-rw-r--r--archivers/sectar/Makefile21
-rw-r--r--archivers/snappy/Makefile11
-rw-r--r--archivers/squsq/Makefile8
-rw-r--r--archivers/szip/Makefile8
-rw-r--r--archivers/ucl/Makefile8
-rw-r--r--archivers/xdms/Makefile8
32 files changed, 81 insertions, 198 deletions
diff --git a/archivers/bzip/Makefile b/archivers/bzip/Makefile
index c0a7b525dffe..5f28522cfe0b 100644
--- a/archivers/bzip/Makefile
+++ b/archivers/bzip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bzip
-# Date created: Fr 27 Sep 1996 11:47:35 MET DST
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
-#
PORTNAME= bzip
PORTVERSION= 0.21
@@ -11,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= ftp://ftp.42.org/pub/OLD/b/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A block-sorting file compressor
+COMMENT= Block-sorting file compressor
RESTRICTED= may be covered by patents
MAN1= bzip.1 bunzip.1
@@ -24,8 +20,8 @@ pre-install:
do-install:
${RM} -f ${PREFIX}/bin/bzip ${PREFIX}/bin/bunzip
- ${INSTALL_PROGRAM} ${WRKSRC}/bzip ${PREFIX}/bin/bzip
- ${LN} -fs ${PREFIX}/bin/bzip ${PREFIX}/bin/bunzip
+ ${INSTALL_PROGRAM} ${WRKSRC}/bzip ${PREFIX}/bin
+ ${LN} -fs bzip ${PREFIX}/bin/bunzip
${INSTALL_MAN} ${WRKSRC}/bzip.1 ${MAN1PREFIX}/man/man1/bzip.1
${INSTALL_MAN} ${WRKSRC}/bzip.1 ${MAN1PREFIX}/man/man1/bunzip.1
diff --git a/archivers/bzip2/Makefile b/archivers/bzip2/Makefile
index 924d947de55f..61bbf5f6af84 100644
--- a/archivers/bzip2/Makefile
+++ b/archivers/bzip2/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: bzip2
-# Date created: 19 Nov 1997
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bzip2
PORTVERSION= 1.0.6
@@ -12,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= http://www.bzip.org/${PORTVERSION}/
MAINTAINER= jharris@widomaker.com
-COMMENT= A block-sorting file compressor
+COMMENT= Block-sorting file compressor
USE_LDCONFIG= yes
PATCH_STRIP= -p3
diff --git a/archivers/deb2targz/Makefile b/archivers/deb2targz/Makefile
index eef88c7ae392..da01e163e5d0 100644
--- a/archivers/deb2targz/Makefile
+++ b/archivers/deb2targz/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: deb2targz
-# Date created: 27 Sep 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= deb2targz
PORTVERSION= 20100710
@@ -12,7 +8,7 @@ MASTER_SITES= # none
DISTFILES= # none
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= A command-line utility for converting a Debian .deb file to a .tar.gz
+COMMENT= Command-line utility for converting a Debian .deb file to a .tar.gz
NO_BUILD= yes
diff --git a/archivers/deco/Makefile b/archivers/deco/Makefile
index 7c78038fbc3b..23c83f63463a 100644
--- a/archivers/deco/Makefile
+++ b/archivers/deco/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: deco
-# Date created: 06 May 2008
-# Whom: Kevin Lo <kevlo@FreeBSD.org>
-#
+# Created by: Kevin Lo <kevlo@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= deco
PORTVERSION= 1.6.2
@@ -15,7 +11,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz:site1 \
${PORTNAME}-archive-1.5.1.tar.gz:site2
MAINTAINER= kevlo@FreeBSD.org
-COMMENT= A program to extract various archive file formats
+COMMENT= Program to extract various archive file formats
RUN_DEPENDS= arc:${PORTSDIR}/archivers/arc \
arj:${PORTSDIR}/archivers/arj \
diff --git a/archivers/gzip/Makefile b/archivers/gzip/Makefile
index 0cdeac4b1feb..db7f3ece1375 100644
--- a/archivers/gzip/Makefile
+++ b/archivers/gzip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gzip
-# Date created: 27 July 2002
-# Whom: cyrille.lefevre@laposte.net
-#
+# Created by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
# $FreeBSD$
-#
PORTNAME= gzip
PORTVERSION= 1.4
@@ -13,7 +9,7 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gabor@FreeBSD.org
-COMMENT= A compression utility designed to be a replacement for compress
+COMMENT= Compression utility designed to be a replacement for compress
GNU_CONFIGURE= yes
diff --git a/archivers/javatar/Makefile b/archivers/javatar/Makefile
index 3e50ae7e0c94..8aa5f8ff070b 100644
--- a/archivers/javatar/Makefile
+++ b/archivers/javatar/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.gjt.org/download/time/java/tar/ \
ftp://ftp.gjt.org/pub/time/java/tar/
MAINTAINER= ale@FreeBSD.org
-COMMENT= A Java tar archive io package
+COMMENT= Java tar archive I/O package
RUN_DEPENDS= ${JAVALIBDIR}/activation.jar:${PORTSDIR}/java/jaf
diff --git a/archivers/jzlib/Makefile b/archivers/jzlib/Makefile
index 3d8fd519293b..366291dd3400 100644
--- a/archivers/jzlib/Makefile
+++ b/archivers/jzlib/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= archivers java
MASTER_SITES= http://www.jcraft.com/jzlib/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A re-implementation of zlib in pure Java
+COMMENT= Reimplementation of zlib in pure Java
USE_JAVA= yes
JAVA_VERSION= 1.6+
@@ -57,8 +57,8 @@ do-install:
.endif
# examples
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/example/* ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example/* ${EXAMPLESDIR}
# jar
- @${INSTALL_DATA} ${JAR_FILE} ${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_DATA} ${JAR_FILE} ${JAVAJARDIR}/${PORTNAME}.jar
.include <bsd.port.mk>
diff --git a/archivers/kbackup/Makefile b/archivers/kbackup/Makefile
index 1b6e09d4e8f1..10952b92b12f 100644
--- a/archivers/kbackup/Makefile
+++ b/archivers/kbackup/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kbackup
-# Date created: 2006-09-29
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
-#
+# Created by: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= kbackup
PORTVERSION= 0.5.4
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
DISTNAME= 44998-${PORTNAME}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
-COMMENT= A program for back up of directories or files
+COMMENT= Program for backing up files and directories
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/archivers/laszip/Makefile b/archivers/laszip/Makefile
index 766e80f60b7b..a79d37acda70 100644
--- a/archivers/laszip/Makefile
+++ b/archivers/laszip/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: laszip
-# Date created: 09 January 2012
-# Whom: Rainer Hurling <rhurlin@gwdg.de>
+# Created by: Rainer Hurling <rhurlin@gwdg.de>
# $FreeBSD$
PORTNAME= laszip
@@ -9,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= http://download.osgeo.org/laszip/
MAINTAINER= rhurlin@gwdg.de
-COMMENT= A library for lossless LAS compression
+COMMENT= Library for lossless LAS compression
LICENSE= LGPL3
@@ -20,6 +18,6 @@ USE_LDCONFIG= yes
CMAKE_DEFS+= -DCMAKE_USE_PTHREADS:BOOL=ON
post-install:
- @${LN} -s ${PREFIX}/lib/liblaszip.so.5.0.0 ${PREFIX}/lib/liblaszip.so.5
+ @${LN} -s liblaszip.so.5.0.0 ${PREFIX}/lib/liblaszip.so.5
.include <bsd.port.mk>
diff --git a/archivers/lbzip2/Makefile b/archivers/lbzip2/Makefile
index 93a006429963..f326062f22a4 100644
--- a/archivers/lbzip2/Makefile
+++ b/archivers/lbzip2/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: archivers/lbzip2
-# Date created: 7 Feb 2009
-# Whom: Gabor Kovesdan <gabor@FreeBSD.org>
+# Created by: Gabor Kovesdan <gabor@FreeBSD.org>
# $FreeBSD$
PORTNAME= lbzip2
@@ -9,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= http://lacos.web.elte.hu/pub/lbzip2/
MAINTAINER= gabor@FreeBSD.org
-COMMENT= A multi-threaded bzip2/bunzip2 filter
+COMMENT= Multi-threaded bzip2/bunzip2 filter
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= bin/lbzip2
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index 22981c5f6a46..f2b30eec0a76 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libcabinet
-# Date Created: 30 November 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libcabinet
PORTVERSION= 0.30
@@ -11,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
MAINTAINER= tj@FreeBSD.org
-COMMENT= A portable library and utility to use Microsoft cabinet files (.cab)
+COMMENT= Portable library and utility to use Microsoft cabinet files (.cab)
USE_LDCONFIG= yes
diff --git a/archivers/libmspack/Makefile b/archivers/libmspack/Makefile
index 55402286776c..9ee80e2db1a3 100644
--- a/archivers/libmspack/Makefile
+++ b/archivers/libmspack/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libmspack
-# Date created: 25 Nov 2004
-# Whom: Max Khon <fjoe@FreeBSD.org>
-#
+# Created by: Max Khon <fjoe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libmspack
PORTVERSION= 0.3
@@ -12,7 +8,7 @@ MASTER_SITES= http://www.cabextract.org.uk/libmspack/
DISTNAME= ${PORTNAME}-${PORTVERSION}alpha
MAINTAINER= fjoe@FreeBSD.org
-COMMENT= A library for Microsoft compression formats
+COMMENT= Library for Microsoft compression formats
LICENSE= LGPL21
diff --git a/archivers/libpar2/Makefile b/archivers/libpar2/Makefile
index 497d6347796c..ac8014f10216 100644
--- a/archivers/libpar2/Makefile
+++ b/archivers/libpar2/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= archivers
MASTER_SITES= SF/parchive/${PORTNAME}/${PORTVERSION}
MAINTAINER= toxic@doobie.com
-COMMENT= A library for manipulating par2 files, extracted from par2cmdline
+COMMENT= Library for manipulating PAR2 files, extracted from par2cmdline
LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20
@@ -26,13 +26,13 @@ ENABLECANCEL_DESC= Enable graceful cancellation of repairs
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MENABLECANCEL}
-EXTRA_PATCHES+= ${FILESDIR}/xpatch-addcancel-par2repairer.cpp
+EXTRA_PATCHES= ${FILESDIR}/xpatch-addcancel-par2repairer.cpp
.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/archivers/libzip/Makefile b/archivers/libzip/Makefile
index 2ec37d28251c..596e18a3dea3 100644
--- a/archivers/libzip/Makefile
+++ b/archivers/libzip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libzip
-# Date created: 2006-03-20
-# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
-#
+# Created by: Alexander Zhuravlev <zaa@zaa.pp.ru>
# $FreeBSD$
-#
PORTNAME= libzip
PORTVERSION= 0.10.1
@@ -11,7 +7,7 @@ CATEGORIES= archivers devel
MASTER_SITES= http://www.nih.at/libzip/
MAINTAINER= makc@FreeBSD.org
-COMMENT= A C library for reading, creating, and modifying zip archives
+COMMENT= C library for reading, creating, and modifying ZIP archives
USE_BZIP2= yes
GNU_CONFIGURE= yes
diff --git a/archivers/makeself/Makefile b/archivers/makeself/Makefile
index 5dad45b3fbe0..c81cff7a7aa2 100644
--- a/archivers/makeself/Makefile
+++ b/archivers/makeself/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: makeself
-# Date created: 22 Oct 1999
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= makeself
PORTVERSION= 2.1.5
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.megastep.org/makeself/
EXTRACT_SUFX= .run
MAINTAINER= jadawin@FreeBSD.org
-COMMENT= A neat script to make self-extracting archives
+COMMENT= Neat script to make self-extracting archives
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
@@ -26,9 +22,7 @@ NO_BUILD= yes
PLIST_FILES= bin/makeself bin/makeself-header \
bin/makeself-header.sh bin/makeself.sh
-.if !defined(NOPORTDOCS)
PORTDOCS= README
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/archivers/mar/Makefile b/archivers/mar/Makefile
index 7180bb89038c..0573e20864cc 100644
--- a/archivers/mar/Makefile
+++ b/archivers/mar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mar
-# Date created: 20 Jun 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= mar
DISTVERSION= 0.5
@@ -12,7 +8,7 @@ MASTER_SITES= CRITICAL
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= A simple binary file format for storing arbitrary meta and user data
+COMMENT= Simple binary file format for storing arbitrary meta and user data
LICENSE= MIT
diff --git a/archivers/mtf/Makefile b/archivers/mtf/Makefile
index 75dc8f8eae73..7ad1bf09e5f3 100644
--- a/archivers/mtf/Makefile
+++ b/archivers/mtf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mtf
-# Date created: 29 January 2002
-# Whom: Philippe Casidy <pcasidy@casidy.com>
-#
+# Created by: Philippe Casidy <pcasidy@casidy.com>
# $FreeBSD$
-#
PORTNAME= mtf
PORTVERSION= 0.2.1
@@ -14,7 +10,7 @@ MASTER_SITE_SUBDIR= system/backup
EXTRACT_SUFX= .tgz
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= A Unix reader for the Microsoft Tape Format used by NT Backup
+COMMENT= Unix reader for the Microsoft Tape Format used by NT Backup
LICENSE= GPLv2
@@ -23,9 +19,8 @@ PLIST_FILES= bin/mtf
PORTDOCS= README
post-patch:
- @${REINPLACE_CMD} -e "s|CC=|CC?=|" \
- -e "s|CFLAGS=|CFLAGS?=|" \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|CC=|CC?=|" -e "s|CFLAGS=|CFLAGS?=|" \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mtf ${PREFIX}/bin
diff --git a/archivers/p5-Archive-Extract-Libarchive/Makefile b/archivers/p5-Archive-Extract-Libarchive/Makefile
index 3634043c4e9d..fcbf12e63a58 100644
--- a/archivers/p5-Archive-Extract-Libarchive/Makefile
+++ b/archivers/p5-Archive-Extract-Libarchive/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Archive-Extract-Libarchive
-# Date created: 2011-10-23
-# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-#
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Archive-Extract-Libarchive
PORTVERSION= 0.38
@@ -12,7 +8,7 @@ MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
-COMMENT= A generic archive extracting mechanism (using libarchive)
+COMMENT= Generic archive extracting mechanism (using libarchive)
BUILD_DEPENDS= p5-Object-Tiny>=0:${PORTSDIR}/devel/p5-Object-Tiny
RUN_DEPENDS= p5-Object-Tiny>=0:${PORTSDIR}/devel/p5-Object-Tiny
diff --git a/archivers/p5-Archive-Extract/Makefile b/archivers/p5-Archive-Extract/Makefile
index ab95dd95b512..e9a782780e43 100644
--- a/archivers/p5-Archive-Extract/Makefile
+++ b/archivers/p5-Archive-Extract/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Archive-Extract
-# Date created: 28 May 2006
-# Whom: Aaron Dalton <aaron@FreeBSD.org>
-#
+# Created by: Aaron Dalton <aaron@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Archive-Extract
PORTVERSION= 0.60
@@ -12,7 +8,7 @@ MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
-COMMENT= A generic archive extracting mechanism
+COMMENT= Generic archive extracting mechanism
MAKE_JOBS_SAFE= yes
PERL_CONFIGURE= yes
diff --git a/archivers/paq/Makefile b/archivers/paq/Makefile
index 1d1b09623354..0f0e0d38f48d 100644
--- a/archivers/paq/Makefile
+++ b/archivers/paq/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: paq
-# Date created: 5 April 2007
-# Whom: bf <bf2006a@yahoo.com>
-#
+# Created by: bf <bf2006a@yahoo.com>
# $FreeBSD$
-#
PORTNAME= paq
PORTVERSION= 20121105
@@ -14,7 +10,7 @@ DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTFILES:M*.zip}
MAINTAINER= bf@FreeBSD.org
-COMMENT= A family of archivers with extremely high compression ratios
+COMMENT= Family of archivers with extremely high compression ratios
LICENSE= GPLv3 MIT
LICENSE_COMB= multi
diff --git a/archivers/pecl-rar/Makefile b/archivers/pecl-rar/Makefile
index b145959df90e..ec362029c0f6 100644
--- a/archivers/pecl-rar/Makefile
+++ b/archivers/pecl-rar/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pecl-rar
-# Date created: 2006/09/07
-# Whom: chinsan <chinsan.tw@gmail.com>
-#
+# Created by: Chin-San Huang <chinsan.tw@gmail.com>
# $FreeBSD$
-#
PORTNAME= rar
PORTVERSION= 3.0.0
@@ -14,7 +10,7 @@ EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
-COMMENT= A PECL extension to create and read rar files
+COMMENT= PECL extension to create and read RAR files
LICENSE= PHP301
diff --git a/archivers/ppmd/Makefile b/archivers/ppmd/Makefile
index 3d0b8b3992dc..d3f7cee386ef 100644
--- a/archivers/ppmd/Makefile
+++ b/archivers/ppmd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ppmd
-# Date created: 11 Aug 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= ppmd
PORTVERSION= 20050811
@@ -11,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= A fast archiver with a good compression ratio
+COMMENT= Fast archiver with good compression ratio
MAKE_JOBS_SAFE= yes
diff --git a/archivers/ruby-bz2/Makefile b/archivers/ruby-bz2/Makefile
index 2820bfd5457c..96bc23fa066e 100644
--- a/archivers/ruby-bz2/Makefile
+++ b/archivers/ruby-bz2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Ruby-BZ2
-# Date created: 16 November 2002
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= bz2
PORTVERSION= 0.2.2
@@ -14,7 +10,7 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby extension to use libbz2
+COMMENT= Ruby extension to use libbz2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -24,7 +20,7 @@ INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>
.if ${RUBY_VER} == 1.9
-BROKEN= does not build with ruby 1.9
+BROKEN= does not build with ruby ${RUBY_VER}
.endif
.include <bsd.port.post.mk>
diff --git a/archivers/ruby-lha/Makefile b/archivers/ruby-lha/Makefile
index fde041bd9dba..3e7004972280 100644
--- a/archivers/ruby-lha/Makefile
+++ b/archivers/ruby-lha/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ruby-lha
-# Date created: 09 January 2006
-# Whom: stas
-#
+# Created by: Stanislav Sedov <stas@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= lha
PORTVERSION= 0.8.1
@@ -15,7 +11,7 @@ DISTNAME= lhalib-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby extension to unpack lha-compressed files
+COMMENT= Ruby extension to unpack LHA-compressed files
USE_ZIP= yes
USE_RUBY= yes
@@ -29,8 +25,8 @@ RUBY_SHEBANG_FILES= ${EXAMPLES}
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}/
- @${INSTALL_SCRIPT} ${EXAMPLES:S,^,${WRKSRC}/,} ${RUBY_MODEXAMPLESDIR}/
+ @${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${EXAMPLES:S,^,${WRKSRC}/,} ${RUBY_MODEXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/archivers/ruby-zip/Makefile b/archivers/ruby-zip/Makefile
index cd3ebe9887a6..9dac7f2a976f 100644
--- a/archivers/ruby-zip/Makefile
+++ b/archivers/ruby-zip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rubyzip
-# Date created: 26 January 2002
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= zip
PORTVERSION= 0.9.4
@@ -15,7 +11,7 @@ EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby module for reading and writing zip files
+COMMENT= Ruby module for reading and writing ZIP files
MAKE_JOBS_SAFE= yes
diff --git a/archivers/rvm/Makefile b/archivers/rvm/Makefile
index fa395b523b66..298fa8c2209a 100644
--- a/archivers/rvm/Makefile
+++ b/archivers/rvm/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: rvm
-# Date created: Mar 15, 2004
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= rvm
PORTVERSION= 1.07
@@ -13,7 +8,7 @@ MASTER_SITES= SF
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= davide.italiano@gmail.com
-COMMENT= An archive manager that uses rsync to manage backups
+COMMENT= Archive manager that uses rsync to manage backups
BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/archivers/sectar/Makefile b/archivers/sectar/Makefile
index f9def78315ce..c141ede9841a 100644
--- a/archivers/sectar/Makefile
+++ b/archivers/sectar/Makefile
@@ -1,19 +1,16 @@
-# New ports collection makefile for: sectar
-# Date created: 22 January 2001
-# Whom: George Reid <greid@ukug.uk.freebsd.org>
-#
+# Created by: George Reid <greid@ukug.uk.freebsd.org>
# $FreeBSD$
-#
-PORTNAME= sectar
-PORTVERSION= 1.02
-CATEGORIES= archivers
-MASTER_SITES= SF/star/${PORTNAME}/${PORTVERSION}
+PORTNAME= sectar
+PORTVERSION= 1.02
+CATEGORIES= archivers
+MASTER_SITES= SF/star/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A program to create encrypted tar archives
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Program to create encrypted tar archives
+
+GNU_CONFIGURE= yes
PLIST_FILES= bin/sectar
-GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/archivers/snappy/Makefile b/archivers/snappy/Makefile
index a3fbc592fe9f..44598724c10e 100644
--- a/archivers/snappy/Makefile
+++ b/archivers/snappy/Makefile
@@ -1,19 +1,14 @@
-# ex:ts=8
-# Ports collection makefile for: snappy
-# Date created: Apr 3 2011
-# Whom: vanilla@
-#
+# Created by: Vanilla I. Shu <vanilla@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= snappy
PORTVERSION= 1.0.5
PORTREVISION= 0
CATEGORIES= archivers
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= vanilla@FreeBSD.org
-COMMENT= A fast compressor/decompressor library
+COMMENT= Fast compressor/decompressor library
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/archivers/squsq/Makefile b/archivers/squsq/Makefile
index 1c2eae995411..20bb9d5ecdcd 100644
--- a/archivers/squsq/Makefile
+++ b/archivers/squsq/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: squsq
-# Date created: 09 May 2003
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME= squsq
PORTVERSION= 3.3
@@ -21,6 +17,6 @@ MAKEFILE= ${FILESDIR}/Makefile
PLIST_FILES= bin/sq bin/usq
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sq ${WRKSRC}/usq ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/sq ${WRKSRC}/usq ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/archivers/szip/Makefile b/archivers/szip/Makefile
index e1bfeeee409f..4069b784e6bc 100644
--- a/archivers/szip/Makefile
+++ b/archivers/szip/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: szip
-# Date created: 15 January 2002
-# Whom: Igor Pokrovsky <tiamat@telegraph.spb.ru>
-#
+# Created by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
# $FreeBSD$
-#
PORTNAME= szip
PORTVERSION= 1.12b
@@ -14,7 +10,7 @@ MASTER_SITES= http://www.compressconsult.com/szip/ \
DISTNAME= sz${PORTVERSION:S/.//}_src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A fast compression utility
+COMMENT= Fast compression utility
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/archivers/ucl/Makefile b/archivers/ucl/Makefile
index 8cf44ee54d3c..a04a2c2a4cae 100644
--- a/archivers/ucl/Makefile
+++ b/archivers/ucl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ucl
-# Date created: 29 January 2001
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ucl
PORTVERSION= 1.03
@@ -12,7 +8,7 @@ CATEGORIES= archivers devel
MASTER_SITES= http://www.oberhumer.com/opensource/ucl/download/
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= A data compression library with low memory usage
+COMMENT= Data compression library with low memory usage
LICENSE= GPLv2
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 9ace7cc274fb..214813ed946e 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xdms
-# Date created: Apr 13, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-#
PORTNAME= xdms
PORTVERSION= 1.3.2
@@ -11,7 +7,7 @@ CATEGORIES= archivers
MASTER_SITES= http://zakalwe.fi/~shd/foss/xdms/
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= An Amiga DMS archiver unpacker
+COMMENT= Tool for decompressing Amiga DMS files
USE_BZIP2= yes
HAS_CONFIGURE= yes