aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-27 19:10:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-27 19:10:59 +0000
commit1ae61fce0e9c1b42ea00b8d8333f3436f2013d1a (patch)
tree7345c56c1ff0ca8d55a6d7d13dc05b61c0bb6e3e
parent7fa21a62f0b561677d55927294ce11faa0c4dde3 (diff)
- Fix message displayed when the port being installed is already installed
Approved by: portmgr (bdrewery via irc)
Notes
Notes: svn path=/head/; revision=328508
-rw-r--r--Mk/bsd.pkgng.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 78987af53ebf..f72079aada76 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -263,8 +263,8 @@ check-already-installed:
pkgname=`${PKG_INFO} -q -O ${PKGORIGIN}`; \
if [ -n "$${pkgname}" ]; then \
v=`${PKG_VERSION} -t $${pkgname} ${PKGNAME}`; \
- if [ "w$${v}" = "x<" ]; then \
- ${ECHO_CMD} "===> An older version of ${PKGORIGIN} is already installed ($${found_package})"; \
+ if [ "$${v}" = "<" ]; then \
+ ${ECHO_CMD} "===> An older version of ${PKGORIGIN} is already installed ($${pkgname})"; \
else \
${ECHO_CMD} "===> ${PKGNAME} is already installed"; \
fi; \