aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2013-12-11 04:14:50 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2013-12-11 04:14:50 +0000
commit1f706e03ccd899ad91dd165c1af616994bae792f (patch)
tree74c88b71f29a975e14256b3aecd5446a5f7f6120
parentdc8b80257457a1f15df06537cf674e754855dd02 (diff)
downloadports-1f706e03ccd899ad91dd165c1af616994bae792f.tar.gz
ports-1f706e03ccd899ad91dd165c1af616994bae792f.zip
Notes
-rw-r--r--misc/Makefile1
-rw-r--r--misc/sword17/Makefile75
-rw-r--r--misc/sword17/distinfo2
-rw-r--r--misc/sword17/files/pkg-message.in16
-rw-r--r--misc/sword17/pkg-descr9
-rw-r--r--misc/sword17/pkg-plist283
6 files changed, 386 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 8a8ecf21d0df..1c3f5261233b 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -423,6 +423,7 @@
SUBDIR += susv2
SUBDIR += susv3
SUBDIR += sword
+ SUBDIR += sword17
SUBDIR += table.el
SUBDIR += talkfilters
SUBDIR += tcb
diff --git a/misc/sword17/Makefile b/misc/sword17/Makefile
new file mode 100644
index 000000000000..29abe40300e9
--- /dev/null
+++ b/misc/sword17/Makefile
@@ -0,0 +1,75 @@
+# Created by: Willem van Engen <wvengen@stack.nl>
+# $FreeBSD$
+
+PORTNAME= sword
+PORTVERSION= 1.7.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.crosswire.org/pub/sword/source/v${PORTVERSION:R}/ \
+ http://crosswire.org/ftpmirror/pub/sword/source/v${PORTVERSION:R}/
+
+MAINTAINER= tabthorpe@FreeBSD.org
+COMMENT= Framework for manipulating Bible texts
+
+LICENSE= GPLv2
+
+CONFLICTS= sword-1.6.*
+
+BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
+
+USES= gmake pkgconfig
+USE_AUTOTOOLS= automake autoconf
+CONFIGURE_ARGS= --with-conf --with-zlib
+USE_LDCONFIG= yes
+SUB_FILES= pkg-message
+
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+OPTIONS_DEFINE= CURL CLUCENE
+CLUCENE_DESC= Include indexing capability
+OPTIONS_DEFAULT=CURL CLUCENE
+
+NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCURL}
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl
+.else
+CONFIGURE_ARGS+= --without-curl
+.endif
+
+.if ${PORT_OPTIONS:MCLUCENE}
+LIB_DEPENDS+= libclucene-core.so:${PORTSDIR}/textproc/clucene \
+ libicudata.so:${PORTSDIR}/devel/icu
+CONFIGURE_ARGS+= --with-clucene=${LOCALBASE} --with-icu
+PLIST_SUB+= ICU="" ICUVER="`${LOCALBASE}/bin/icu-config --version`"
+.else
+CONFIGURE_ARGS+= --without-clucene --without-icu
+PLIST_SUB+= ICU="@comment "
+.endif
+
+run-autotools:: run-autotools-aclocal
+
+ @${REINPLACE_CMD} -e 's|-O3||' ${WRKSRC}/configure
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ -e's|-O3||g' \
+ ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
+
+post-install:
+ @${MKDIR} ${PREFIX}/share/sword/mods.d
+.if !exists(${PREFIX}/etc/sword.conf)
+ @(cd ${WRKSRC} && ${GMAKE} install_config)
+.else
+ @${ECHO_CMD} "Config file not installed since ${PREFIX}/etc/sword.conf already exists."
+ @${ECHO_CMD} "Please check that DataPath points to your modules (default ${DATADIR}).";
+.endif
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+register:
+ ${MAKE_CMD} register -C ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/misc/sword17/distinfo b/misc/sword17/distinfo
new file mode 100644
index 000000000000..22f9d6699f30
--- /dev/null
+++ b/misc/sword17/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sword-1.7.0.tar.gz) = 819bb4178e871ac2cbcf2a7765f94314c0051b79f522d02c24f8d9ddddac3501
+SIZE (sword-1.7.0.tar.gz) = 2115304
diff --git a/misc/sword17/files/pkg-message.in b/misc/sword17/files/pkg-message.in
new file mode 100644
index 000000000000..3023b1dfda7c
--- /dev/null
+++ b/misc/sword17/files/pkg-message.in
@@ -0,0 +1,16 @@
+To use sword, you need to have bible, commentary and/or lexicon
+modules. You can install those from the crosswire website in two
+ways. If you live in a persecuted country however and do not wish
+to risk detection, you should *not* try this.
+
+ 1. Use installmgr (doesn't work when port is built WITHOUT_CURL). E.g.:
+ # installmgr -init
+ # installmgr -r crosswire
+ # installmgr -ri crosswire ASV
+ See `installmgr --help` for details.
+ 2. Download raw zip-archives from
+ http://www.crosswire.org/sword/modules/
+ and unpack them in %%PREFIX%%/share/sword.
+
+You probably want to install a bible-application that uses sword,
+like bibletime or xiphos.
diff --git a/misc/sword17/pkg-descr b/misc/sword17/pkg-descr
new file mode 100644
index 000000000000..0bd334f20a22
--- /dev/null
+++ b/misc/sword17/pkg-descr
@@ -0,0 +1,9 @@
+The SWORD Project is the CrossWire Bible Society's free Bible
+software project. Its purpose is to create cross-platform open-source
+tools, covered by the GNU General Public License, that allow
+programmers and Bible societies to write new Bible software more
+quickly and easily. We also create Bible study software for all
+readers, students, scholars, and translators of the Bible, and have
+a growing collection of over 200 texts in over 50 languages.
+
+WWW: http://www.crosswire.org/sword/
diff --git a/misc/sword17/pkg-plist b/misc/sword17/pkg-plist
new file mode 100644
index 000000000000..81b026b7ea54
--- /dev/null
+++ b/misc/sword17/pkg-plist
@@ -0,0 +1,283 @@
+bin/diatheke
+bin/mod2imp
+bin/mod2osis
+bin/osis2mod
+bin/tei2mod
+bin/vs2osisref
+bin/vs2osisreftxt
+bin/mod2vpl
+bin/mkfastmod
+bin/vpl2mod
+bin/imp2vs
+bin/installmgr
+bin/xml2gbs
+bin/imp2gbs
+bin/imp2ld
+bin/mod2zmod
+%%ETCDIR%%.conf
+include/sword/canon.h
+include/sword/canon_abbrevs.h
+include/sword/cipherfil.h
+include/sword/curlftpt.h
+include/sword/curlhttpt.h
+include/sword/defs.h
+include/sword/echomod.h
+include/sword/encfiltmgr.h
+include/sword/entriesblk.h
+include/sword/femain.h
+include/sword/filemgr.h
+include/sword/versificationmgr.h
+include/sword/flatapi.h
+include/sword/ftpparse.h
+include/sword/remotetrans.h
+include/sword/ftplibftpt.h
+include/sword/ftplib.h
+include/sword/gbffootnotes.h
+include/sword/gbfheadings.h
+include/sword/gbfhtml.h
+include/sword/gbfxhtml.h
+include/sword/gbfhtmlhref.h
+include/sword/rawld.h
+include/sword/gbfwebif.h
+include/sword/gbfmorph.h
+include/sword/gbfosis.h
+include/sword/gbfplain.h
+include/sword/gbfredletterwords.h
+include/sword/gbfrtf.h
+include/sword/gbfstrongs.h
+include/sword/gbfwordjs.h
+include/sword/gbfthml.h
+include/sword/greeklexattribs.h
+include/sword/hebrewmcim.h
+include/sword/hrefcom.h
+include/sword/installmgr.h
+include/sword/latin1utf16.h
+include/sword/latin1utf8.h
+include/sword/listkey.h
+include/sword/localemgr.h
+include/sword/lzsscomprs.h
+include/sword/markupfiltmgr.h
+include/sword/multimapwdef.h
+include/sword/nullim.h
+include/sword/osisglosses.h
+include/sword/osisenum.h
+include/sword/osisheadings.h
+include/sword/osishtmlhref.h
+include/sword/osisxhtml.h
+include/sword/osiswebif.h
+include/sword/osismorph.h
+include/sword/osismorphsegmentation.h
+include/sword/osisplain.h
+include/sword/osisrtf.h
+include/sword/osisosis.h
+include/sword/osisstrongs.h
+include/sword/osisfootnotes.h
+include/sword/osislemma.h
+include/sword/osisredletterwords.h
+include/sword/osisscripref.h
+include/sword/osiswordjs.h
+include/sword/osisvariants.h
+include/sword/osisxlit.h
+include/sword/papyriplain.h
+include/sword/rawcom.h
+include/sword/rawcom4.h
+include/sword/rawfiles.h
+include/sword/rawgenbook.h
+include/sword/rawld4.h
+include/sword/rawstr.h
+include/sword/rawstr4.h
+include/sword/rawtext.h
+include/sword/rawtext4.h
+include/sword/rawverse.h
+include/sword/rawverse4.h
+include/sword/roman.h
+include/sword/rtfhtml.h
+include/sword/sapphire.h
+include/sword/scsuutf8.h
+include/sword/strkey.h
+include/sword/swbasicfilter.h
+include/sword/swbuf.h
+include/sword/swcacher.h
+include/sword/swcipher.h
+include/sword/swcom.h
+include/sword/swcomprs.h
+include/sword/swconfig.h
+include/sword/swdisp.h
+include/sword/swfilter.h
+include/sword/swfiltermgr.h
+include/sword/swgenbook.h
+include/sword/swinputmeth.h
+include/sword/swkey.h
+include/sword/swld.h
+include/sword/swlocale.h
+include/sword/swlog.h
+include/sword/swmacs.h
+include/sword/swmgr.h
+include/sword/stringmgr.h
+include/sword/swmodule.h
+include/sword/swoptfilter.h
+include/sword/swobject.h
+include/sword/swsearchable.h
+include/sword/swtext.h
+include/sword/swunicod.h
+include/sword/swversion.h
+include/sword/sysdata.h
+include/sword/thmlfootnotes.h
+include/sword/thmlgbf.h
+include/sword/thmlheadings.h
+include/sword/thmlhtml.h
+include/sword/thmlxhtml.h
+include/sword/thmlhtmlhref.h
+include/sword/thmlwebif.h
+include/sword/thmllemma.h
+include/sword/thmlmorph.h
+include/sword/thmlosis.h
+include/sword/thmlplain.h
+include/sword/thmlrtf.h
+include/sword/thmlscripref.h
+include/sword/thmlstrongs.h
+include/sword/thmlvariants.h
+include/sword/thmlwordjs.h
+include/sword/teiplain.h
+include/sword/teirtf.h
+include/sword/teixhtml.h
+include/sword/teihtmlhref.h
+include/sword/treekey.h
+include/sword/treekeyidx.h
+include/sword/unicodertf.h
+include/sword/url.h
+include/sword/untgz.h
+include/sword/utf16utf8.h
+include/sword/utf8arshaping.h
+include/sword/utf8bidireorder.h
+include/sword/utf8cantillation.h
+include/sword/utf8greekaccents.h
+include/sword/utf8hebrewpoints.h
+include/sword/utf8arabicpoints.h
+include/sword/utf8html.h
+include/sword/utf8latin1.h
+include/sword/utf8nfc.h
+include/sword/utf8nfkd.h
+include/sword/utf8transliterator.h
+include/sword/utf8utf16.h
+include/sword/utilstr.h
+include/sword/utilxml.h
+include/sword/versekey.h
+include/sword/versetreekey.h
+include/sword/zcom.h
+include/sword/zipcomprs.h
+include/sword/zld.h
+include/sword/zstr.h
+include/sword/ztext.h
+include/sword/zverse.h
+include/sword/canon_kjva.h
+include/sword/canon_leningrad.h
+include/sword/canon_mt.h
+include/sword/canon_nrsv.h
+include/sword/canon_nrsva.h
+include/sword/canon_synodal.h
+include/sword/canon_synodalprot.h
+include/sword/canon_vulg.h
+include/sword/canon_german.h
+include/sword/canon_luther.h
+include/sword/canon_catholic.h
+include/sword/canon_catholic2.h
+include/sword/canon_lxx.h
+include/sword/canon_null.h
+include/sword/canon_orthodox.h
+lib/libsword-%%PORTVERSION%%.so
+lib/libsword.a
+lib/libsword.la
+lib/libsword.so
+libdata/pkgconfig/sword.pc
+%%DATADIR%%/locales.d/abbr.conf
+%%DATADIR%%/locales.d/af-utf8.conf
+%%DATADIR%%/locales.d/af.conf
+%%DATADIR%%/locales.d/ar_EG-cp1256.conf
+%%DATADIR%%/locales.d/ar_EG-utf8.conf
+%%DATADIR%%/locales.d/az-utf8.conf
+%%DATADIR%%/locales.d/bg_BG-cp1251.conf
+%%DATADIR%%/locales.d/bg_BG-utf8.conf
+%%DATADIR%%/locales.d/cs-utf8.conf
+%%DATADIR%%/locales.d/cs.conf
+%%DATADIR%%/locales.d/cy-utf8.conf
+%%DATADIR%%/locales.d/cy.conf
+%%DATADIR%%/locales.d/da-utf8.conf
+%%DATADIR%%/locales.d/da.conf
+%%DATADIR%%/locales.d/de-utf8.conf
+%%DATADIR%%/locales.d/de.conf
+%%DATADIR%%/locales.d/de_abbrev-utf8.conf
+%%DATADIR%%/locales.d/de_abbrev.conf
+%%DATADIR%%/locales.d/es-utf8.conf
+%%DATADIR%%/locales.d/es.conf
+%%DATADIR%%/locales.d/et-utf8.conf
+%%DATADIR%%/locales.d/et.conf
+%%DATADIR%%/locales.d/et_abbr-utf8.conf
+%%DATADIR%%/locales.d/et_abbr.conf
+%%DATADIR%%/locales.d/fa-utf8.conf
+%%DATADIR%%/locales.d/fi-utf8.conf
+%%DATADIR%%/locales.d/fi.conf
+%%DATADIR%%/locales.d/fo-utf8.conf
+%%DATADIR%%/locales.d/fr-utf8.conf
+%%DATADIR%%/locales.d/fr.conf
+%%DATADIR%%/locales.d/fr_abbrev-utf8.conf
+%%DATADIR%%/locales.d/fr_abbrev.conf
+%%DATADIR%%/locales.d/ga-utf8.conf
+%%DATADIR%%/locales.d/he-utf8.conf
+%%DATADIR%%/locales.d/hr-utf8.conf
+%%DATADIR%%/locales.d/hu-utf8.conf
+%%DATADIR%%/locales.d/hu.conf
+%%DATADIR%%/locales.d/id-utf8.conf
+%%DATADIR%%/locales.d/id.conf
+%%DATADIR%%/locales.d/it-utf8.conf
+%%DATADIR%%/locales.d/it.conf
+%%DATADIR%%/locales.d/iu-utf8.conf
+%%DATADIR%%/locales.d/ja-utf8.conf
+%%DATADIR%%/locales.d/ko-utf8.conf
+%%DATADIR%%/locales.d/ko.conf
+%%DATADIR%%/locales.d/ko_abbrev-utf8.conf
+%%DATADIR%%/locales.d/ko_abbrev.conf
+%%DATADIR%%/locales.d/la-utf8.conf
+%%DATADIR%%/locales.d/la.conf
+%%DATADIR%%/locales.d/locales.conf
+%%DATADIR%%/locales.d/lt-utf8.conf
+%%DATADIR%%/locales.d/mt-utf8.conf
+%%DATADIR%%/locales.d/nb-utf8.conf
+%%DATADIR%%/locales.d/nb.conf
+%%DATADIR%%/locales.d/nl-utf8.conf
+%%DATADIR%%/locales.d/nl.conf
+%%DATADIR%%/locales.d/no-utf8.conf
+%%DATADIR%%/locales.d/no.conf
+%%DATADIR%%/locales.d/pl-utf8.conf
+%%DATADIR%%/locales.d/pl.conf
+%%DATADIR%%/locales.d/pon_utf8.conf
+%%DATADIR%%/locales.d/pt-utf8.conf
+%%DATADIR%%/locales.d/pt.conf
+%%DATADIR%%/locales.d/pt_BR-utf8.conf
+%%DATADIR%%/locales.d/pt_BR.conf
+%%DATADIR%%/locales.d/ro-utf8.conf
+%%DATADIR%%/locales.d/ro.conf
+%%DATADIR%%/locales.d/ru_RU-cp1251.conf
+%%DATADIR%%/locales.d/ru_RU-koi8-r.conf
+%%DATADIR%%/locales.d/ru_RU-utf8.conf
+%%DATADIR%%/locales.d/sk-utf8.conf
+%%DATADIR%%/locales.d/sk.conf
+%%DATADIR%%/locales.d/sl-utf8.conf
+%%DATADIR%%/locales.d/sl.conf
+%%DATADIR%%/locales.d/sv-utf8.conf
+%%DATADIR%%/locales.d/sv.conf
+%%DATADIR%%/locales.d/th-utf8.conf
+%%DATADIR%%/locales.d/uk_UA-cp1251.conf
+%%DATADIR%%/locales.d/uk_UA-koi8-u.conf
+%%DATADIR%%/locales.d/uk_UA-utf8.conf
+%%DATADIR%%/locales.d/vi-utf8.conf
+%%DATADIR%%/locales.d/zh_CN-utf8.conf
+%%DATADIR%%/locales.d/zh_Hans-utf8.conf
+%%DATADIR%%/locales.d/zh_Hant-utf8.conf
+%%DATADIR%%/locales.d/zh_TW-utf8.conf
+%%DATADIR%%/locales.d/zh_english-utf8.conf
+%%DATADIR%%/mods.d/globals.conf
+@dirrm %%DATADIR%%/mods.d
+@dirrm %%DATADIR%%/locales.d
+@dirrm %%DATADIR%%
+@dirrm include/sword