aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-12 09:21:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-12 09:21:54 +0000
commit2973530931241386095a34a2bb8d99123446d748 (patch)
tree778ca977d30519c605e9a928b71645b75b6a38b3
parent5ee6dc26a24bf00eafd1bf92c83f7a41b351134c (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Cwd/Makefile21
-rw-r--r--devel/p5-Cwd/distinfo3
-rw-r--r--devel/p5-Cwd/pkg-descr10
-rw-r--r--devel/p5-Cwd/pkg-plist5
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 012421448641..1b33e646617d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1090,6 +1090,7 @@
SUBDIR += p5-Curses-UI
SUBDIR += p5-Curses-Widgets
SUBDIR += p5-Cvs
+ SUBDIR += p5-Cwd
SUBDIR += p5-DB_File-Lock
SUBDIR += p5-Danga-Socket
SUBDIR += p5-Danga-Socket-Callback
diff --git a/devel/p5-Cwd/Makefile b/devel/p5-Cwd/Makefile
new file mode 100644
index 000000000000..c1d679038a5c
--- /dev/null
+++ b/devel/p5-Cwd/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Audio-Mixer
+# Date created: 06 Oct 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cwd
+PORTVERSION= 2.21
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Get pathname of current working directory
+
+PERL_CONFIGURE= YES
+
+MAN3= Cwd.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Cwd/distinfo b/devel/p5-Cwd/distinfo
new file mode 100644
index 000000000000..10cab90fce72
--- /dev/null
+++ b/devel/p5-Cwd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cwd-2.21.tar.gz) = 030eeaa1957726b5e32d0eaada9c7bf6
+SHA256 (Cwd-2.21.tar.gz) = 103ce2613776ea6a7bf1ab580fbbdad20a09e3ccd48a001a32c59e3d95b30260
+SIZE (Cwd-2.21.tar.gz) = 16223
diff --git a/devel/p5-Cwd/pkg-descr b/devel/p5-Cwd/pkg-descr
new file mode 100644
index 000000000000..7a7b5f408607
--- /dev/null
+++ b/devel/p5-Cwd/pkg-descr
@@ -0,0 +1,10 @@
+Cwd - get pathname of current working directory
+
+This module provides functions for determining the pathname of the current
+working directory. It is recommended that getcwd (or another *cwd() function)
+be used in all code to ensure portability.
+
+By default, it exports the functions cwd(), getcwd(), fastcwd(), and
+fastgetcwd() (and, on Win32, getdcwd()) into the caller's namespace.
+
+WWW: http://search.cpan.org/~kwilliams/Cwd-2.21/Cwd.pm
diff --git a/devel/p5-Cwd/pkg-plist b/devel/p5-Cwd/pkg-plist
new file mode 100644
index 000000000000..0122aa064e4a
--- /dev/null
+++ b/devel/p5-Cwd/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Cwd.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/Cwd.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/Cwd.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cwd