aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2010-03-22 10:56:04 +0000
committerPeter Pentchev <roam@FreeBSD.org>2010-03-22 10:56:04 +0000
commit2b2456bcb8eca669f49b93dd78f41e5fc3c1cc62 (patch)
tree4a84780f3385e482b32678fc70dc1b039072d4c8
parentbf9e0b67a75957df3f949a9a20f106462d1f7004 (diff)
downloadports-2b2456bcb8eca669f49b93dd78f41e5fc3c1cc62.tar.gz
ports-2b2456bcb8eca669f49b93dd78f41e5fc3c1cc62.zip
Notes
-rw-r--r--dns/c-ares/Makefile19
-rw-r--r--dns/c-ares/distinfo6
-rw-r--r--dns/c-ares/files/ares-config-info.patch31
-rw-r--r--dns/c-ares/files/patch-Makefile.in11
-rw-r--r--dns/c-ares/pkg-plist7
5 files changed, 49 insertions, 25 deletions
diff --git a/dns/c-ares/Makefile b/dns/c-ares/Makefile
index dc03727015a6..29354fccedd9 100644
--- a/dns/c-ares/Makefile
+++ b/dns/c-ares/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= c-ares
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
CATEGORIES= dns
MASTER_SITES= http://c-ares.haxx.se/
@@ -15,6 +15,7 @@ COMMENT= An asynchronous DNS resolver library
OPTIONS= CONFIG_INFO "Add the ares_config_info patch" ON \
DEBUG "Build with debug information" OFF \
+ HIDE_SYMBOLS "Hide internal library symbols" ON \
OPTIMIZED_CFLAGS "Build with compiler optimizations" OFF
CONFLICTS= ares-1.*
@@ -32,6 +33,11 @@ CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
+.if defined(WITH_HIDE_SYMBOLS)
+CONFIGURE_ARGS+= --enable-symbol-hiding
+.else
+CONFIGURE_ARGS+= --disable-symbol-hiding
+.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+= --enable-optimize
.else
@@ -45,19 +51,21 @@ MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ARGS+= --enable-shared
MAN3= ares_cancel.3 \
ares_destroy.3 ares_dup.3 \
ares_expand_name.3 ares_expand_string.3 \
ares_fds.3 \
- ares_free_hostent.3 ares_free_string.3 \
+ ares_free_data.3 ares_free_hostent.3 ares_free_string.3 \
ares_gethostbyaddr.3 ares_gethostbyname.3 ares_gethostbyname_file.3 \
ares_getnameinfo.3 \
ares_getsock.3 \
ares_init.3 ares_init_options.3 \
+ ares_library_cleanup.3 ares_library_init.3 \
ares_mkquery.3 \
ares_parse_a_reply.3 ares_parse_aaaa_reply.3 ares_parse_ptr_reply.3 \
+ ares_parse_srv_reply.3 ares_parse_txt_reply.3 \
ares_process.3 \
ares_query.3 \
ares_search.3 \
@@ -69,4 +77,9 @@ MAN3= ares_cancel.3 \
ares_destroy_options.3 \
ares_save_options.3
+PROGRAMS= acountry adig ahost
+
+post-install:
+ ${INSTALL_PROGRAM} ${PROGRAMS:S@^@${WRKSRC}/.libs/@} ${PREFIX}/bin/
+
.include <bsd.port.post.mk>
diff --git a/dns/c-ares/distinfo b/dns/c-ares/distinfo
index 550998b382fb..45a71dc20453 100644
--- a/dns/c-ares/distinfo
+++ b/dns/c-ares/distinfo
@@ -1,3 +1,3 @@
-MD5 (c-ares-1.6.0.tar.gz) = 4503b0db3dd79d3c1f58d87722dbab46
-SHA256 (c-ares-1.6.0.tar.gz) = feb6abcac61556a07b26e11a8195b0b4f4926bd3bc9fb3dfb8ad451b9e2296e6
-SIZE (c-ares-1.6.0.tar.gz) = 448639
+MD5 (c-ares-1.7.0.tar.gz) = 15ab7852306b554b0b1145f41005a3bb
+SHA256 (c-ares-1.7.0.tar.gz) = c6b7104c25426778c1db66ee6cdaad028fad243c5c42c09cc638bd85c985fae3
+SIZE (c-ares-1.7.0.tar.gz) = 617652
diff --git a/dns/c-ares/files/ares-config-info.patch b/dns/c-ares/files/ares-config-info.patch
index 52b6285f9446..2fe403134c59 100644
--- a/dns/c-ares/files/ares-config-info.patch
+++ b/dns/c-ares/files/ares-config-info.patch
@@ -1,8 +1,11 @@
-Add the ares_get_config() routine used by Unreal IRCd.
+Description: Add the ares_get_config() routine used by Unreal IRCd.
+Origin: the Unreal IRCd distribution
+Forwarded: no
+Last-Update: 2010-03-22
--- ares.h.orig
+++ ares.h
-@@ -218,6 +218,14 @@
+@@ -261,6 +261,14 @@
int nsort;
};
@@ -17,26 +20,25 @@ Add the ares_get_config() routine used by Unreal IRCd.
struct hostent;
struct timeval;
struct sockaddr;
-@@ -313,7 +321,7 @@
- void ares_free_string(void *str);
- void ares_free_hostent(struct hostent *host);
- const char *ares_strerror(int code);
--
-+int ares_get_config(struct ares_config_info *d, ares_channel c);
+@@ -487,6 +495,8 @@
+
+ CARES_EXTERN const char *ares_strerror(int code);
+
++CARES_EXTERN int ares_get_config(struct ares_config_info *d, ares_channel c);
++
#ifdef __cplusplus
}
#endif
--- ares_init.c.orig
+++ ares_init.c
-@@ -1478,6 +1478,26 @@
- pat->mask.addr4.s_addr = htonl(IN_CLASSC_NET);
+@@ -1498,6 +1498,26 @@
}
- #endif
-+
+ #endif /* !WIN32 && !WATT32 */
+
+int ares_get_config(struct ares_config_info *d, ares_channel c)
+{
-+int i;
-+char *p;
++ int i;
++ char *p;
+
+ memset(d, 0, sizeof(struct ares_config_info));
+
@@ -52,6 +54,7 @@ Add the ares_get_config() routine used by Unreal IRCd.
+
+ return ARES_SUCCESS;
+}
++
/* initialize an rc4 key. If possible a cryptographically secure random key
is generated using a suitable function (for example win32's RtlGenRandom as
described in
diff --git a/dns/c-ares/files/patch-Makefile.in b/dns/c-ares/files/patch-Makefile.in
index 5521a53d9ccc..e6a2d66cf732 100644
--- a/dns/c-ares/files/patch-Makefile.in
+++ b/dns/c-ares/files/patch-Makefile.in
@@ -1,11 +1,14 @@
-Place the pkgconfig file in the correct directory on FreeBSD.
+Description: Place the pkgconfig file in the correct directory on FreeBSD.
+Author: Peter Pentchev <roam@FreeBSD.org>
+Forwarded: not-needed
+Last-Update: 2009-03-22
--- Makefile.in.orig
+++ Makefile.in
-@@ -283,7 +283,7 @@
- config-win32.h RELEASE-NOTES libcares.pc.in buildconf get_ver.awk maketgz \
- TODO
+@@ -316,7 +316,7 @@
+ CLEANFILES = $(PDFPAGES) $(HTMLPAGES)
+ DISTCLEANFILES = ares_build.h
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = libcares.pc
diff --git a/dns/c-ares/pkg-plist b/dns/c-ares/pkg-plist
index 67da2aa6da52..6b92de13b6e6 100644
--- a/dns/c-ares/pkg-plist
+++ b/dns/c-ares/pkg-plist
@@ -1,6 +1,11 @@
+bin/acountry
+bin/adig
+bin/ahost
include/ares.h
-include/ares_version.h
+include/ares_build.h
+include/ares_rules.h
include/ares_dns.h
+include/ares_version.h
lib/libcares.a
lib/libcares.la
lib/libcares.so