aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-05-26 00:13:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-05-26 00:13:19 +0000
commit2d42b6b8e6634784af0ad182decd346a0bd69765 (patch)
tree306a37ba25866fa6c5fb65659db395aed49a2407
parente771371e204c9d60e9a58631dfb8adaa96f94fab (diff)
downloadports-2d42b6b8e6634784af0ad182decd346a0bd69765.tar.gz
ports-2d42b6b8e6634784af0ad182decd346a0bd69765.zip
Notes
-rw-r--r--emulators/ppsspp/files/patch-CMakeLists.txt10
-rw-r--r--emulators/ppsspp/files/patch-Common_StdMutex.h17
-rw-r--r--emulators/ppsspp/files/patch-Core_HLE_sceRtc.cpp36
-rw-r--r--emulators/ppsspp/files/patch-Qt_Platform_linux.pri4
-rw-r--r--emulators/ppsspp/files/patch-Qt_Settings.pri2
-rw-r--r--emulators/ppsspp/files/patch-UI_NativeApp.cpp5
-rw-r--r--emulators/ppsspp/files/patch-native_ext_cityhash_city.cpp8
-rw-r--r--emulators/ppsspp/files/patch-native_ext_stb__vorbis_stb__vorbis.c2
-rw-r--r--emulators/ppsspp/files/patch-native_file_file__util.cpp2
-rw-r--r--emulators/ppsspp/files/patch-native_net_http__server.cpp6
10 files changed, 58 insertions, 34 deletions
diff --git a/emulators/ppsspp/files/patch-CMakeLists.txt b/emulators/ppsspp/files/patch-CMakeLists.txt
index b48e7359efa0..2b8e8bfe50f3 100644
--- a/emulators/ppsspp/files/patch-CMakeLists.txt
+++ b/emulators/ppsspp/files/patch-CMakeLists.txt
@@ -1,15 +1,19 @@
--- CMakeLists.txt.orig 2015-02-26 20:05:06 UTC
+++ CMakeLists.txt
-@@ -21,6 +21,8 @@ if(CMAKE_SYSTEM_PROCESSOR)
+@@ -21,7 +21,11 @@ if(CMAKE_SYSTEM_PROCESSOR)
if(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^armv7")
set(ARMV7 ON)
endif()
+- elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^x86" OR ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i.86")
+ elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^amd64")
+ set(X86 ON)
- elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^x86" OR ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i.86")
++ elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^x86" OR
++ ${CMAKE_SYSTEM_PROCESSOR} MATCHES "^amd64" OR
++ ${CMAKE_SYSTEM_PROCESSOR} MATCHES "i.86")
set(X86 ON)
elseif(${CMAKE_SYSTEM_PROCESSOR} MATCHES "^mips")
-@@ -250,7 +252,7 @@ if(NOT MSVC)
+ set(MIPS ON)
+@@ -250,7 +254,7 @@ if(NOT MSVC)
if (NOT CMAKE_C_COMPILER_ID STREQUAL "Intel" AND NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
add_definitions(-Wno-psabi)
endif()
diff --git a/emulators/ppsspp/files/patch-Common_StdMutex.h b/emulators/ppsspp/files/patch-Common_StdMutex.h
index c718e1a34581..34975eb377d2 100644
--- a/emulators/ppsspp/files/patch-Common_StdMutex.h
+++ b/emulators/ppsspp/files/patch-Common_StdMutex.h
@@ -1,17 +1,12 @@
--- Common/StdMutex.h.orig 2015-02-26 20:05:06 UTC
+++ Common/StdMutex.h
-@@ -4,12 +4,10 @@
- #define GCC_VER(x,y,z) ((x) * 10000 + (y) * 100 + (z))
+@@ -5,7 +5,8 @@
#define GCC_VERSION GCC_VER(__GNUC__, __GNUC_MINOR__, __GNUC_PATCHLEVEL__)
--// Note: __MAC_10_7 is defined on 10.7+.
+ // Note: __MAC_10_7 is defined on 10.7+.
-#if (GCC_VERSION >= GCC_VER(4,4,0) && __GXX_EXPERIMENTAL_CXX0X__ || defined(__APPLE__)) \
--/* GCC 4.4 provides <mutex>, except on these platforms: */ \
-- && !defined(ANDROID) && !defined(__SYMBIAN32__) && !defined(MACGNUSTD)
-+#if __cplusplus >= 201103L
++#if (__cplusplus >= 201103L || defined(__APPLE__) \
++ || (GCC_VERSION >= GCC_VER(4,4,0) && __GXX_EXPERIMENTAL_CXX0X__)) \
+ /* GCC 4.4 provides <mutex>, except on these platforms: */ \
+ && !defined(ANDROID) && !defined(__SYMBIAN32__) && !defined(MACGNUSTD)
#include <mutex>
- #else
-+#warning "partial <mutex> implementation"
-
- // partial <mutex> implementation for win32/pthread
- #include <algorithm>
diff --git a/emulators/ppsspp/files/patch-Core_HLE_sceRtc.cpp b/emulators/ppsspp/files/patch-Core_HLE_sceRtc.cpp
index 058a426595f5..cc230e43833d 100644
--- a/emulators/ppsspp/files/patch-Core_HLE_sceRtc.cpp
+++ b/emulators/ppsspp/files/patch-Core_HLE_sceRtc.cpp
@@ -1,38 +1,58 @@
--- Core/HLE/sceRtc.cpp.orig 2015-02-26 20:05:06 UTC
+++ Core/HLE/sceRtc.cpp
-@@ -459,7 +459,7 @@ static int sceRtcConvertLocalTimeToUTC(u
+@@ -459,12 +459,10 @@ static int sceRtcConvertLocalTimeToUTC(u
{
u64 srcTick = Memory::Read_U64(tickLocalPtr);
// TODO : Let the user select his timezone / daylight saving instead of taking system param ?
-#if defined(__GLIBC__) || defined(BLACKBERRY) || defined(__SYMBIAN32__)
-+#if 1 // #else block uses undeclared `timezone'
++#ifndef _MSC_VER
time_t timezone = 0;
tm *time = localtime(&timezone);
srcTick -= time->tm_gmtoff*1000000ULL;
-@@ -482,7 +482,7 @@ static int sceRtcConvertUtcToLocalTime(u
+-#else
+- srcTick -= -timezone * 1000000ULL;
+ #endif
+ Memory::Write_U64(srcTick, tickUTCPtr);
+ }
+@@ -482,12 +480,10 @@ static int sceRtcConvertUtcToLocalTime(u
{
u64 srcTick = Memory::Read_U64(tickUTCPtr);
// TODO : Let the user select his timezone / daylight saving instead of taking system param ?
-#if defined(__GLIBC__) || defined(BLACKBERRY) || defined(__SYMBIAN32__)
-+#if 1 // #else block uses undeclared `timezone'
++#ifndef _MSC_VER
time_t timezone = 0;
tm *time = localtime(&timezone);
srcTick += time->tm_gmtoff*1000000ULL;
-@@ -1015,7 +1015,7 @@ static int sceRtcFormatRFC2822LocalTime(
+-#else
+- srcTick += -timezone * 1000000ULL;
+ #endif
+ Memory::Write_U64(srcTick, tickLocalPtr);
+ }
+@@ -1015,12 +1011,10 @@ static int sceRtcFormatRFC2822LocalTime(
}
int tz_seconds;
-#if defined(__GLIBC__) || defined(BLACKBERRY) || defined(__SYMBIAN32__)
-+#if 1 // #else block uses undeclared `timezone'
++#ifndef _MSC_VER
time_t timezone = 0;
tm *time = localtime(&timezone);
tz_seconds = time->tm_gmtoff;
-@@ -1050,7 +1050,7 @@ static int sceRtcFormatRFC3339LocalTime(
+-#else
+- tz_seconds = -timezone;
+ #endif
+
+ DEBUG_LOG(SCERTC, "sceRtcFormatRFC2822LocalTime(%08x, %08x)", outPtr, srcTickPtr);
+@@ -1050,12 +1044,10 @@ static int sceRtcFormatRFC3339LocalTime(
}
int tz_seconds;
-#if defined(__GLIBC__) || defined(BLACKBERRY) || defined(__SYMBIAN32__)
-+#if 1 // #else block uses undeclared `timezone'
++#ifndef _MSC_VER
time_t timezone = 0;
tm *time = localtime(&timezone);
tz_seconds = time->tm_gmtoff;
+-#else
+- tz_seconds = -timezone;
+ #endif
+
+ DEBUG_LOG(SCERTC, "sceRtcFormatRFC3339LocalTime(%08x, %08x)", outPtr, srcTickPtr);
diff --git a/emulators/ppsspp/files/patch-Qt_Platform_linux.pri b/emulators/ppsspp/files/patch-Qt_Platform_linux.pri
index dc5f53d8ac48..1e560bc81fc1 100644
--- a/emulators/ppsspp/files/patch-Qt_Platform_linux.pri
+++ b/emulators/ppsspp/files/patch-Qt_Platform_linux.pri
@@ -5,8 +5,8 @@
# Executable
- LIBS += -ldl -lrt
-+ LIBS += $$QMAKE_LIBS_DYNLOAD
-+ linux-*|hpux-*|solaris-*: LIBS += -lrt
++ LIBS += $$QMAKE_LIBS_DYNLOAD # dlopen
++ linux-*|hpux-*|solaris-*: LIBS += -lrt # clock_gettime
# Packaging
icon16.files = $$P/assets/unix-icons/hicolor/16x16/apps/ppsspp.png
diff --git a/emulators/ppsspp/files/patch-Qt_Settings.pri b/emulators/ppsspp/files/patch-Qt_Settings.pri
index 45fc45a7e841..4f1543af8dc5 100644
--- a/emulators/ppsspp/files/patch-Qt_Settings.pri
+++ b/emulators/ppsspp/files/patch-Qt_Settings.pri
@@ -6,7 +6,7 @@
P = $$_PRO_FILE_PWD_/..
-INCLUDEPATH += $$P/ext/zlib $$P/Common
+INCLUDEPATH += $$P/Common
-+contains(QT_CONFIG, no-zlib): INCLUDEPATH += $$P/ext/zlib
++win32|contains(QT_CONFIG, no-zlib): INCLUDEPATH += $$P/ext/zlib
# Work out arch name
include(Platform/ArchDetection.pri)
diff --git a/emulators/ppsspp/files/patch-UI_NativeApp.cpp b/emulators/ppsspp/files/patch-UI_NativeApp.cpp
index 0e6cca63f687..847da1bd6f5e 100644
--- a/emulators/ppsspp/files/patch-UI_NativeApp.cpp
+++ b/emulators/ppsspp/files/patch-UI_NativeApp.cpp
@@ -1,12 +1,11 @@
--- UI/NativeApp.cpp.orig 2015-02-26 20:05:06 UTC
+++ UI/NativeApp.cpp
-@@ -291,7 +291,8 @@ void NativeInit(int argc, const char *ar
+@@ -295,7 +295,7 @@ void NativeInit(int argc, const char *ar
#elif defined(BLACKBERRY) || defined(IOS)
// Packed assets are included in app
VFSRegister("", new DirectoryAssetReader(external_directory));
-#elif defined(__APPLE__) || (defined(__linux__) && !defined(ANDROID))
-+#elif defined(__APPLE__) || (defined(__linux__) && !defined(ANDROID)) || \
-+ defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
++#elif !defined(MOBILE_DEVICE) && !defined(_WIN32)
VFSRegister("", new DirectoryAssetReader((File::GetExeDirectory() + "assets/").c_str()));
VFSRegister("", new DirectoryAssetReader((File::GetExeDirectory()).c_str()));
VFSRegister("", new DirectoryAssetReader("/usr/share/ppsspp/assets/"));
diff --git a/emulators/ppsspp/files/patch-native_ext_cityhash_city.cpp b/emulators/ppsspp/files/patch-native_ext_cityhash_city.cpp
index 6ec7e348c636..61d87faaec27 100644
--- a/emulators/ppsspp/files/patch-native_ext_cityhash_city.cpp
+++ b/emulators/ppsspp/files/patch-native_ext_cityhash_city.cpp
@@ -1,6 +1,6 @@
--- native/ext/cityhash/city.cpp.orig 2015-02-23 23:22:58 UTC
+++ native/ext/cityhash/city.cpp
-@@ -68,7 +68,7 @@ static uint32 UNALIGNED_LOAD32(const cha
+@@ -68,12 +68,12 @@ static uint32 UNALIGNED_LOAD32(const cha
#define bswap_32(x) BSWAP_32(x)
#define bswap_64(x) BSWAP_64(x)
@@ -9,3 +9,9 @@
#include <sys/endian.h>
#define bswap_32(x) bswap32(x)
#define bswap_64(x) bswap64(x)
+
+-#elif defined(__OpenBSD__)
++#elif defined(__Bitrig__) || defined(__OpenBSD__)
+ #include <sys/types.h>
+ #define bswap_32(x) swap32(x)
+ #define bswap_64(x) swap64(x)
diff --git a/emulators/ppsspp/files/patch-native_ext_stb__vorbis_stb__vorbis.c b/emulators/ppsspp/files/patch-native_ext_stb__vorbis_stb__vorbis.c
index e123418139a9..17d87f17cb4d 100644
--- a/emulators/ppsspp/files/patch-native_ext_stb__vorbis_stb__vorbis.c
+++ b/emulators/ppsspp/files/patch-native_ext_stb__vorbis_stb__vorbis.c
@@ -5,7 +5,7 @@
#pragma warning (disable:4244)
#include <malloc.h>
-#elif !defined(__SYMBIAN32__)
-+#elif !defined(__SYMBIAN32__) && !defined(__DragonFly__) && \
++#elif !defined(__SYMBIAN32__) && !defined(__Bitrig__) && !defined(__DragonFly__) && \
+ !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
#include <alloca.h>
#endif
diff --git a/emulators/ppsspp/files/patch-native_file_file__util.cpp b/emulators/ppsspp/files/patch-native_file_file__util.cpp
index fd5f0b073ab9..eccfa60b65c3 100644
--- a/emulators/ppsspp/files/patch-native_file_file__util.cpp
+++ b/emulators/ppsspp/files/patch-native_file_file__util.cpp
@@ -5,7 +5,7 @@
#include "util/text/utf8.h"
-#if defined(__FreeBSD__) || defined(__APPLE__)
-+#if !defined(__linux__) && !defined(__SYMBIAN32__)
++#if !defined(__linux__) && !defined(_WIN32) && !defined(__QNX__)
#define stat64 stat
#endif
diff --git a/emulators/ppsspp/files/patch-native_net_http__server.cpp b/emulators/ppsspp/files/patch-native_net_http__server.cpp
index fc1e0bb7bbb2..f93b3af4e2d5 100644
--- a/emulators/ppsspp/files/patch-native_net_http__server.cpp
+++ b/emulators/ppsspp/files/patch-native_net_http__server.cpp
@@ -1,10 +1,10 @@
--- native/net/http_server.cpp.orig 2015-02-23 23:22:58 UTC
+++ native/net/http_server.cpp
-@@ -12,6 +12,7 @@
+@@ -11,6 +11,7 @@
+ #include <sys/socket.h> /* socket definitions */
#include <sys/types.h> /* socket types */
#include <sys/wait.h> /* for waitpid() */
- #include <arpa/inet.h> /* inet (3) funtions */
+#include <netinet/in.h> /* struct sockaddr_in */
+ #include <arpa/inet.h> /* inet (3) funtions */
#include <unistd.h> /* misc. UNIX functions */
- #endif