aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-04-24 19:15:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-04-24 19:15:05 +0000
commit32daaae72c4bea6711020b6b7a68acbaf0af386e (patch)
treeb590ae091a9af999c14febe1822125712dc4d64d
parenta5d01b17a3d027e7980bd9a736a47dee432f579f (diff)
downloadports-32daaae72c4bea6711020b6b7a68acbaf0af386e.tar.gz
ports-32daaae72c4bea6711020b6b7a68acbaf0af386e.zip
Notes
-rw-r--r--Mk/bsd.gecko.mk5
-rw-r--r--Mk/bsd.ssp.mk11
-rw-r--r--audio/linux-skype_oss_wrapper/Makefile1
-rw-r--r--devel/linux_libusb/Makefile1
-rw-r--r--devel/mingw32-libyaml/Makefile1
-rw-r--r--devel/psptoolchain-gcc-stage1/Makefile1
-rw-r--r--devel/psptoolchain-newlib/Makefile1
-rw-r--r--devel/psptoolchain-pspsdk-stage2/Makefile1
-rw-r--r--lang/gnu-cobol/Makefile1
-rw-r--r--lang/mlton/Makefile1
-rw-r--r--math/gretl/Makefile1
-rw-r--r--math/mingw32-libgmp/Makefile1
12 files changed, 13 insertions, 13 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 6bec2b87fdb2..384847dd360a 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -119,11 +119,6 @@ BUILD_DEPENDS+= rust-cbindgen>=0.6.8:devel/rust-cbindgen \
MOZ_OPTIONS+= --enable-pie
.endif
-.if ${MOZILLA_VER:R:R} >= 65
-# Let vendor add -fstack-protector-strong on all architectures
-SSP_UNSAFE= yes
-.endif
-
MOZILLA_SUFX?= none
MOZSRC?= ${WRKSRC}
PLISTF?= ${WRKDIR}/plist_files
diff --git a/Mk/bsd.ssp.mk b/Mk/bsd.ssp.mk
index 4f0058fe38da..0bc5819bcd6f 100644
--- a/Mk/bsd.ssp.mk
+++ b/Mk/bsd.ssp.mk
@@ -4,14 +4,9 @@
SSP_Include_MAINTAINER= portmgr@FreeBSD.org
.if !defined(SSP_UNSAFE) && \
- (${ARCH} == i386 || ${ARCH} == amd64)
+ (${MACHINE} != "mips")
# Overridable as a user may want to use -fstack-protector-all
-SSP_CFLAGS?= -fstack-protector
+SSP_CFLAGS?= -fstack-protector-strong
CFLAGS+= ${SSP_CFLAGS}
-LDFLAGS+= -fstack-protector
-# -lssp_nonshared is needed on i386 where /usr/lib/libc.so is not an ldscript
-# This is currently unused XXX
-. if defined(SSP_NEED_NONSHARED)
-LDFLAGS+= -lssp_nonshared
-. endif
+LDFLAGS+= ${SSP_CFLAGS}
.endif
diff --git a/audio/linux-skype_oss_wrapper/Makefile b/audio/linux-skype_oss_wrapper/Makefile
index 290b55977c85..f0bced7d1d8a 100644
--- a/audio/linux-skype_oss_wrapper/Makefile
+++ b/audio/linux-skype_oss_wrapper/Makefile
@@ -24,6 +24,7 @@ USES= linux
USE_LINUX= base devtools:build
USE_LINUX_PREFIX= yes
# do not define USE_LDCONFIG, it's not for global use
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= lib/skype_oss_wrapper/libpulse.so.0
diff --git a/devel/linux_libusb/Makefile b/devel/linux_libusb/Makefile
index 01a5d0746288..4138f7547fcd 100644
--- a/devel/linux_libusb/Makefile
+++ b/devel/linux_libusb/Makefile
@@ -20,6 +20,7 @@ PLIST_FILES= usr/lib/libusb.so \
usr/lib/libusb-0.1.so.4
CC= ${LINUXBASE}/usr/bin/gcc
CFLAGS+= -I${WRKDIR}/sys
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
MAKE_ARGS+= LIBUSB_GLOBAL_INCLUDE_FILE=libusb_global_linux.h
MAKE_ARGS+= PTHREAD_LIBS="-lpthread -lrt"
MAKE_ARGS+= WITHOUT_SSP=yes
diff --git a/devel/mingw32-libyaml/Makefile b/devel/mingw32-libyaml/Makefile
index 67e649d2b5c5..bfb6ea7aa781 100644
--- a/devel/mingw32-libyaml/Makefile
+++ b/devel/mingw32-libyaml/Makefile
@@ -21,6 +21,7 @@ GNU_CONFIGURE_PREFIX= ${PREFIX}/mingw32
CONFIGURE_ARGS= --host="mingw32"
CC= ${PKGNAMEPREFIX}gcc
CFLAGS= -O3 # Override CFLAGS for a cross-build
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
USES= libtool
.include <bsd.port.mk>
diff --git a/devel/psptoolchain-gcc-stage1/Makefile b/devel/psptoolchain-gcc-stage1/Makefile
index 9a7437c979dd..ac53d3ce826a 100644
--- a/devel/psptoolchain-gcc-stage1/Makefile
+++ b/devel/psptoolchain-gcc-stage1/Makefile
@@ -52,6 +52,7 @@ CONFIGURE_ARGS?= --prefix=${PREFIX}/${PSP_GCC_STAGE_PREFIX} \
--with-ld=${LOCALBASE}/bin/psp-ld \
--with-as=${LOCALBASE}/bin/psp-as \
--mandir=${PREFIX}/man
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
# Don't install any documentation for psptoolchain's gcc stage 1 - makes no sense.
# Disable installation of .info files and libiberty for both stages.
diff --git a/devel/psptoolchain-newlib/Makefile b/devel/psptoolchain-newlib/Makefile
index 3504fb2cd684..88177520d489 100644
--- a/devel/psptoolchain-newlib/Makefile
+++ b/devel/psptoolchain-newlib/Makefile
@@ -29,6 +29,7 @@ CONFIGURE_ENV= PATH=${LOCALBASE}/${PSP_GCC_STAGE_PREFIX}/bin:${PATH} \
CFLAGS="${CFLAGS:C/(^|[[:space:]])-march=[^[:space:]]*//g} -g"
MAKE_ENV= PATH=${LOCALBASE}/${PSP_GCC_STAGE_PREFIX}/bin:${PATH}
CONFIGURE_ARGS= --prefix=${PREFIX} --target="psp"
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
# Disable installation of .info files and fix includedir reference.
post-patch:
diff --git a/devel/psptoolchain-pspsdk-stage2/Makefile b/devel/psptoolchain-pspsdk-stage2/Makefile
index 14b01a9c3491..e82c71cba9ed 100644
--- a/devel/psptoolchain-pspsdk-stage2/Makefile
+++ b/devel/psptoolchain-pspsdk-stage2/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= psp-cpp:devel/psptoolchain-gcc-stage2 \
# psp-gcc doesn't need -march=... in CFLAGS (e.g. set by CPUTYPE in make.conf)
CONFIGURE_ENV= CFLAGS="${CFLAGS:C/(^|[[:space:]])-march=[^[:space:]]*//g}"
CONFIGURE_ARGS= --prefix=${PREFIX} --with-pspdev="${LOCALBASE}"
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
PLIST= ${.CURDIR}/pkg-plist
MASTERDIR= ${.CURDIR}/../psptoolchain-pspsdk-stage1
diff --git a/lang/gnu-cobol/Makefile b/lang/gnu-cobol/Makefile
index c711f81741e5..467c62d28638 100644
--- a/lang/gnu-cobol/Makefile
+++ b/lang/gnu-cobol/Makefile
@@ -24,6 +24,7 @@ INFO= gnucobol
DATADIR= ${PREFIX}/share/gnucobol
INSTALL_TARGET= install-strip
+SSP_CFLAGS?= -fstack-protector # XXX -strong fails to build
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index dcc45a339fd0..92e15fb6e1bc 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -71,6 +71,7 @@ BUILD_DEPENDS+= wine:emulators/wine \
${LOCALBASE}/mingw32/lib/libgmp.a:math/mingw32-libgmp
RUN_DEPENDS+= mingw32-gcc:devel/mingw32-gcc \
${LOCALBASE}/mingw32/lib/libgmp.a:math/mingw32-libgmp
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
PLIST_SUB+= MINGW32CROSS=""
.else
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index db9ef07040a1..e7cfb9eadcbb 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -27,6 +27,7 @@ USE_LDCONFIG= yes
BINARY_ALIAS= make=${GMAKE}
ALL_TARGET= # empty
+SSP_CFLAGS?= -fstack-protector # XXX -strong crashes mklang on 12.0+ i386
CONFIGURE_ENV= ac_cv_lib_dl_dlopen="" \
LAPACK_LIBS="${LAPACK} ${BLAS}"
diff --git a/math/mingw32-libgmp/Makefile b/math/mingw32-libgmp/Makefile
index f781bd548e6b..4e2b08e48c53 100644
--- a/math/mingw32-libgmp/Makefile
+++ b/math/mingw32-libgmp/Makefile
@@ -23,6 +23,7 @@ GNU_CONFIGURE= yes
CC= ${PKGNAMEPREFIX}gcc
CXX= ${PKGNAMEPREFIX}c++
CFLAGS+= -I/usr/include
+SSP_CFLAGS?= -fstack-protector # XXX -strong isn't supported by GCC < 4.9
CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split" \
PREFIX="${PREFIX}/${GMP_TARG}" \
M4="/usr/bin/m4"