aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-04-22 01:26:01 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-04-22 01:26:01 +0000
commit33e82833423d02a83c437c6ed419aebb9f4be3fe (patch)
tree79e0717ad48bf0198c251ad9461c102b2b5a60f5
parentdd5b69aab28dbaab03e2bef9a7023b10e5d886f0 (diff)
BROKEN on 7.0: Incorrect objformat handling
Notes
Notes: svn path=/head/; revision=190603
-rw-r--r--math/guppi/Makefile8
-rw-r--r--x11-themes/gtk-cleanice-engine/Makefile8
-rw-r--r--x11-themes/gtk-smooth-engine/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 9c6a59c39562..c74eb071f7c8 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -36,4 +36,10 @@ post-extract:
@${MKDIR} ${WRKDIR}/gnumeric
@${CP} ${FILESDIR}/GNOME_Gnumeric_Graph.idl ${WRKDIR}/gnumeric
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700029
+BROKEN= Incorrect objformat handling
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-themes/gtk-cleanice-engine/Makefile b/x11-themes/gtk-cleanice-engine/Makefile
index cb822710ad5c..0f0c1f444c73 100644
--- a/x11-themes/gtk-cleanice-engine/Makefile
+++ b/x11-themes/gtk-cleanice-engine/Makefile
@@ -37,4 +37,10 @@ post-install:
${INSTALL_DATA} ${THEMEDIR}/cleanice-dark/gtkrc \
${PREFIX}/share/themes/CleanIce-Dark/gtk-2.0
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700029
+BROKEN= Incorrect objformat handling
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-themes/gtk-smooth-engine/Makefile b/x11-themes/gtk-smooth-engine/Makefile
index b68a696440be..f16971285f06 100644
--- a/x11-themes/gtk-smooth-engine/Makefile
+++ b/x11-themes/gtk-smooth-engine/Makefile
@@ -24,6 +24,10 @@ CONFLICTS= gtk-engines2-[0-9]*
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700029
+BROKEN= Incorrect objformat handling
+.endif
+
.if ${HAVE_GNOME:Mgtk20}!=""
WITH_GTK2= yes
.endif