aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 10:15:44 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-18 10:15:44 +0000
commit36785a757b17be14b70934f9bee46747c0eb772e (patch)
treea8247e1c24a577483622041042918f66fd5ea16c
parent0ae755ed3410657b7f1fc6a4002839e2c55a31b1 (diff)
downloadports-36785a757b17be14b70934f9bee46747c0eb772e.tar.gz
ports-36785a757b17be14b70934f9bee46747c0eb772e.zip
Notes
-rw-r--r--devel/mime/Makefile7
-rw-r--r--devel/mime/files/patch-Makefile.in37
-rw-r--r--devel/mime/files/patch-header.c4
-rw-r--r--devel/mime/files/patch-message.c4
-rw-r--r--devel/mime/files/patch-util.c4
-rw-r--r--devel/mime/files/patch-util.h4
6 files changed, 47 insertions, 13 deletions
diff --git a/devel/mime/Makefile b/devel/mime/Makefile
index dacdb13d05ac..12ebd203aa43 100644
--- a/devel/mime/Makefile
+++ b/devel/mime/Makefile
@@ -14,11 +14,8 @@ COMMENT= C library to parse mime data
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e "s,-fpic,-fpic -fPIC,g" ${WRKSRC}/Makefile.in
-
post-install:
- @(cd ${PREFIX}/lib ; ${LN} -sf libmime.so.1 libmime.so )
+ @(cd ${STAGEDIR}${PREFIX}/lib ; ${STRIP_CMD} libmime.so.1; \
+ ${LN} -sf libmime.so.1 libmime.so )
.include <bsd.port.mk>
diff --git a/devel/mime/files/patch-Makefile.in b/devel/mime/files/patch-Makefile.in
new file mode 100644
index 000000000000..ae23cb5fa964
--- /dev/null
+++ b/devel/mime/files/patch-Makefile.in
@@ -0,0 +1,37 @@
+--- ./Makefile.in.orig 2003-09-16 01:37:19.000000000 +0200
++++ ./Makefile.in 2014-02-18 11:12:31.484358106 +0100
+@@ -88,17 +88,17 @@
+ $(POBJS) $(TPROG) $(TOBJS) .depend
+
+ install: $(ARNAME) $(SONAME) $(PANAME)
+- mkdir -p -m 755 $(LIBDIR)
++ mkdir -p -m 755 $(DESTDIR)$(LIBDIR)
+ for i in $(ARNAME) $(SONAME) $(PANAME); do \
+- cp $$i $(LIBDIR); \
+- chown $(LIBOWN):$(LIBGRP) $(LIBDIR)/$$i; \
+- chmod $(LIBMOD) $(LIBDIR)/$$i; \
++ cp $$i $(DESTDIR)$(LIBDIR); \
++ chown $(LIBOWN):$(LIBGRP) $(DESTDIR)$(LIBDIR)/$$i; \
++ chmod $(LIBMOD) $(DESTDIR)$(LIBDIR)/$$i; \
+ done
+- mkdir -p -m 755 $(INCDIR)
++ mkdir -p -m 755 $(DESTDIR)$(INCDIR)
+ for i in $(INCS); do \
+- cp $$i $(INCDIR); \
+- chown $(INCOWN):$(INCGRP) $(INCDIR)/$$i; \
+- chmod $(INCMOD) $(INCDIR)/$$i; \
++ cp $$i $(DESTDIR)$(INCDIR); \
++ chown $(INCOWN):$(INCGRP) $(DESTDIR)$(INCDIR)/$$i; \
++ chmod $(INCMOD) $(DESTDIR)$(INCDIR)/$$i; \
+ done
+
+ depend:
+@@ -116,7 +116,7 @@
+ .SUFFIXES:
+ .SUFFIXES: .so .po .c .o
+ .c.so:
+- $(CC) -fpic $(AFLAGS) -c $< -o $@
++ $(CC) -fpic -fPIC $(AFLAGS) -c $< -o $@
+
+ .c.po:
+ $(CC) $(PROFILE) $(AFLAGS) -c $< -o $@
diff --git a/devel/mime/files/patch-header.c b/devel/mime/files/patch-header.c
index f28b35dc9ff5..87a37e96c35a 100644
--- a/devel/mime/files/patch-header.c
+++ b/devel/mime/files/patch-header.c
@@ -1,5 +1,5 @@
---- header.c.orig Sun Oct 30 23:37:49 2005
-+++ header.c Sun Oct 30 23:38:13 2005
+--- ./header.c.orig 2003-09-16 01:37:19.000000000 +0200
++++ ./header.c 2014-02-18 11:11:32.980337829 +0100
@@ -67,7 +67,7 @@
alc = 0;
diff --git a/devel/mime/files/patch-message.c b/devel/mime/files/patch-message.c
index 8c507080df10..301ac69b6e63 100644
--- a/devel/mime/files/patch-message.c
+++ b/devel/mime/files/patch-message.c
@@ -1,5 +1,5 @@
---- message.c.orig Tue Aug 31 10:14:24 2010
-+++ message.c Tue Aug 31 10:14:10 2010
+--- ./message.c.orig 2003-09-16 01:37:19.000000000 +0200
++++ ./message.c 2014-02-18 11:11:32.983337749 +0100
@@ -89,7 +89,7 @@
* XXX - need to be fixed to support "\r\n"
*/
diff --git a/devel/mime/files/patch-util.c b/devel/mime/files/patch-util.c
index 24a9b5eeca2a..1159aba63a17 100644
--- a/devel/mime/files/patch-util.c
+++ b/devel/mime/files/patch-util.c
@@ -1,5 +1,5 @@
---- util.c.orig Sun Oct 30 23:38:55 2005
-+++ util.c Sun Oct 30 23:39:26 2005
+--- ./util.c.orig 2003-09-16 01:37:19.000000000 +0200
++++ ./util.c 2014-02-18 11:11:32.986338150 +0100
@@ -31,7 +31,7 @@
#if 0
diff --git a/devel/mime/files/patch-util.h b/devel/mime/files/patch-util.h
index 20047f262028..582e8a8421e9 100644
--- a/devel/mime/files/patch-util.h
+++ b/devel/mime/files/patch-util.h
@@ -1,5 +1,5 @@
---- util.h.orig Sun Oct 30 23:39:40 2005
-+++ util.h Sun Oct 30 23:39:56 2005
+--- ./util.h.orig 2003-09-16 01:37:19.000000000 +0200
++++ ./util.h 2014-02-18 11:11:32.989336888 +0100
@@ -30,6 +30,6 @@
#ifndef _UTIL_H_
#define _UTIL_H_