aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 00:33:29 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 00:33:29 +0000
commit3b13c98a60e823f1bc3e1f443d21e61fcb8dcbcc (patch)
tree92d4e44e25fb88a61a380cd3ee9dacf24fca37c4
parent1261ab9470d3b27700cd81cd7020d4b3af86b962 (diff)
downloadports-3b13c98a60e823f1bc3e1f443d21e61fcb8dcbcc.tar.gz
ports-3b13c98a60e823f1bc3e1f443d21e61fcb8dcbcc.zip
Notes
-rw-r--r--mail/batv-milter/Makefile4
-rw-r--r--mail/emil/Makefile8
-rw-r--r--mail/mailgraph/Makefile6
-rw-r--r--mail/mboxgrep/Makefile8
-rw-r--r--mail/p5-Log-Procmail/Makefile4
-rw-r--r--mail/p5-Mail-Audit/Makefile6
-rw-r--r--mail/p5-POE-Component-Client-POP3/Makefile4
-rw-r--r--mail/p5-POE-Component-Client-POP3/pkg-plist6
-rw-r--r--mail/popa3d/Makefile4
-rw-r--r--mail/qgmailnotifier/Makefile4
-rw-r--r--mail/qmail-auditor/Makefile6
-rw-r--r--mail/qmail-autoresponder/Makefile4
-rw-r--r--mail/qmail-notify/Makefile4
-rw-r--r--mail/qmail-qfilter/Makefile4
-rw-r--r--mail/qmail-remove/Makefile4
-rw-r--r--mail/renattach/Makefile4
-rw-r--r--mail/spambnc/Makefile8
-rw-r--r--mail/squirrelmail-spam-buttons-plugin/Makefile6
-rw-r--r--mail/squirrelmail-vlogin-plugin/Makefile6
19 files changed, 48 insertions, 52 deletions
diff --git a/mail/batv-milter/Makefile b/mail/batv-milter/Makefile
index 32323d677eff..edb1093c2f1d 100644
--- a/mail/batv-milter/Makefile
+++ b/mail/batv-milter/Makefile
@@ -23,6 +23,8 @@ SITE_SUB= -e "s|%%PREFIX%%|${PREFIX}|g" \
-e "s|%%OPENSSLINC%%|${OPENSSLINC}|g" \
-e "s|%%OPENSSLLIB%%|${OPENSSLLIB}|g"
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
@@ -40,11 +42,9 @@ post-install:
.endif
@${RM} -f ${MANPREFIX}/man/cat8/batv-filter.8 ${MANPREFIX}/man/cat8/batv-filter.8.gz
${INSTALL_MAN} ${WRKSRC}/*/batv-filter.8 ${STAGEDIR}${MANPREFIX}/man/man8/
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.post.mk>
diff --git a/mail/emil/Makefile b/mail/emil/Makefile
index 770fd35860f3..4b436091ba60 100644
--- a/mail/emil/Makefile
+++ b/mail/emil/Makefile
@@ -18,8 +18,12 @@ COMMENT= Mail format/encoding converter
GNU_CONFIGURE= yes
CONFIGURE_ENV= YACC=byacc
-.if defined(NOPORTDOCS)
-MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MDOCS)
+MAKE_ENV= NOPORTDOCS=yes
.endif
.include <bsd.port.mk>
diff --git a/mail/mailgraph/Makefile b/mail/mailgraph/Makefile
index 6cc0fe4aef96..b45e58557dfa 100644
--- a/mail/mailgraph/Makefile
+++ b/mail/mailgraph/Makefile
@@ -28,10 +28,10 @@ USE_RC_SUBR= ${PORTNAME}
SUB_LIST+= MAILGRAPH_USER=${MAILGRAPH_USER} MAILGRAPH_GROUP=${MAILGRAPH_GROUP}
PLIST_SUB= CGIDIR=${CGIDIR:S,${PREFIX}/,,} WWWROOT=${WWWROOT:S,${PREFIX}/,,}
+OPTIONS_DEFINE= DOCS
+
DOCS= README CHANGES
-.if !defined(NOPORTDOCS)
PORTDOCS= ${DOCS}
-.endif
pre-everything::
@${ECHO_MSG} ""
@@ -52,11 +52,9 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/mailgraph.pl ${STAGEDIR}${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKSRC}/mailgraph.cgi ${STAGEDIR}${CGIDIR}
@${INSTALL_DATA} ${WRKSRC}/mailgraph.css ${STAGEDIR}${WWWROOT}/mailgraph
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
for f in ${DOCS}; do \
${INSTALL_DATA} ${WRKSRC}/$$f ${STAGEDIR}${DOCSDIR}; \
done
-.endif
.include <bsd.port.mk>
diff --git a/mail/mboxgrep/Makefile b/mail/mboxgrep/Makefile
index e28657e4387f..01e5939a6a8e 100644
--- a/mail/mboxgrep/Makefile
+++ b/mail/mboxgrep/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF
MAINTAINER= anders@FreeBSD.org
COMMENT= Utility to scan mailboxes for messages matching a regular expression
-.if defined(WITH_PCRE)
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
-.endif
+PCRE_LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+
+OPTIONS_DEFINE= DOCS PCRE
USES= uidfix
GNU_CONFIGURE= yes
@@ -32,11 +32,9 @@ post-patch:
${WRKSRC}/src/Makefile.in ${WRKSRC}/doc/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
${INSTALL} -d -o root -g wheel -m 0755 ${STAGEDIR}${DOCSDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/mail/p5-Log-Procmail/Makefile b/mail/p5-Log-Procmail/Makefile
index fba932c3ab1d..05bc0cebfefc 100644
--- a/mail/p5-Log-Procmail/Makefile
+++ b/mail/p5-Log-Procmail/Makefile
@@ -13,13 +13,13 @@ COMMENT= Perl extension for reading procmail logfiles
USES= perl5
USE_PERL5= configure
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
PORTDOCS= Changes
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Audit/Makefile b/mail/p5-Mail-Audit/Makefile
index e4d270ac8d1d..ece8eaabe401 100644
--- a/mail/p5-Mail-Audit/Makefile
+++ b/mail/p5-Mail-Audit/Makefile
@@ -25,22 +25,20 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= Changes FAQ README
PORTEXAMPLES= popread proc2ma
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -i '' -e 's|/var/spool/mail|/var/mail|g' \
${WRKSRC}/lib/Mail/Audit.pm
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/${i}
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${PORTEXAMPLES}
${INSTALL_SCRIPT} ${WRKSRC}/bin/${i} ${STAGEDIR}${EXAMPLESDIR}/${i}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/mail/p5-POE-Component-Client-POP3/Makefile b/mail/p5-POE-Component-Client-POP3/Makefile
index 01f547fb3bfe..de765f16ebaa 100644
--- a/mail/p5-POE-Component-Client-POP3/Makefile
+++ b/mail/p5-POE-Component-Client-POP3/Makefile
@@ -16,11 +16,11 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
+OPTIONS_DEFINE= EXAMPLES
+
post-install:
-.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/p5-POE-Component-Client-POP3/pkg-plist b/mail/p5-POE-Component-Client-POP3/pkg-plist
index 98d9c66d9321..bcdb092b9088 100644
--- a/mail/p5-POE-Component-Client-POP3/pkg-plist
+++ b/mail/p5-POE-Component-Client-POP3/pkg-plist
@@ -1,9 +1,9 @@
%%PERL5_MAN3%%/POE::Component::Client::POP3.3.gz
%%SITE_PERL%%/POE/Component/Client/POP3.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/POP3/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/term.perl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.perl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/term.perl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.perl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/POP3
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index 1412548c5973..1a06d44f9a62 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -16,7 +16,7 @@ PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
UNIQUENAME= ${.CURDIR:T}
-OPTIONS_DEFINE= SMTP_AFTER_POP3 STANDALONE_POP3 SETPROCTITLE
+OPTIONS_DEFINE= SMTP_AFTER_POP3 STANDALONE_POP3 SETPROCTITLE DOCS
NO_OPTIONS_SORT=yes
SMTP_AFTER_POP3_DESC=Enable SMTP-after-POP support
STANDALONE_POP3_DESC=Enable standalone server mode
@@ -89,7 +89,7 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/popauth.m4 ${STAGEDIR}${CFDIR}/hack/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/DESIGN ${STAGEDIR}${DOCSDIR}/
${INSTALL_MAN} ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}/
diff --git a/mail/qgmailnotifier/Makefile b/mail/qgmailnotifier/Makefile
index b0e9035f9944..bec08caabc9f 100644
--- a/mail/qgmailnotifier/Makefile
+++ b/mail/qgmailnotifier/Makefile
@@ -19,14 +19,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|/bin|${PREFIX}/bin|g' ${WRKSRC}/qgmailnotifier.pro
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/qmail-auditor/Makefile b/mail/qmail-auditor/Makefile
index a0516e6a5bfc..31ed6285333e 100644
--- a/mail/qmail-auditor/Makefile
+++ b/mail/qmail-auditor/Makefile
@@ -18,16 +18,14 @@ GNU_CONFIGURE= yes
SUB_FILES= pkg-message
SUB_LIST= QMAIL_PREFIX=${QMAIL_PREFIX}
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${STAGEDIR}${PREFIX}|g' \
${WRKSRC}/src/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/qmail-autoresponder/Makefile b/mail/qmail-autoresponder/Makefile
index 3b1f59d0bfd9..42a66d6d7348 100644
--- a/mail/qmail-autoresponder/Makefile
+++ b/mail/qmail-autoresponder/Makefile
@@ -22,6 +22,8 @@ DOCS= NEWS README TODO procedure.txt schema.mysql
ALL_TARGET= ${PROGS}
+OPTIONS_DEFINE= DOCS
+
do-configure:
${ECHO_CMD} "${STAGEDIR}${PREFIX}/bin" > ${WRKSRC}/conf-bin
${ECHO_CMD} "${STAGEDIR}${MANPREFIX}/man" > ${WRKSRC}/conf-man
@@ -31,9 +33,7 @@ do-configure:
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PROGS} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/qmail-autoresponder.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/qmail-notify/Makefile b/mail/qmail-notify/Makefile
index e674e823c3f1..6c51f091d54a 100644
--- a/mail/qmail-notify/Makefile
+++ b/mail/qmail-notify/Makefile
@@ -15,6 +15,8 @@ CFLAGS+= -DHAVE_SRANDOM
DOCS= NEWS README TODO
EXAMPLES= cron.hourly message.txt
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-configure:
${ECHO_CMD} "${STAGEDIR}${PREFIX}/bin" > ${WRKSRC}/conf-bin
${ECHO_CMD} "${CC} ${CFLAGS}" > ${WRKSRC}/conf-cc
@@ -24,9 +26,7 @@ do-install:
cd ${WRKSRC} && ./installer
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/qmail-qfilter/Makefile b/mail/qmail-qfilter/Makefile
index d8359db6cb80..4f6e48e626d9 100644
--- a/mail/qmail-qfilter/Makefile
+++ b/mail/qmail-qfilter/Makefile
@@ -17,6 +17,8 @@ BGLIBS_LIB= ${LOCALBASE}/lib/bglibs
DOCS= NEWS README TODO
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-configure:
${ECHO_CMD} "${STAGEDIR}${PREFIX}/bin" > ${WRKSRC}/conf-bin
${ECHO_CMD} "${STAGEDIR}${MANPREFIX}/man" > ${WRKSRC}/conf-man
@@ -28,9 +30,7 @@ do-configure:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} samples/* ${STAGEDIR}${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/mail/qmail-remove/Makefile b/mail/qmail-remove/Makefile
index 559e6d067f5a..c4d8798e7c2f 100644
--- a/mail/qmail-remove/Makefile
+++ b/mail/qmail-remove/Makefile
@@ -16,6 +16,8 @@ PORTDOCS= INSTALL LICENSE README
USES= shebangfix
SHEBANG_FILES= populate.pl
+OPTIONS_DEFINE= DOCS
+
do-build:
@(cd ${WRKSRC} ;\
${ECHO_MSG} "Compiling ${PORTNAME}:" ; \
@@ -26,11 +28,9 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/sbin
@${INSTALL_SCRIPT} ${WRKSRC}/populate.pl \
${STAGEDIR}${PREFIX}/bin/populate-qmail-queue.pl
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/mail/renattach/Makefile b/mail/renattach/Makefile
index 99e5f1b55732..80a45497758d 100644
--- a/mail/renattach/Makefile
+++ b/mail/renattach/Makefile
@@ -15,16 +15,16 @@ GNU_CONFIGURE= yes
PORTDOCS= INSTALL
PLIST_FILES= bin/renattach etc/renattach.conf.ex man/man1/renattach.1.gz
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${RM} -f ${WRKSRC}/src/getopt*
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===================="
@${ECHO_MSG} "Check with ${DOCSDIR}/INSTALL"
@${ECHO_MSG} "After that you may need to adjust renattach.conf to your needs"
-.endif
.include <bsd.port.mk>
diff --git a/mail/spambnc/Makefile b/mail/spambnc/Makefile
index d4e07e90afbc..8abfa29406d5 100644
--- a/mail/spambnc/Makefile
+++ b/mail/spambnc/Makefile
@@ -25,7 +25,11 @@ PLIST= ${WRKDIR}/.pkg-plist
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-.if !defined(NOPORTDOCS)
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
MASTER_SITES+= http://www.spambouncer.org/configure/:upg
DISTFILES+= upgrading.shtml:upg
PORTDOCS= documentation.html upgrading.html loglevels.txt
@@ -48,7 +52,7 @@ do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR})
${RM} -rf ${STAGEDIR}${DATADIR}/docs
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/quickstart.shtml \
${STAGEDIR}${DOCSDIR}/documentation.html
diff --git a/mail/squirrelmail-spam-buttons-plugin/Makefile b/mail/squirrelmail-spam-buttons-plugin/Makefile
index 49e7bfa236bb..c158cb270a3a 100644
--- a/mail/squirrelmail-spam-buttons-plugin/Makefile
+++ b/mail/squirrelmail-spam-buttons-plugin/Makefile
@@ -15,16 +15,14 @@ USE_SM_COMPAT= yes
SQUIRREL_PLUGIN_NAME= ${PORTNAME:S/-/_/}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
post-extract:
@${MV} ${WRKSRC}/${_SMSRCDIR}/config_example.php ${WRKSRC}/${_SMSRCDIR}/config.sample.php
@${RM} ${WRKSRC}/${_SMSRCDIR}/README
-.ifdef NOPORTDOCS
- @${RM} -R ${WRKSRC}/${_SMSRCDIR}/docs
-.else
@${MV} ${WRKSRC}/${_SMSRCDIR}/docs ${WRKSRC}/${_SMSRCDIR}/doc
-.endif
.include <bsd.port.post.mk>
diff --git a/mail/squirrelmail-vlogin-plugin/Makefile b/mail/squirrelmail-vlogin-plugin/Makefile
index f926588bd05d..bff2c26fdee8 100644
--- a/mail/squirrelmail-vlogin-plugin/Makefile
+++ b/mail/squirrelmail-vlogin-plugin/Makefile
@@ -14,21 +14,19 @@ USE_SM_COMPAT= yes
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../squirrelmail/bsd.squirrelmail.mk"
# We need to rearrange, install and cleanup documentation pre-install
# because bsd.squirrelmail.mk installs everything under ${WRKSRC}/${PORTNAME}.
pre-install::
-.if !defined(NOPORTDOCS)
cd ${WRKSRC}/${PORTNAME}/docs \
&& ${RM} .htaccess index.php \
&& ${MKDIR} ${STAGEDIR}${DOCSDIR} \
&& ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR} \
&& cd ${WRKSRC}/${PORTNAME} \
&& ${RM} -rf README docs
-.else
- cd ${WRKSRC}/${PORTNAME} && ${RM} -rf README docs
-.endif
.include <bsd.port.post.mk>