aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-11 21:22:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-11 21:22:41 +0000
commit3d0108e92686a31468419ecf077709bf82ea45a5 (patch)
tree6beca350d94ff91b50d2724ab2b5b9feee7a3df9
parent764256342c843bcab880362ace0521988eb819ed (diff)
downloadports-3d0108e92686a31468419ecf077709bf82ea45a5.tar.gz
ports-3d0108e92686a31468419ecf077709bf82ea45a5.zip
Notes
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile6
-rw-r--r--ports-mgmt/tinderbox-devel/distinfo6
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-portbuild10
-rw-r--r--ports-mgmt/tinderbox/Makefile6
-rw-r--r--ports-mgmt/tinderbox/distinfo6
-rw-r--r--ports-mgmt/tinderbox/files/patch-portbuild10
6 files changed, 34 insertions, 10 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 34db3f5f9b02..2fe677f312a8 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tinderbox
#DISTVERSION= ${PORTVERSION}-${PORTREVISION}
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
DIST_SUBDIR= tinderbox
@@ -42,7 +43,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
WANT_PHP_WEB= yes
USE_PHP= session
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- favicon.ico tb242_template_paefchen_v2.tbz
+ favicon.ico tb242_template_paefchen_v3.tbz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
@@ -110,7 +111,7 @@ post-extract:
@${RM} -R ${WRKSRC}/www-exp
.else
@${CP} ${_DISTDIR}/favicon.ico ${WRKSRC}/www-exp
- @${TAR} -C ${WRKSRC}/www-exp/templates -xf ${_DISTDIR}/tb242_template_paefchen_v2.tbz
+ @${TAR} -C ${WRKSRC}/www-exp/templates -xf ${_DISTDIR}/tb242_template_paefchen_v3.tbz
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}/www-exp/templates/paefchen
@${REINPLACE_CMD} 's|/templates/default|/templates/paefchen|' ${WRKSRC}/www-exp/inc_tinderbox.php.dist
@${RM} ${WRKSRC}/www-exp/inc_tinderbox.php.dist.bak
@@ -124,6 +125,7 @@ post-patch:
@${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
@${RM} ${WRKSRC}/buildscript.orig
+ @${RM} ${WRKSRC}/portbuild.orig
.if defined(WITH_WEB_EXP)
@${RM} ${WRKSRC}/www-exp/core/TinderboxDS.php.orig
@${RM} ${WRKSRC}/www-exp/module/moduleBuildPorts.php.orig
diff --git a/ports-mgmt/tinderbox-devel/distinfo b/ports-mgmt/tinderbox-devel/distinfo
index b8c91d68c393..b4a495eea77c 100644
--- a/ports-mgmt/tinderbox-devel/distinfo
+++ b/ports-mgmt/tinderbox-devel/distinfo
@@ -4,6 +4,6 @@ SIZE (tinderbox/tinderbox-2.4.3.tar.gz) = 131585
MD5 (tinderbox/favicon.ico) = 1d2e9e267ca81f0ef5bc7b9c391aaced
SHA256 (tinderbox/favicon.ico) = 842f1e23dcfcee24d4d7578381256256cda994347751fb332b6eb2182eae216e
SIZE (tinderbox/favicon.ico) = 4710
-MD5 (tinderbox/tb242_template_paefchen_v2.tbz) = 80557c9012ad4ca66dcf94e04747dc44
-SHA256 (tinderbox/tb242_template_paefchen_v2.tbz) = f875dc4edf69f357a6cfba54c4a9a9f21d251127d4146280cb761aa44dd7ec41
-SIZE (tinderbox/tb242_template_paefchen_v2.tbz) = 7923
+MD5 (tinderbox/tb242_template_paefchen_v3.tbz) = 9870c8133e6415d0cefa32e2e9c209bf
+SHA256 (tinderbox/tb242_template_paefchen_v3.tbz) = 9b060c4256530bebcb73457a7413f0ca3916fc99bcefc4f673ae7820484deaaf
+SIZE (tinderbox/tb242_template_paefchen_v3.tbz) = 7924
diff --git a/ports-mgmt/tinderbox-devel/files/patch-portbuild b/ports-mgmt/tinderbox-devel/files/patch-portbuild
new file mode 100644
index 000000000000..116a31ee1d92
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-portbuild
@@ -0,0 +1,10 @@
+Index: portbuild
+@@ -251,7 +251,7 @@
+ fi
+
+ if [ x"${OPTIONS_ENABLED}" = x"1" ]; then
+- export PORT_DBDIR=${chroot}/var/db/ports
++ export PORT_DBDIR=/var/db/ports
+ fi
+
+ echo "building $pkgname in $chroot"
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 34db3f5f9b02..2fe677f312a8 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tinderbox
#DISTVERSION= ${PORTVERSION}-${PORTREVISION}
PORTVERSION= 2.4.3
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
DIST_SUBDIR= tinderbox
@@ -42,7 +43,7 @@ RUN_DEPENDS+= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
WANT_PHP_WEB= yes
USE_PHP= session
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- favicon.ico tb242_template_paefchen_v2.tbz
+ favicon.ico tb242_template_paefchen_v3.tbz
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
.endif
@@ -110,7 +111,7 @@ post-extract:
@${RM} -R ${WRKSRC}/www-exp
.else
@${CP} ${_DISTDIR}/favicon.ico ${WRKSRC}/www-exp
- @${TAR} -C ${WRKSRC}/www-exp/templates -xf ${_DISTDIR}/tb242_template_paefchen_v2.tbz
+ @${TAR} -C ${WRKSRC}/www-exp/templates -xf ${_DISTDIR}/tb242_template_paefchen_v3.tbz
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}/www-exp/templates/paefchen
@${REINPLACE_CMD} 's|/templates/default|/templates/paefchen|' ${WRKSRC}/www-exp/inc_tinderbox.php.dist
@${RM} ${WRKSRC}/www-exp/inc_tinderbox.php.dist.bak
@@ -124,6 +125,7 @@ post-patch:
@${RM} ${WRKSRC}/lib/setup-mysql.sh.bak
.endif
@${RM} ${WRKSRC}/buildscript.orig
+ @${RM} ${WRKSRC}/portbuild.orig
.if defined(WITH_WEB_EXP)
@${RM} ${WRKSRC}/www-exp/core/TinderboxDS.php.orig
@${RM} ${WRKSRC}/www-exp/module/moduleBuildPorts.php.orig
diff --git a/ports-mgmt/tinderbox/distinfo b/ports-mgmt/tinderbox/distinfo
index b8c91d68c393..b4a495eea77c 100644
--- a/ports-mgmt/tinderbox/distinfo
+++ b/ports-mgmt/tinderbox/distinfo
@@ -4,6 +4,6 @@ SIZE (tinderbox/tinderbox-2.4.3.tar.gz) = 131585
MD5 (tinderbox/favicon.ico) = 1d2e9e267ca81f0ef5bc7b9c391aaced
SHA256 (tinderbox/favicon.ico) = 842f1e23dcfcee24d4d7578381256256cda994347751fb332b6eb2182eae216e
SIZE (tinderbox/favicon.ico) = 4710
-MD5 (tinderbox/tb242_template_paefchen_v2.tbz) = 80557c9012ad4ca66dcf94e04747dc44
-SHA256 (tinderbox/tb242_template_paefchen_v2.tbz) = f875dc4edf69f357a6cfba54c4a9a9f21d251127d4146280cb761aa44dd7ec41
-SIZE (tinderbox/tb242_template_paefchen_v2.tbz) = 7923
+MD5 (tinderbox/tb242_template_paefchen_v3.tbz) = 9870c8133e6415d0cefa32e2e9c209bf
+SHA256 (tinderbox/tb242_template_paefchen_v3.tbz) = 9b060c4256530bebcb73457a7413f0ca3916fc99bcefc4f673ae7820484deaaf
+SIZE (tinderbox/tb242_template_paefchen_v3.tbz) = 7924
diff --git a/ports-mgmt/tinderbox/files/patch-portbuild b/ports-mgmt/tinderbox/files/patch-portbuild
new file mode 100644
index 000000000000..116a31ee1d92
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-portbuild
@@ -0,0 +1,10 @@
+Index: portbuild
+@@ -251,7 +251,7 @@
+ fi
+
+ if [ x"${OPTIONS_ENABLED}" = x"1" ]; then
+- export PORT_DBDIR=${chroot}/var/db/ports
++ export PORT_DBDIR=/var/db/ports
+ fi
+
+ echo "building $pkgname in $chroot"