aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-04 13:49:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-04 13:49:06 +0000
commit4813d17d9f0ba0b66d140cc382a3b12f474a45cb (patch)
tree7dafa5211b6b5a88ef255009137b2180a2a80f06
parent35c921ea907b0796159e3d30fa58001fa80b57b4 (diff)
downloadports-4813d17d9f0ba0b66d140cc382a3b12f474a45cb.tar.gz
ports-4813d17d9f0ba0b66d140cc382a3b12f474a45cb.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-fastnumbers/Makefile21
-rw-r--r--devel/py-fastnumbers/distinfo3
-rw-r--r--devel/py-fastnumbers/pkg-descr9
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index da406e382fd8..8e0ab5e34bd9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4386,6 +4386,7 @@
SUBDIR += py-fasteners
SUBDIR += py-fastentrypoints
SUBDIR += py-fastimport
+ SUBDIR += py-fastnumbers
SUBDIR += py-filemagic
SUBDIR += py-fileutils
SUBDIR += py-five.customerize
diff --git a/devel/py-fastnumbers/Makefile b/devel/py-fastnumbers/Makefile
new file mode 100644
index 000000000000..12ffa61b6b59
--- /dev/null
+++ b/devel/py-fastnumbers/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= fastnumbers
+PORTVERSION= 2.0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Super-fast and clean conversions to numbers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/fastnumbers.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-fastnumbers/distinfo b/devel/py-fastnumbers/distinfo
new file mode 100644
index 000000000000..98703bcc70e4
--- /dev/null
+++ b/devel/py-fastnumbers/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508392676
+SHA256 (fastnumbers-2.0.1.tar.gz) = ea67263d6360b9294c4bc5924089771d3f003bf6b6343383d700ea9659b506fb
+SIZE (fastnumbers-2.0.1.tar.gz) = 299489
diff --git a/devel/py-fastnumbers/pkg-descr b/devel/py-fastnumbers/pkg-descr
new file mode 100644
index 000000000000..360801dc93bf
--- /dev/null
+++ b/devel/py-fastnumbers/pkg-descr
@@ -0,0 +1,9 @@
+py-fastnumbers provides:
+* drop-in replacements for the Python built-in int and float that on
+ average are up to 2x faster
+* a set of convenience functions that wrap the above int and float replacements
+ and provides easy, concise, powerful, fast and flexible error handling
+* a set of functions that can be used to rapidly identify if an input could be
+ converted to int or float
+
+WWW: https://github.com/SethMMorton/fastnumbers