aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-18 07:52:53 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-06-18 07:52:53 +0000
commit4f948ee5a004a058e0c2b49b678f4ad06361cce7 (patch)
tree36273e7911e0dc13645c74b31a4dba36f28a7e46
parentb77a0da8418025ee67ff0add0edd964b82d36acb (diff)
downloadports-4f948ee5a004a058e0c2b49b678f4ad06361cce7.tar.gz
ports-4f948ee5a004a058e0c2b49b678f4ad06361cce7.zip
Notes
-rw-r--r--comms/ruby-serialport/Makefile19
-rw-r--r--comms/ruby-serialport/distinfo6
-rw-r--r--comms/ruby-serialport/files/patch-serialport.c27
-rw-r--r--comms/ruby-serialport/pkg-plist6
4 files changed, 14 insertions, 44 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
index d5f1e3005a72..fe81fd305882 100644
--- a/comms/ruby-serialport/Makefile
+++ b/comms/ruby-serialport/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= serialport
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= comms ruby
-MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITES= RF
MASTER_SITE_SUBDIR= ruby-${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
@@ -20,23 +19,21 @@ COMMENT= A Ruby library to communicate via the RS232 port
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_EXTCONF= ext/extconf.rb
INSTALL_TARGET= site-install
-DOCS= CHANGELOG README
-EXAMPLES= test/*.rb
-
-post-patch:
-.for f in ${EXAMPLES}
- ${RUBY} -i -pe 'sub!(%r"\.\./serialport", "serialport")' ${WRKSRC}/${f}
-.endfor
+DOCS= ChangeLog README
+EXAMPLES= examples/*.rb
post-install:
-.if !defined(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
.endfor
+.endif
+.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
diff --git a/comms/ruby-serialport/distinfo b/comms/ruby-serialport/distinfo
index 1f1b5bf3df20..e180878feec3 100644
--- a/comms/ruby-serialport/distinfo
+++ b/comms/ruby-serialport/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/ruby-serialport-0.6.tar.gz) = c38aec045ebc7560bbaee69038d94b69
-SHA256 (ruby/ruby-serialport-0.6.tar.gz) = 9e7d08ffccf0809d6a6c82ccdeb720238cec61691740b73d22767e0686d9f6b3
-SIZE (ruby/ruby-serialport-0.6.tar.gz) = 10066
+MD5 (ruby/ruby-serialport-0.7.0.tar.gz) = d754a9a192af241e1ff59db21d409e02
+SHA256 (ruby/ruby-serialport-0.7.0.tar.gz) = f56b3505b357f0f72ed13ff65f264905ebb746cd2a0cb6e2052c7722dc6d6015
+SIZE (ruby/ruby-serialport-0.7.0.tar.gz) = 17722
diff --git a/comms/ruby-serialport/files/patch-serialport.c b/comms/ruby-serialport/files/patch-serialport.c
deleted file mode 100644
index 1830a5874f34..000000000000
--- a/comms/ruby-serialport/files/patch-serialport.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- serialport.c.orig Sun Nov 27 10:28:52 2005
-+++ serialport.c Sun Nov 27 10:35:17 2005
-@@ -20,6 +20,10 @@
- #include <ruby.h> /* ruby inclusion */
- #include <rubyio.h> /* ruby io inclusion */
-
-+#if defined (freebsd)
-+#include <sys/param.h>
-+#endif
-+
- struct modem_params {
- int data_rate;
- int data_bits;
-@@ -569,9 +573,12 @@
- #if defined(linux) || defined(cygwin)
- "/dev/ttyS0", "/dev/ttyS1", "/dev/ttyS2", "/dev/ttyS3",
- "/dev/ttyS4", "/dev/ttyS5", "/dev/ttyS6", "/dev/ttyS7"
--#elif defined(freebsd) || defined(netbsd) || defined(openbsd)
-+#elif (defined(freebsd) && __FreeBSD_version < 600006) || defined(netbsd) || defined(openbsd)
- "/dev/cuaa0", "/dev/cuaa1", "/dev/cuaa2", "/dev/cuaa3",
- "/dev/cuaa4", "/dev/cuaa5", "/dev/cuaa6", "/dev/cuaa7"
-+#elif (defined(freebsd) && __FreeBSD_version >= 600006)
-+ "/dev/cuad0", "/dev/cuad1", "/dev/cuad2", "/dev/cuad3",
-+ "/dev/cuad4", "/dev/cuad5", "/dev/cuad6", "/dev/cuad7"
- #elif defined(solaris)
- "/dev/ttya", "/dev/ttyb", "/dev/ttyc", "/dev/ttyd",
- "/dev/ttye", "/dev/ttyf", "/dev/ttyg", "/dev/ttyh"
diff --git a/comms/ruby-serialport/pkg-plist b/comms/ruby-serialport/pkg-plist
index 954fce6ff4d1..bbc30ce2e742 100644
--- a/comms/ruby-serialport/pkg-plist
+++ b/comms/ruby-serialport/pkg-plist
@@ -1,6 +1,6 @@
%%RUBY_SITEARCHLIBDIR%%/serialport.so
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/miniterm.rb
-%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/miniterm.rb
+%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%