aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-15 12:55:27 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-15 12:55:27 +0000
commit523a4107aeacf5d271f0c5ac2b744c8b57f2bf39 (patch)
tree062f5c6747f5dc83fb287a3b05c19f13f7a2a975
parent7257f62b899b0ad28f6da0b7a47c245f0b2c0907 (diff)
downloadports-523a4107aeacf5d271f0c5ac2b744c8b57f2bf39.tar.gz
ports-523a4107aeacf5d271f0c5ac2b744c8b57f2bf39.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-Identity/Makefile25
-rw-r--r--devel/p5-Config-Identity/distinfo2
-rw-r--r--devel/p5-Config-Identity/pkg-descr7
-rw-r--r--devel/p5-Config-Identity/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 477f57fe5bfe..7b9d59f69ce0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1636,6 +1636,7 @@
SUBDIR += p5-Config-Grammar
SUBDIR += p5-Config-INI
SUBDIR += p5-Config-INI-Simple
+ SUBDIR += p5-Config-Identity
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-IniHash
SUBDIR += p5-Config-IniRegEx
diff --git a/devel/p5-Config-Identity/Makefile b/devel/p5-Config-Identity/Makefile
new file mode 100644
index 000000000000..7def828f0779
--- /dev/null
+++ b/devel/p5-Config-Identity/Makefile
@@ -0,0 +1,25 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Config-Identity
+PORTVERSION= 0.0018
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Load (and optionally decrypt via GnuPG) user/pass identity information
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-File-HomeDir>=0:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-Identity/distinfo b/devel/p5-Config-Identity/distinfo
new file mode 100644
index 000000000000..8581a953cff0
--- /dev/null
+++ b/devel/p5-Config-Identity/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Config-Identity-0.0018.tar.gz) = ddf4496c61544981662f388891f6ad2601d4fb4675020c165e85934858381f11
+SIZE (Config-Identity-0.0018.tar.gz) = 12329
diff --git a/devel/p5-Config-Identity/pkg-descr b/devel/p5-Config-Identity/pkg-descr
new file mode 100644
index 000000000000..bb7e83019a3e
--- /dev/null
+++ b/devel/p5-Config-Identity/pkg-descr
@@ -0,0 +1,7 @@
+Config::Identity is a tool for loadiing (and optionally decrypting via GnuPG)
+user/pass identity information
+
+For GitHub API access, an identity is a "login"/"token" pair.
+For PAUSE access, an identity is a "user"/"password" pair.
+
+WWW: http://search.cpan.org/dist/Config-Identity/
diff --git a/devel/p5-Config-Identity/pkg-plist b/devel/p5-Config-Identity/pkg-plist
new file mode 100644
index 000000000000..8bdaf5813ae0
--- /dev/null
+++ b/devel/p5-Config-Identity/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Config/Identity.pm
+%%SITE_PERL%%/Config/Identity/GitHub.pm
+%%SITE_PERL%%/Config/Identity/PAUSE.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Identity/.packlist
+%%PERL5_MAN3%%/Config::Identity.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config/Identity
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Config
+@dirrm %%SITE_PERL%%/Config/Identity
+@dirrmtry %%SITE_PERL%%/Config