aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-07 04:11:05 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-07 04:11:05 +0000
commit5c711fca55bc69f507767cf2e4d3c82b12efa542 (patch)
treeafd2100c3b6d9c58e6f155c898433031d0a474bb
parent2431878e6b45e4ccbbe5585793ac5a3167657b09 (diff)
downloadports-5c711fca55bc69f507767cf2e4d3c82b12efa542.tar.gz
ports-5c711fca55bc69f507767cf2e4d3c82b12efa542.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-PubSubHubbub-Publisher/Makefile23
-rw-r--r--net/p5-Net-PubSubHubbub-Publisher/distinfo2
-rw-r--r--net/p5-Net-PubSubHubbub-Publisher/pkg-descr4
-rw-r--r--net/p5-Net-PubSubHubbub-Publisher/pkg-plist9
5 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4241782a0cc4..dca18830c0b5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -617,6 +617,7 @@
SUBDIR += p5-Net-Ping
SUBDIR += p5-Net-Ping-External
SUBDIR += p5-Net-Proxy
+ SUBDIR += p5-Net-PubSubHubbub-Publisher
SUBDIR += p5-Net-RTP
SUBDIR += p5-Net-RabbitMQ
SUBDIR += p5-Net-Radius
diff --git a/net/p5-Net-PubSubHubbub-Publisher/Makefile b/net/p5-Net-PubSubHubbub-Publisher/Makefile
new file mode 100644
index 000000000000..4b118075a1d9
--- /dev/null
+++ b/net/p5-Net-PubSubHubbub-Publisher/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Net-PubSubHubbub-Publisher
+# Date created: 2010-12-05
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-PubSubHubbub-Publisher
+PORTVERSION= 0.91
+CATEGORIES= net www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Client library to ping a PubSubHubbub hub
+
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::PubSubHubbub::Publisher.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-PubSubHubbub-Publisher/distinfo b/net/p5-Net-PubSubHubbub-Publisher/distinfo
new file mode 100644
index 000000000000..4c6a66b5ed7d
--- /dev/null
+++ b/net/p5-Net-PubSubHubbub-Publisher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-PubSubHubbub-Publisher-0.91.tar.gz) = 02b529815721bbf1c4e31b1b0de46dd74ca35528cd9c6e9fdf56da3048e5fc4e
+SIZE (Net-PubSubHubbub-Publisher-0.91.tar.gz) = 2553
diff --git a/net/p5-Net-PubSubHubbub-Publisher/pkg-descr b/net/p5-Net-PubSubHubbub-Publisher/pkg-descr
new file mode 100644
index 000000000000..a4a70f005f2c
--- /dev/null
+++ b/net/p5-Net-PubSubHubbub-Publisher/pkg-descr
@@ -0,0 +1,4 @@
+Net::PubSubHubbub::Publisher is a client library to ping a
+PubSubHubbub hub.
+
+WWW: http://search.cpan.org/dist/Net-PubSubHubbub-Publisher/
diff --git a/net/p5-Net-PubSubHubbub-Publisher/pkg-plist b/net/p5-Net-PubSubHubbub-Publisher/pkg-plist
new file mode 100644
index 000000000000..661ff51b6231
--- /dev/null
+++ b/net/p5-Net-PubSubHubbub-Publisher/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/PubSubHubbub/Publisher/.packlist
+%%SITE_PERL%%/Net/PubSubHubbub/Publisher.pm
+bin/pubsubhubbub-publish
+@dirrmtry %%SITE_PERL%%/Net/PubSubHubbub
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/PubSubHubbub/Publisher
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/PubSubHubbub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net