aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-11-28 16:08:33 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-11-28 16:08:33 +0000
commit63d1c684362ddf9583c793e1b1ad86f5d1b81fde (patch)
tree4758e5abb775d4e05a67a170848b8db8aaf58f06
parentf0a0071a6ec4e2f3ebf3de86c912c1f05a52daf3 (diff)
downloadports-63d1c684362ddf9583c793e1b1ad86f5d1b81fde.tar.gz
ports-63d1c684362ddf9583c793e1b1ad86f5d1b81fde.zip
Notes
-rw-r--r--devel/py-twisted/Makefile1
-rw-r--r--devel/py-twistedCore/Makefile6
-rw-r--r--devel/py-twistedCore/pkg-plist7
-rw-r--r--devel/py-twistedRunner/Makefile1
-rw-r--r--dns/py-twistedNames/Makefile1
-rw-r--r--mail/py-twistedMail/Makefile1
-rw-r--r--net-im/py-twistedWords/Makefile1
-rw-r--r--net/py-twistedPair/Makefile1
-rw-r--r--news/py-twistedNews/Makefile1
-rw-r--r--security/py-twistedConch/Makefile1
-rw-r--r--textproc/py-twistedLore/Makefile1
-rw-r--r--www/py-twistedWeb/Makefile1
12 files changed, 8 insertions, 15 deletions
diff --git a/devel/py-twisted/Makefile b/devel/py-twisted/Makefile
index 30185bd9ef11..6f30ae0ec031 100644
--- a/devel/py-twisted/Makefile
+++ b/devel/py-twisted/Makefile
@@ -16,7 +16,6 @@ LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
NO_BUILD= yes
-NO_STAGE= yes
USE_PYTHON= -2.7
PYDISTUTILS_NOEGGINFO= yes
diff --git a/devel/py-twistedCore/Makefile b/devel/py-twistedCore/Makefile
index e408250c6faf..cbb22fd01fc0 100644
--- a/devel/py-twistedCore/Makefile
+++ b/devel/py-twistedCore/Makefile
@@ -22,7 +22,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# Twisted, but the user should feel free to install x11-toolits/py-gnome
# separately if desired.
-NO_STAGE= yes
USE_BZIP2= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
@@ -32,9 +31,6 @@ REINPLACE_ARGS= -i ''
MAN1= manhole.1 pyhtmlizer.1 tap2deb.1 tap2rpm.1 tapconvert.1 trial.1 twistd.1
post-install:
-# permission safeness
- @${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/twisted/
- @${CHMOD} -R a+X ${PYTHONPREFIX_SITELIBDIR}/twisted/
- cd ${WRKSRC}/doc/man/ && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1/
+ cd ${WRKSRC}/doc/man/ && ${INSTALL_MAN} ${MAN1} ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/devel/py-twistedCore/pkg-plist b/devel/py-twistedCore/pkg-plist
index 667d0c1f84c0..ef362e81022e 100644
--- a/devel/py-twistedCore/pkg-plist
+++ b/devel/py-twistedCore/pkg-plist
@@ -5,6 +5,13 @@ bin/tap2rpm
bin/tapconvert
bin/trial
bin/twistd
+man/man1/manhole.1.gz
+man/man1/pyhtmlizer.1.gz
+man/man1/tap2deb.1.gz
+man/man1/tap2rpm.1.gz
+man/man1/tapconvert.1.gz
+man/man1/trial.1.gz
+man/man1/twistd.1.gz
%%PYTHON_SITELIBDIR%%/twisted/__init__.py
%%PYTHON_SITELIBDIR%%/twisted/__init__.pyc
%%PYTHON_SITELIBDIR%%/twisted/__init__.pyo
diff --git a/devel/py-twistedRunner/Makefile b/devel/py-twistedRunner/Makefile
index 9143c3de3f10..bf01f2c4a909 100644
--- a/devel/py-twistedRunner/Makefile
+++ b/devel/py-twistedRunner/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/dns/py-twistedNames/Makefile b/dns/py-twistedNames/Makefile
index 848f7a8f2e78..1b7dbe2d5deb 100644
--- a/dns/py-twistedNames/Makefile
+++ b/dns/py-twistedNames/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/mail/py-twistedMail/Makefile b/mail/py-twistedMail/Makefile
index 8183d974baf4..cf01a388bfdb 100644
--- a/mail/py-twistedMail/Makefile
+++ b/mail/py-twistedMail/Makefile
@@ -23,5 +23,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net-im/py-twistedWords/Makefile b/net-im/py-twistedWords/Makefile
index 4bf83d4a2c48..8a4718fd3279 100644
--- a/net-im/py-twistedWords/Makefile
+++ b/net-im/py-twistedWords/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/net/py-twistedPair/Makefile b/net/py-twistedPair/Makefile
index 4b45b8e1d1ca..193f37585ace 100644
--- a/net/py-twistedPair/Makefile
+++ b/net/py-twistedPair/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/news/py-twistedNews/Makefile b/news/py-twistedNews/Makefile
index bf61331c7210..9bee869cd3e4 100644
--- a/news/py-twistedNews/Makefile
+++ b/news/py-twistedNews/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/py-twistedConch/Makefile b/security/py-twistedConch/Makefile
index 649b45728801..81ac8ee2e4cf 100644
--- a/security/py-twistedConch/Makefile
+++ b/security/py-twistedConch/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/de
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.0.9a:${PORTSDIR}/devel/py-asn1 \
${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
-NO_STAGE= yes
USE_BZIP2= yes
USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
diff --git a/textproc/py-twistedLore/Makefile b/textproc/py-twistedLore/Makefile
index 63dd3b8b1aa4..0cd338e589a8 100644
--- a/textproc/py-twistedLore/Makefile
+++ b/textproc/py-twistedLore/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/py-twistedWeb/Makefile b/www/py-twistedWeb/Makefile
index 0754f165852c..482611d8ff96 100644
--- a/www/py-twistedWeb/Makefile
+++ b/www/py-twistedWeb/Makefile
@@ -22,5 +22,4 @@ USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
-NO_STAGE= yes
.include <bsd.port.mk>