aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-02 10:21:47 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-02 10:21:47 +0000
commit65df9b5dde54c1e3033c6376baf9bc8887385c8e (patch)
tree1b2b9aa5c740b4caf45ab66a07c88f0755f1c378
parent05470a947eb89df027afa41219ede41e24063752 (diff)
Notes
-rw-r--r--x11/sxhkd/Makefile4
-rw-r--r--x11/sxhkd/distinfo5
-rw-r--r--x11/sxhkd/files/patch-Makefile16
3 files changed, 13 insertions, 12 deletions
diff --git a/x11/sxhkd/Makefile b/x11/sxhkd/Makefile
index b7f283b979c4..23ea8d550ff6 100644
--- a/x11/sxhkd/Makefile
+++ b/x11/sxhkd/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= sxhkd
-PORTVERSION= 0.5.6
+PORTVERSION= 0.5.7
CATEGORIES= x11
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gor@clogic.com.ua
COMMENT= Simple X hotkey daemon
LICENSE= BSD2CLAUSE
diff --git a/x11/sxhkd/distinfo b/x11/sxhkd/distinfo
index 55f474dee6ba..97f0a0562dad 100644
--- a/x11/sxhkd/distinfo
+++ b/x11/sxhkd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (baskerville-sxhkd-0.5.6_GH0.tar.gz) = 72366eea4d7ed17a3a9eab5257e59edf9a7cd63b926af1dca2d895dfefaff995
-SIZE (baskerville-sxhkd-0.5.6_GH0.tar.gz) = 35301
+TIMESTAMP = 1477912763
+SHA256 (baskerville-sxhkd-0.5.7_GH0.tar.gz) = 21b8bfea2a83f019062dfea53051e2bc61896595fc788c6c7b5e3fd9354b279f
+SIZE (baskerville-sxhkd-0.5.7_GH0.tar.gz) = 34472
diff --git a/x11/sxhkd/files/patch-Makefile b/x11/sxhkd/files/patch-Makefile
index b2c4125f4480..0938347ff341 100644
--- a/x11/sxhkd/files/patch-Makefile
+++ b/x11/sxhkd/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig 2016-03-15 16:20:41 UTC
+--- Makefile.orig 2016-10-30 12:28:09 UTC
+++ Makefile
-@@ -1,14 +1,14 @@
- NAME = sxhkd
- VERSION := $(shell git describe 2> /dev/null || cat VERSION)
+@@ -2,14 +2,14 @@ NAME = sxhkd
+ VERCMD ?= git describe 2> /dev/null
+ VERSION := $(shell $(VERCMD) || cat VERSION)
-CPPFLAGS += -D_POSIX_C_SOURCE=200112L -DVERSION=\"$(VERSION)\"
+CPPFLAGS += $(shell pkg-config --cflags xcb-keysyms) -DVERSION=\"$(VERSION)\"
@@ -16,11 +16,11 @@
-DOCPREFIX ?= $(PREFIX)/share/doc/$(NAME)
+BINPREFIX = $(PREFIX)/bin
+MANPREFIX = $(PREFIX)/man
-+EXPREFIX = $(PREFIX)/share/examples/$(NAME)
++EXPREFIX = $(PREFIX)/share/examples/$(NAME)
- SRC = $(wildcard *.c)
- OBJ = $(SRC:.c=.o)
-@@ -27,11 +27,15 @@ $(NAME): $(OBJ)
+ SRC := $(wildcard *.c)
+ OBJ := $(SRC:.c=.o)
+@@ -28,11 +28,15 @@ $(NAME): $(OBJ)
install:
mkdir -p "$(DESTDIR)$(BINPREFIX)"