aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-22 07:46:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-22 07:46:52 +0000
commit6d1f7cdf90058537f1263b5e701adac5bab0a733 (patch)
tree25556d9052e111d55756a7fc0c97c8196b9302fd
parent47c1ee730fcb7ff800862506cec80aaf0a2dd7b7 (diff)
downloadports-6d1f7cdf90058537f1263b5e701adac5bab0a733.tar.gz
ports-6d1f7cdf90058537f1263b5e701adac5bab0a733.zip
Notes
-rw-r--r--devel/libftdi/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index 4e906b706489..a6fdc859826a 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -21,14 +21,13 @@ USES= pathfix pkgconfig
PORTDOCS= COPYING.LIB ChangeLog README
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MBOOST}
PLIST_SUB+= BOOST=""
CONFIGURE_ARGS+= --with-boost
CXXFLAGS+= "-I${LOCALBASE}/include"
-LIB_DEPENDS+= boost_system:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= libboost_system.so:${PORTSDIR}/devel/boost-libs
.else
PLIST_SUB+= BOOST="@comment "
CONFIGURE_ARGS+= --without-boost
@@ -45,6 +44,9 @@ PLIST_SUB+= PYTHON="@comment "
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= DOCS
+
post-patch:
@${REINPLACE_CMD} -E -e \
's:\$$\(libdir\)/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
@@ -54,9 +56,7 @@ pre-configure:
@cd ${WRKSRC} && ${AUTORECONF} --force --install
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>