aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-07 07:44:26 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-07 07:44:26 +0000
commit6f1287003076a66b3874202a0ccee07835658b3f (patch)
tree631b2e0ea326a30b434e711980814ba3b010db90
parent312fd92cc301fbf0529d852d31550be7b6e0c679 (diff)
downloadports-6f1287003076a66b3874202a0ccee07835658b3f.tar.gz
ports-6f1287003076a66b3874202a0ccee07835658b3f.zip
Notes
-rw-r--r--biology/consed/Makefile2
-rw-r--r--biology/p5-Bio-ASN1-EntrezGene/Makefile3
-rw-r--r--biology/p5-bioperl-run/Makefile3
-rw-r--r--biology/velvet/Makefile3
-rw-r--r--devel/p5-Config-YAML/Makefile3
-rw-r--r--devel/p5-MooseX-CompileTime-Traits/Makefile3
-rw-r--r--devel/p5-Sys-Cpu/Makefile3
-rw-r--r--sysutils/backupme/Makefile2
-rw-r--r--sysutils/p5-BSD-Sysctl/Makefile3
-rw-r--r--sysutils/p5-Filesys-DiskUsage/Makefile3
-rw-r--r--sysutils/p5-Lchown/Makefile3
-rw-r--r--sysutils/p5-MogileFS-Utils/Makefile3
-rw-r--r--sysutils/p5-Proc-PidUtil/Makefile3
-rw-r--r--sysutils/p5-Schedule-At/Makefile3
-rw-r--r--sysutils/pwgen/Makefile3
-rw-r--r--sysutils/topless/Makefile3
-rw-r--r--sysutils/usermin/Makefile2
-rw-r--r--sysutils/worldtools/Makefile3
-rw-r--r--x11-themes/fvwm-themes/Makefile2
19 files changed, 34 insertions, 19 deletions
diff --git a/biology/consed/Makefile b/biology/consed/Makefile
index c5f067276030..9dc71cb3c238 100644
--- a/biology/consed/Makefile
+++ b/biology/consed/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= phred:${PORTSDIR}/biology/phred \
phrap:${PORTSDIR}/biology/phrap \
phd2fasta:${PORTSDIR}/biology/phd2fasta
-USE_PERL5= yes
+USES= perl5
USE_LINUX= yes
USE_LINUX_APPS= xorglibs
ONLY_FOR_ARCHS= i386 amd64
diff --git a/biology/p5-Bio-ASN1-EntrezGene/Makefile b/biology/p5-Bio-ASN1-EntrezGene/Makefile
index bd91a167633c..11a94ac25c46 100644
--- a/biology/p5-Bio-ASN1-EntrezGene/Makefile
+++ b/biology/p5-Bio-ASN1-EntrezGene/Makefile
@@ -17,7 +17,8 @@ COMMENT= Regular expression-based Perl Parser for NCBI Entrez Gene
WRKSRC= ${WRKDIR}/Bio-ASN1-EntrezGene-1.09
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bio::ASN1::EntrezGene.3 \
Bio::ASN1::EntrezGene::Indexer.3 \
diff --git a/biology/p5-bioperl-run/Makefile b/biology/p5-bioperl-run/Makefile
index b2becf786dbf..80a257afce72 100644
--- a/biology/p5-bioperl-run/Makefile
+++ b/biology/p5-bioperl-run/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= p5-bioperl-run-1.[13579]*
-PERL_MODBUILD= YES
+USES= perl5
+USE_PERL5= modbuild
WRKSRC= ${WRKDIR}/BioPerl-run-1.6.0
MAN1= bp_bioperl_application_installer.pl.1 \
diff --git a/biology/velvet/Makefile b/biology/velvet/Makefile
index 6808c05340c1..de5eae20a9c6 100644
--- a/biology/velvet/Makefile
+++ b/biology/velvet/Makefile
@@ -22,7 +22,8 @@ MAXKMERLENGTH?= 31
VELVET_CATEGORIES?= 2
MAKE_ENV+= MAXKMERLENGTH=${MAXKMERLENGTH} CATEGORIES=${VELVET_CATEGORIES}
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
BINARIES= velvetg velveth
SCRIPTS= shuffleSequences_fasta.pl shuffleSequences_fastq.pl \
diff --git a/devel/p5-Config-YAML/Makefile b/devel/p5-Config-YAML/Makefile
index 3d3c55a939a6..effe7ea0c35a 100644
--- a/devel/p5-Config-YAML/Makefile
+++ b/devel/p5-Config-YAML/Makefile
@@ -17,7 +17,8 @@ COMMENT= Simple configuration automation
BUILD_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Config::YAML.3
diff --git a/devel/p5-MooseX-CompileTime-Traits/Makefile b/devel/p5-MooseX-CompileTime-Traits/Makefile
index f15cf2547c9d..7435ec9b1a65 100644
--- a/devel/p5-MooseX-CompileTime-Traits/Makefile
+++ b/devel/p5-MooseX-CompileTime-Traits/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-MooseX-Declare>0:${PORTSDIR}/devel/p5-MooseX-Declare
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::CompileTime::Traits.3
diff --git a/devel/p5-Sys-Cpu/Makefile b/devel/p5-Sys-Cpu/Makefile
index 0ad6047d90b2..105b3b230c1e 100644
--- a/devel/p5-Sys-Cpu/Makefile
+++ b/devel/p5-Sys-Cpu/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= terry@sucked-in.com
COMMENT= Sys::CPU - Perl extension for getting CPU information
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sys::CPU.3
diff --git a/sysutils/backupme/Makefile b/sysutils/backupme/Makefile
index 17c09ff4f259..c199b20f4395 100644
--- a/sysutils/backupme/Makefile
+++ b/sysutils/backupme/Makefile
@@ -24,7 +24,7 @@ RUN_DEPENDS= p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
p5-Net-Jabber>=0:${PORTSDIR}/net-im/p5-Net-Jabber \
p5-Net-SSH>=0:${PORTSDIR}/net/p5-Net-SSH
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
NO_INSTALL_MANPAGES= yes
diff --git a/sysutils/p5-BSD-Sysctl/Makefile b/sysutils/p5-BSD-Sysctl/Makefile
index e6166a3a4f87..03ae2423f4ff 100644
--- a/sysutils/p5-BSD-Sysctl/Makefile
+++ b/sysutils/p5-BSD-Sysctl/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= david@landgren.net
COMMENT= Fetch sysctl values from BSD-like systems
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= BSD::Sysctl.3
diff --git a/sysutils/p5-Filesys-DiskUsage/Makefile b/sysutils/p5-Filesys-DiskUsage/Makefile
index e3b639f77196..08fc99d9ff4d 100644
--- a/sysutils/p5-Filesys-DiskUsage/Makefile
+++ b/sysutils/p5-Filesys-DiskUsage/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= culot@FreeBSD.org
COMMENT= Perl equivalent of du(1)
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Filesys::DiskUsage.3
diff --git a/sysutils/p5-Lchown/Makefile b/sysutils/p5-Lchown/Makefile
index 26ec56b3aa7c..f8bffa2fe2f7 100644
--- a/sysutils/p5-Lchown/Makefile
+++ b/sysutils/p5-Lchown/Makefile
@@ -16,7 +16,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jeffrey@goldmark.org
COMMENT= A perl5 module providing access to lchown(2)
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Lchown.3
diff --git a/sysutils/p5-MogileFS-Utils/Makefile b/sysutils/p5-MogileFS-Utils/Makefile
index f1a360185060..4d695228cf08 100644
--- a/sysutils/p5-MogileFS-Utils/Makefile
+++ b/sysutils/p5-MogileFS-Utils/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-MogileFS-Client>=1.16:${PORTSDIR}/sysutils/p5-MogileFS-Client
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mogadm.1 \
mogdelete.1 \
diff --git a/sysutils/p5-Proc-PidUtil/Makefile b/sysutils/p5-Proc-PidUtil/Makefile
index c12eaa9d705c..80af78f35ac0 100644
--- a/sysutils/p5-Proc-PidUtil/Makefile
+++ b/sysutils/p5-Proc-PidUtil/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= PID file management utilities
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Proc::PidUtil.3
diff --git a/sysutils/p5-Schedule-At/Makefile b/sysutils/p5-Schedule-At/Makefile
index 44125ab65f84..5f91f37804a7 100644
--- a/sysutils/p5-Schedule-At/Makefile
+++ b/sysutils/p5-Schedule-At/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= OS independent interface to the Unix 'at' command
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Schedule::At.3
diff --git a/sysutils/pwgen/Makefile b/sysutils/pwgen/Makefile
index a3db1d3e1d3e..aaadfeb42ebe 100644
--- a/sysutils/pwgen/Makefile
+++ b/sysutils/pwgen/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= andrey@hm.perm.ru
COMMENT= A small, powerful, GPL'ed password generator
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
MAN1= pwgen.1
PLIST_FILES= bin/pwgen
diff --git a/sysutils/topless/Makefile b/sysutils/topless/Makefile
index 812e9d393287..fa2f8858b0eb 100644
--- a/sysutils/topless/Makefile
+++ b/sysutils/topless/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://people.freebsd.org/~daichi/src/
MAINTAINER= koma2@lovepeers.org
COMMENT= Display command output on the whole screen like "top"
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
MAN1= topless.1
PLIST_FILES= bin/topless
diff --git a/sysutils/usermin/Makefile b/sysutils/usermin/Makefile
index 8a59cdc074e1..9d8922d673e9 100644
--- a/sysutils/usermin/Makefile
+++ b/sysutils/usermin/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
p5-Authen-PAM>=0:${PORTSDIR}/security/p5-Authen-PAM
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
USE_RC_SUBR= usermin
SUB_LIST= PERL5=${PERL}
SUB_FILES= pkg-message
diff --git a/sysutils/worldtools/Makefile b/sysutils/worldtools/Makefile
index 1fca2a77252c..b4b8760635ce 100644
--- a/sysutils/worldtools/Makefile
+++ b/sysutils/worldtools/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://anarcat.ath.cx/software/distfiles/
MAINTAINER= anarcat@anarcat.ath.cx
COMMENT= Handy tools for living with make world
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
MAN8= buildit.8 upgrade.8 whereintheworld.8
diff --git a/x11-themes/fvwm-themes/Makefile b/x11-themes/fvwm-themes/Makefile
index 331af375d0e1..ffd19ea2cc55 100644
--- a/x11-themes/fvwm-themes/Makefile
+++ b/x11-themes/fvwm-themes/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= fvwm2:${PORTSDIR}/x11-wm/fvwm2
USE_BZIP2= yes
USE_XORG= xpm
USE_GMAKE= yes
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
MAN1= fvwm-themes-config.1 fvwm-themes-menuapp.1 fvwm-themes-com.1 \