aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-10-02 13:38:59 +0000
committerStefan Eßer <se@FreeBSD.org>2020-10-02 13:38:59 +0000
commit707f559724d669d19fab3ac779fa9dcc497aefc4 (patch)
tree9d36feeb8365b0e53150afe05bb9944c20b09459
parent122674f6ff38d9bae26c91d630d25ea1f77ca30f (diff)
downloadports-707f559724d669d19fab3ac779fa9dcc497aefc4.tar.gz
ports-707f559724d669d19fab3ac779fa9dcc497aefc4.zip
Notes
-rw-r--r--net-mgmt/portmon/Makefile7
-rw-r--r--net-mgmt/portmon/files/patch-extras_portmon.8 (renamed from net-mgmt/portmon/files/patch-extras__portmon.8)4
-rw-r--r--net-mgmt/portmon/files/patch-src_portmon.c21
-rw-r--r--net-mgmt/portmon/files/patch-src_portmon.h37
4 files changed, 64 insertions, 5 deletions
diff --git a/net-mgmt/portmon/Makefile b/net-mgmt/portmon/Makefile
index 92a58231cfe4..e8e6d49cae23 100644
--- a/net-mgmt/portmon/Makefile
+++ b/net-mgmt/portmon/Makefile
@@ -3,6 +3,7 @@
PORTNAME= portmon
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://voodoo.bawue.com/download/ \
http://www.aboleo.net/software/portmon/downloads/ \
@@ -16,12 +17,12 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
+PLIST_FILES= bin/portmon etc/portmon.hosts.sample share/man/man8/portmon.8.gz
PORTDOCS= README
-PLIST_FILES= bin/portmon etc/portmon.hosts.sample man/man8/portmon.8.gz
OPTIONS_DEFINE= DOCS
-post-patch:
+post-build:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
${WRKSRC}/extras/${PORTNAME}.8
@@ -29,7 +30,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/extras/portmon.8 \
- ${STAGEDIR}${PREFIX}/man/man8
+ ${STAGEDIR}${MAN8PREFIX}/share/man/man8
${INSTALL_DATA} ${WRKSRC}/extras/portmon.hosts.sample \
${STAGEDIR}${PREFIX}/etc
diff --git a/net-mgmt/portmon/files/patch-extras__portmon.8 b/net-mgmt/portmon/files/patch-extras_portmon.8
index 08e061425b9c..614d9ffd1e99 100644
--- a/net-mgmt/portmon/files/patch-extras__portmon.8
+++ b/net-mgmt/portmon/files/patch-extras_portmon.8
@@ -1,5 +1,5 @@
---- extras/portmon.8.orig Sun Aug 24 10:08:43 2003
-+++ extras/portmon.8 Sun Aug 24 10:09:06 2003
+--- extras/portmon.8.orig 2003-08-24 07:11:14 UTC
++++ extras/portmon.8
@@ -1,6 +1,6 @@
.\" manpage for portmon
.\" by Nik Reiman, <nik@aboleo.net>
diff --git a/net-mgmt/portmon/files/patch-src_portmon.c b/net-mgmt/portmon/files/patch-src_portmon.c
new file mode 100644
index 000000000000..2c4db8f2d6ed
--- /dev/null
+++ b/net-mgmt/portmon/files/patch-src_portmon.c
@@ -0,0 +1,21 @@
+--- src/portmon.c.orig 2003-08-23 06:01:10 UTC
++++ src/portmon.c
+@@ -35,6 +35,18 @@
+ #include <getopt.h>
+ #endif
+
++int report_flag;
++int daemonize_flag;
++
++struct host_struct *hosts;
++
++char *err_msg;
++char logfile[STRLARGE];
++int timeout;
++int verbose;
++
++
++
+ void version(void)
+ {
+ printf("This is %s, version %s\n", PACKAGE, VERSION);
diff --git a/net-mgmt/portmon/files/patch-src_portmon.h b/net-mgmt/portmon/files/patch-src_portmon.h
new file mode 100644
index 000000000000..9b1c2a5c41ec
--- /dev/null
+++ b/net-mgmt/portmon/files/patch-src_portmon.h
@@ -0,0 +1,37 @@
+--- src/portmon.h.orig 2003-08-23 06:04:38 UTC
++++ src/portmon.h
+@@ -31,8 +31,8 @@
+ #define STRLARGE 512
+
+ // flags
+-int report_flag;
+-int daemonize_flag;
++extern int report_flag;
++extern int daemonize_flag;
+
+ struct port
+ {
+@@ -48,17 +48,17 @@ struct host_struct
+ char name[STRMED];
+ struct port ports[STRSMALL];
+ int num_ports;
+-}
+- *hosts;
++};
++extern struct host_struct *hosts;
+
+ // place to hold error messages
+-char *err_msg;
++extern char *err_msg;
+ // place we log crap
+-char logfile[STRLARGE];
++extern char logfile[STRLARGE];
+ // timeout (seconds)
+-int timeout;
++extern int timeout;
+ // verbose mode
+-int verbose;
++extern int verbose;
+
+ // Functions in various files
+